summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-12-02 15:49:59 +0100
committerDavid Seifert <soap@gentoo.org>2017-12-02 17:14:26 +0100
commited24ab01691c2d03fc21562f78b6a05e71803d62 (patch)
tree8cec67bfabf8dadf6bde893c0456aff707467d30 /sys-apps/utempter/files
parentsys-apps/vbetool: Port to EAPI 6 (diff)
downloadgentoo-ed24ab01691c2d03fc21562f78b6a05e71803d62.tar.gz
gentoo-ed24ab01691c2d03fc21562f78b6a05e71803d62.tar.bz2
gentoo-ed24ab01691c2d03fc21562f78b6a05e71803d62.zip
sys-apps/utempter: Port to EAPI 6
Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'sys-apps/utempter/files')
-rw-r--r--sys-apps/utempter/files/utempter-0.5.5.6-build.patch11
-rw-r--r--sys-apps/utempter/files/utempter-0.5.5.6-fix-build-system.patch (renamed from sys-apps/utempter/files/utempter-0.5.5.6-soname-makefile-fix.patch)29
-rw-r--r--sys-apps/utempter/files/utempter-0.5.5.6-no_utmpx.patch4
3 files changed, 26 insertions, 18 deletions
diff --git a/sys-apps/utempter/files/utempter-0.5.5.6-build.patch b/sys-apps/utempter/files/utempter-0.5.5.6-build.patch
deleted file mode 100644
index 8fbfb111196f..000000000000
--- a/sys-apps/utempter/files/utempter-0.5.5.6-build.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile
-+++ Makefile
-@@ -37,7 +37,7 @@
- ln -sf $(SHAREDLIB).$(VERSION) $(RPM_BUILD_ROOT)/$(LIBDIR)/$(SHAREDLIB).$(SOMAJOR)
-
- $(SHAREDLIB): utmpintf.os
-- $(CC) -o $@ -shared -Wl,-soname,$(SONAME) $^ -lc
-+ $(CC) $(LDFLAGS) -o $@ -shared -Wl,-soname,$(SONAME) $^ -lc
-
- utmpintf.o: utmpintf.c utempter.h
-
diff --git a/sys-apps/utempter/files/utempter-0.5.5.6-soname-makefile-fix.patch b/sys-apps/utempter/files/utempter-0.5.5.6-fix-build-system.patch
index 123c77eb357c..83b41a04b25f 100644
--- a/sys-apps/utempter/files/utempter-0.5.5.6-soname-makefile-fix.patch
+++ b/sys-apps/utempter/files/utempter-0.5.5.6-fix-build-system.patch
@@ -1,6 +1,6 @@
---- Makefile.orig 2005-04-15 08:54:32.000000000 -0400
-+++ Makefile 2005-04-15 08:56:17.000000000 -0400
-@@ -5,6 +5,10 @@
+--- a/Makefile
++++ b/Makefile
+@@ -5,12 +5,14 @@
CVSROOT=$(shell cat CVS/Root)
# major number of the .so lib
SOMAJOR = 0
@@ -11,7 +11,22 @@
SHAREDLIB = lib$(NAME).so
SONAME = $(SHAREDLIB).$(SOMAJOR)
-@@ -29,6 +33,8 @@
+
+-CFLAGS = -Wall $(RPM_OPT_FLAGS)
+-
+ TARGETS = $(NAME) utmp $(SHAREDLIB)
+
+ all: $(TARGETS)
+@@ -19,7 +21,7 @@
+ rm -f *.so utempter utmp *.os
+
+ %.os : %.c
+- $(CC) -c $(CFLAGS) -fPIC $< -o $@
++ $(CC) -c $(CFLAGS) $(CPPFLAGS) -fPIC $< -o $@
+
+ install:
+ mkdir -p $(RPM_BUILD_ROOT)/usr/sbin
+@@ -29,9 +31,11 @@
install -m 644 utempter.h $(RPM_BUILD_ROOT)/usr/include
install -m 644 $(SHAREDLIB) $(RPM_BUILD_ROOT)/$(LIBDIR)/$(SHAREDLIB).$(VERSION)
ln -sf $(SHAREDLIB).$(VERSION) $(RPM_BUILD_ROOT)/$(LIBDIR)/$(SHAREDLIB)
@@ -19,4 +34,8 @@
+ ln -sf $(SHAREDLIB).$(VERSION) $(RPM_BUILD_ROOT)/$(LIBDIR)/$(SHAREDLIB).$(SOMAJOR)
$(SHAREDLIB): utmpintf.os
- $(CC) -o $@ -shared -Wl,-soname,$(SONAME) $^ -lc
+- $(CC) -o $@ -shared -Wl,-soname,$(SONAME) $^ -lc
++ $(CC) $(LDFLAGS) -o $@ -shared -Wl,-soname,$(SONAME) $^ -lc $(LIBS)
+
+ utmpintf.o: utmpintf.c utempter.h
+
diff --git a/sys-apps/utempter/files/utempter-0.5.5.6-no_utmpx.patch b/sys-apps/utempter/files/utempter-0.5.5.6-no_utmpx.patch
index 8644db837f4a..b6fc7ea7d27e 100644
--- a/sys-apps/utempter/files/utempter-0.5.5.6-no_utmpx.patch
+++ b/sys-apps/utempter/files/utempter-0.5.5.6-no_utmpx.patch
@@ -1,5 +1,5 @@
---- utempter-0.5.5/utempter.c.mps 2004-12-11 14:54:06.000000000 +0100
-+++ utempter-0.5.5/utempter.c 2004-12-11 14:57:46.000000000 +0100
+--- a/utempter.c
++++ b/utempter.c
@@ -11,7 +11,9 @@
#include <sys/stat.h>
#include <sys/sysmacros.h>