summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2023-10-01 15:10:31 -0400
committerMike Gilbert <floppym@gentoo.org>2023-10-01 15:12:32 -0400
commita5e63255fc09e019665714b82053187abbef82dc (patch)
treea78dc950431f7cc516d5a4903052055df0ac6de1 /sys-apps/systemd-utils
parentsys-apps/systemd-utils: install libudev man pages (diff)
downloadgentoo-a5e63255fc09e019665714b82053187abbef82dc.tar.gz
gentoo-a5e63255fc09e019665714b82053187abbef82dc.tar.bz2
gentoo-a5e63255fc09e019665714b82053187abbef82dc.zip
sys-apps/systemd-utils: install man pages for native ABI only
Bug: https://bugs.gentoo.org/915011 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-apps/systemd-utils')
-rw-r--r--sys-apps/systemd-utils/systemd-utils-253.11-r1.ebuild28
-rw-r--r--sys-apps/systemd-utils/systemd-utils-253.12-r1.ebuild28
-rw-r--r--sys-apps/systemd-utils/systemd-utils-254.5-r1.ebuild28
3 files changed, 42 insertions, 42 deletions
diff --git a/sys-apps/systemd-utils/systemd-utils-253.11-r1.ebuild b/sys-apps/systemd-utils/systemd-utils-253.11-r1.ebuild
index de6425e32cf7..7499ad4455ec 100644
--- a/sys-apps/systemd-utils/systemd-utils-253.11-r1.ebuild
+++ b/sys-apps/systemd-utils/systemd-utils-253.11-r1.ebuild
@@ -323,6 +323,18 @@ multilib_src_compile() {
man/systemd-hwdb.8
man/systemd-udevd.service.8
man/udevadm.8
+ man/libudev.3
+ man/udev_device_get_syspath.3
+ man/udev_device_has_tag.3
+ man/udev_device_new_from_syspath.3
+ man/udev_enumerate_add_match_subsystem.3
+ man/udev_enumerate_new.3
+ man/udev_enumerate_scan_devices.3
+ man/udev_list_entry.3
+ man/udev_monitor_filter_update.3
+ man/udev_monitor_new_from_netlink.3
+ man/udev_monitor_receive_device.3
+ man/udev_new.3
hwdb.d/60-autosuspend-chromiumos.hwdb
rules.d/50-udev-default.rules
rules.d/64-btrfs.rules
@@ -347,18 +359,6 @@ multilib_src_compile() {
targets+=(
udev:shared_library
src/libudev/libudev.pc
- man/libudev.3
- man/udev_device_get_syspath.3
- man/udev_device_has_tag.3
- man/udev_device_new_from_syspath.3
- man/udev_enumerate_add_match_subsystem.3
- man/udev_enumerate_new.3
- man/udev_enumerate_scan_devices.3
- man/udev_list_entry.3
- man/udev_monitor_filter_update.3
- man/udev_monitor_new_from_netlink.3
- man/udev_monitor_receive_device.3
- man/udev_new.3
)
if use test; then
targets+=(
@@ -463,6 +463,8 @@ multilib_src_install() {
doman man/{udev.conf.5,systemd.link.5,hwdb.7,systemd-hwdb.8,udev.7,udevadm.8}
newman man/systemd-udevd.service.8 systemd-udevd.8
+ doman man/libudev.3
+ doman man/udev_*.3
fi
fi
if use udev; then
@@ -470,8 +472,6 @@ multilib_src_install() {
gen_usr_ldscript -a udev
insinto "/usr/$(get_libdir)/pkgconfig"
doins src/libudev/libudev.pc
- doman man/libudev.3
- doman man/udev_*.3
fi
}
diff --git a/sys-apps/systemd-utils/systemd-utils-253.12-r1.ebuild b/sys-apps/systemd-utils/systemd-utils-253.12-r1.ebuild
index 16e6b7cebd76..636ecc7b503e 100644
--- a/sys-apps/systemd-utils/systemd-utils-253.12-r1.ebuild
+++ b/sys-apps/systemd-utils/systemd-utils-253.12-r1.ebuild
@@ -323,6 +323,18 @@ multilib_src_compile() {
man/systemd-hwdb.8
man/systemd-udevd.service.8
man/udevadm.8
+ man/libudev.3
+ man/udev_device_get_syspath.3
+ man/udev_device_has_tag.3
+ man/udev_device_new_from_syspath.3
+ man/udev_enumerate_add_match_subsystem.3
+ man/udev_enumerate_new.3
+ man/udev_enumerate_scan_devices.3
+ man/udev_list_entry.3
+ man/udev_monitor_filter_update.3
+ man/udev_monitor_new_from_netlink.3
+ man/udev_monitor_receive_device.3
+ man/udev_new.3
hwdb.d/60-autosuspend-chromiumos.hwdb
rules.d/50-udev-default.rules
rules.d/64-btrfs.rules
@@ -347,18 +359,6 @@ multilib_src_compile() {
targets+=(
udev:shared_library
src/libudev/libudev.pc
- man/libudev.3
- man/udev_device_get_syspath.3
- man/udev_device_has_tag.3
- man/udev_device_new_from_syspath.3
- man/udev_enumerate_add_match_subsystem.3
- man/udev_enumerate_new.3
- man/udev_enumerate_scan_devices.3
- man/udev_list_entry.3
- man/udev_monitor_filter_update.3
- man/udev_monitor_new_from_netlink.3
- man/udev_monitor_receive_device.3
- man/udev_new.3
)
if use test; then
targets+=(
@@ -463,6 +463,8 @@ multilib_src_install() {
doman man/{udev.conf.5,systemd.link.5,hwdb.7,systemd-hwdb.8,udev.7,udevadm.8}
newman man/systemd-udevd.service.8 systemd-udevd.8
+ doman man/libudev.3
+ doman man/udev_*.3
fi
fi
if use udev; then
@@ -470,8 +472,6 @@ multilib_src_install() {
gen_usr_ldscript -a udev
insinto "/usr/$(get_libdir)/pkgconfig"
doins src/libudev/libudev.pc
- doman man/libudev.3
- doman man/udev_*.3
fi
}
diff --git a/sys-apps/systemd-utils/systemd-utils-254.5-r1.ebuild b/sys-apps/systemd-utils/systemd-utils-254.5-r1.ebuild
index 78bd97986039..acd85797cc65 100644
--- a/sys-apps/systemd-utils/systemd-utils-254.5-r1.ebuild
+++ b/sys-apps/systemd-utils/systemd-utils-254.5-r1.ebuild
@@ -331,6 +331,18 @@ multilib_src_compile() {
man/systemd-hwdb.8
man/systemd-udevd.service.8
man/udevadm.8
+ man/libudev.3
+ man/udev_device_get_syspath.3
+ man/udev_device_has_tag.3
+ man/udev_device_new_from_syspath.3
+ man/udev_enumerate_add_match_subsystem.3
+ man/udev_enumerate_new.3
+ man/udev_enumerate_scan_devices.3
+ man/udev_list_entry.3
+ man/udev_monitor_filter_update.3
+ man/udev_monitor_new_from_netlink.3
+ man/udev_monitor_receive_device.3
+ man/udev_new.3
hwdb.d/60-autosuspend-chromiumos.hwdb
rules.d/50-udev-default.rules
rules.d/60-persistent-storage.rules
@@ -352,18 +364,6 @@ multilib_src_compile() {
targets+=(
udev:shared_library
src/libudev/libudev.pc
- man/libudev.3
- man/udev_device_get_syspath.3
- man/udev_device_has_tag.3
- man/udev_device_new_from_syspath.3
- man/udev_enumerate_add_match_subsystem.3
- man/udev_enumerate_new.3
- man/udev_enumerate_scan_devices.3
- man/udev_list_entry.3
- man/udev_monitor_filter_update.3
- man/udev_monitor_new_from_netlink.3
- man/udev_monitor_receive_device.3
- man/udev_new.3
)
if use test; then
targets+=(
@@ -465,6 +465,8 @@ multilib_src_install() {
doman man/{udev.conf.5,systemd.link.5,hwdb.7,systemd-hwdb.8,udev.7,udevadm.8}
newman man/systemd-udevd.service.8 systemd-udevd.8
+ doman man/libudev.3
+ doman man/udev_*.3
fi
fi
if use udev; then
@@ -472,8 +474,6 @@ multilib_src_install() {
gen_usr_ldscript -a udev
insinto "/usr/$(get_libdir)/pkgconfig"
doins src/libudev/libudev.pc
- doman man/libudev.3
- doman man/udev_*.3
fi
}