summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-02-24 14:27:03 +0100
committerLars Wendler <polynomial-c@gentoo.org>2016-02-24 14:28:20 +0100
commit089092201f23a666ce7e8472831972034b50bbce (patch)
tree2849e8c7f87997b94712dd724a8715514f6e8b87 /sys-apps/sdparm/sdparm-1.10.ebuild
parentdev-dotnet/libgdiplus: correct giflib dep (diff)
downloadgentoo-089092201f23a666ce7e8472831972034b50bbce.tar.gz
gentoo-089092201f23a666ce7e8472831972034b50bbce.tar.bz2
gentoo-089092201f23a666ce7e8472831972034b50bbce.zip
sys-apps/sdparm: Bump to version 1.10
Package-Manager: portage-2.2.27 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-apps/sdparm/sdparm-1.10.ebuild')
-rw-r--r--sys-apps/sdparm/sdparm-1.10.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-apps/sdparm/sdparm-1.10.ebuild b/sys-apps/sdparm/sdparm-1.10.ebuild
new file mode 100644
index 000000000000..057cd7472f0f
--- /dev/null
+++ b/sys-apps/sdparm/sdparm-1.10.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Utility to output and modify parameters on a SCSI device, like hdparm"
+HOMEPAGE="http://sg.danny.cz/sg/sdparm.html"
+SRC_URI="http://sg.danny.cz/sg/p/${P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~arm-linux ~x86-linux"
+IUSE=""
+
+# Older releases contain a conflicting sas_disk_blink
+RDEPEND=">=sys-apps/sg3_utils-1.39"
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS ChangeLog CREDITS README notes.txt )
+
+src_configure() {
+ # sdparm ships with a local copy of this lib, but will use the system copy if it
+ # detects it (see the README file). Force the use of the system lib. #479578
+ export ac_cv_lib_sgutils2_sg_ll_inquiry=yes
+ default
+}
+
+src_install() {
+ default
+
+ # These don't exist yet. Someone wanna copy hdparm's and make them work? :)
+ #newinitd ${FILESDIR}/sdparm-init-1 sdparm
+ #newconfd ${FILESDIR}/sdparm-conf.d-1 sdparm
+}