summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@atlas.cz>2022-06-14 23:09:07 +0200
committerSam James <sam@gentoo.org>2022-06-25 06:35:12 +0100
commit53c83c8af6130f233d4af428644bc98c6ff3cdb2 (patch)
treea520bb627c7b108b16f1794f8209d38491824918 /sys-apps/s6
parentdev-lang/execline: add 2.9.0.0 (diff)
downloadgentoo-53c83c8af6130f233d4af428644bc98c6ff3cdb2.tar.gz
gentoo-53c83c8af6130f233d4af428644bc98c6ff3cdb2.tar.bz2
gentoo-53c83c8af6130f233d4af428644bc98c6ff3cdb2.zip
sys-apps/s6: add 2.11.1.1
Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/s6')
-rw-r--r--sys-apps/s6/Manifest1
-rw-r--r--sys-apps/s6/s6-2.11.1.1.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/sys-apps/s6/Manifest b/sys-apps/s6/Manifest
index a9f6ac81ca9e..6eaa14d7d718 100644
--- a/sys-apps/s6/Manifest
+++ b/sys-apps/s6/Manifest
@@ -1 +1,2 @@
DIST s6-2.11.1.0.tar.gz 228745 BLAKE2B 872ac1f736337a8e6617c46af92f8e894c06a4b40501ebf58568dc6a58cb594fdf36654cdb8cfd8e922431c17f9b4f82441296a3ce8031ba8b1f27fa1ba8a051 SHA512 ab3cb4a61fae21537eacffdaa427a0a6b23b12088586f0cd8dc993e0de29e9863d04c8706cb044acdc08254002b19eb5f894262d37348d467f8c713d8124e738
+DIST s6-2.11.1.1.tar.gz 228878 BLAKE2B c94c18b66862c7945a317ab76d933d40fc360847b71c6fb3d507535ee41637d60327a05486a93ab7aec630a0c8ead61d6c17bfc064bd9f94b39a7cc56f76cb49 SHA512 f5fc903c11b57b2a83d9e120a51f64b63984a2af9b772dd6fd64f268b512a083350abedcae04c926deb6751b5ae30e992d6a4128ddf4ab1d49c548ef8f3d7752
diff --git a/sys-apps/s6/s6-2.11.1.1.ebuild b/sys-apps/s6/s6-2.11.1.1.ebuild
new file mode 100644
index 000000000000..ba06fd3ede5b
--- /dev/null
+++ b/sys-apps/s6/s6-2.11.1.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="skarnet.org's small and secure supervision software suite"
+HOMEPAGE="https://www.skarnet.org/software/s6/"
+SRC_URI="https://www.skarnet.org/software/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+execline static static-libs"
+
+REQUIRED_USE="static? ( static-libs )"
+
+RDEPEND="dev-libs/skalibs:=[static-libs?]
+ execline? ( dev-lang/execline:=[static-libs?] )
+"
+DEPEND="${RDEPEND}"
+
+HTML_DOCS=( doc/. )
+
+src_prepare() {
+ default
+
+ # Avoid QA warning for LDFLAGS addition
+ sed -i -e 's/.*-Wl,--hash-style=both$/:/' configure || die
+
+ sed -i -e '/AR := /d' -e '/RANLIB := /d' Makefile || die
+}
+
+src_configure() {
+ tc-export AR CC RANLIB
+
+ local myconf=(
+ --bindir=/bin
+ --dynlibdir=/usr/$(get_libdir)
+ --libdir=/usr/$(get_libdir)/${PN}
+ --with-dynlib=/usr/$(get_libdir)
+ --with-lib=/usr/$(get_libdir)/execline
+ --with-lib=/usr/$(get_libdir)/skalibs
+ --with-sysdeps=/usr/$(get_libdir)/skalibs
+ --enable-shared
+ $(use_enable static allstatic)
+ $(use_enable static static-libc)
+ $(use_enable static-libs static)
+ $(use_enable execline)
+ )
+
+ econf "${myconf[@]}"
+}