summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2016-06-22 23:08:25 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2016-06-22 23:08:37 +0100
commit5c6b402ab1dbd4c2ec912597536a2b5f4d52f43b (patch)
tree0d28ef06c1b658dcba0111b89c729ca181745062 /sys-apps/prctl/prctl-1.6.ebuild
parentprofiles: Update l10n.desc. (diff)
downloadgentoo-5c6b402ab1dbd4c2ec912597536a2b5f4d52f43b.tar.gz
gentoo-5c6b402ab1dbd4c2ec912597536a2b5f4d52f43b.tar.bz2
gentoo-5c6b402ab1dbd4c2ec912597536a2b5f4d52f43b.zip
sys-apps/prctl: bump up to 1.6, keyworded for x86 and amd64
Has got new mcekill knob, useful on x86/amd64 family. Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'sys-apps/prctl/prctl-1.6.ebuild')
-rw-r--r--sys-apps/prctl/prctl-1.6.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sys-apps/prctl/prctl-1.6.ebuild b/sys-apps/prctl/prctl-1.6.ebuild
new file mode 100644
index 000000000000..f20ddd743f29
--- /dev/null
+++ b/sys-apps/prctl/prctl-1.6.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit toolchain-funcs
+
+DESCRIPTION="Tool to query and modify process behavior"
+HOMEPAGE="http://sourceforge.net/projects/prctl/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="sys-apps/groff"
+
+PATCHES=("${FILESDIR}"/${P}-no-implicits.patch)
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin prctl
+ doman prctl.1
+ dodoc ChangeLog
+}