summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-11-05 22:53:02 +0000
committerSam James <sam@gentoo.org>2022-11-06 01:49:31 +0000
commit6e16406ce46083d05de45dcdd50edc445b3098ab (patch)
tree6559caaebd7d0502b34c21f1a689fda6b84edf31 /sys-apps/man2html
parentapp-i18n/unicode-cldr: new upstream release (diff)
downloadgentoo-6e16406ce46083d05de45dcdd50edc445b3098ab.tar.gz
gentoo-6e16406ce46083d05de45dcdd50edc445b3098ab.tar.bz2
gentoo-6e16406ce46083d05de45dcdd50edc445b3098ab.zip
sys-apps/man2html: further Clang 15 configure fixes
Fixes: 49e4d668bc441ec4db407b51edeab5af14b798af Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/man2html')
-rw-r--r--sys-apps/man2html/files/man-1.6g-clang-15-configure.patch24
-rw-r--r--sys-apps/man2html/man2html-1.6g-r2.ebuild (renamed from sys-apps/man2html/man2html-1.6g-r1.ebuild)0
2 files changed, 13 insertions, 11 deletions
diff --git a/sys-apps/man2html/files/man-1.6g-clang-15-configure.patch b/sys-apps/man2html/files/man-1.6g-clang-15-configure.patch
index 783693059e2f..c15617b56e84 100644
--- a/sys-apps/man2html/files/man-1.6g-clang-15-configure.patch
+++ b/sys-apps/man2html/files/man-1.6g-clang-15-configure.patch
@@ -5,7 +5,7 @@
echo "#include <stdlib.h>
#include <string.h>
-main() { exit(0); strerror(0); }" > conftest.c
-+int main() { exit(0); strerror(0); }" > conftest.c
++int main(void) { exit(0); strerror(0); }" > conftest.c
eval $compile
if test -s conftest && ./conftest 2>/dev/null; then
DEFS="$DEFS -DSTDC_HEADERS"
@@ -15,7 +15,7 @@
echo "#include <sys/termios.h>
-main() { exit(0); }" > conftest.c
+#include <stdlib.h>
-+int main() { exit(0); }" > conftest.c
++int main(void) { exit(0); }" > conftest.c
eval $compile
if test -s conftest && ./conftest 2>/dev/null; then
DEFS="$DEFS -DTERMIOS_HEADER"
@@ -26,7 +26,7 @@
+#include <stdlib.h>
#ifdef _POSIX_VERSION
-main() { exit(0); }
-+int main() { exit(0); }
++int main(void) { exit(0); }
#else
# error no _POSIX_VERSION
#endif" > conftest.c
@@ -36,7 +36,7 @@
echo "#include <strings.h>
-main() { exit(0); rindex(0, 0); bzero(0, 0); }" > conftest.c
+#include <stdlib.h>
-+int main() { exit(0); rindex(0, 0); bzero(0, 0); }" > conftest.c
++int main(void) { exit(0); rindex(0, 0); bzero(0, 0); }" > conftest.c
eval $compile
if test -s conftest ; then :
else DEFS="$DEFS -DUSG"
@@ -46,36 +46,38 @@
echo '#include <sys/types.h>
-main() { uid_t x; exit(0); }' > conftest.c
+#include <stdlib.h>
-+int main() { uid_t x; exit(0); }' > conftest.c
++int main(void) { uid_t x; exit(0); }' > conftest.c
eval $compile
if test -s conftest ; then :
else
-@@ -300,7 +304,7 @@ char *alloca ();
+@@ -300,7 +304,8 @@ char *alloca ();
#endif
#endif
#endif
-main() { char *p = (char *) alloca(1); exit(0); }' > conftest.c
-+int main() { char *p = (char *) alloca(1); exit(0); }' > conftest.c
++#include <stdlib.h>
++int main(void) { char *p = (char *) alloca(1); exit(0); }' > conftest.c
eval $compile
if test -s conftest ; then :
elif test -d /usr/ucblib; then LIBS="$LIBS -L/usr/ucblib -lucb"
-@@ -312,7 +316,7 @@ rm -f conftest conftest.c
+@@ -312,7 +317,8 @@ rm -f conftest conftest.c
if [ $usenls = true ]; then
echo checking for nls
echo '#include <nl_types.h>
- main() {nl_catd catfd; exit(0); }' > conftest.c
-+ int main() {nl_catd catfd; exit(0); }' > conftest.c
++ #include <stdlib.h>
++ int main(void) {nl_catd catfd; exit(0); }' > conftest.c
eval $compile
if test -s conftest && ./conftest 2>/dev/null; then :
else
-@@ -329,8 +333,9 @@ echo checking for getopt.h
+@@ -329,8 +335,9 @@ echo checking for getopt.h
echo '#define _GNU_SOURCE
#include <getopt.h>
#include <stdio.h>
+#include <stdlib.h>
struct option long_opts[] = { { "", no_argument, NULL, 0 } };
-main() { exit(0); }' > conftest.c
-+int main() { exit(0); }' > conftest.c
++int main(void) { exit(0); }' > conftest.c
eval $compile
if test -s conftest ; then
manpathoption="--path"
diff --git a/sys-apps/man2html/man2html-1.6g-r1.ebuild b/sys-apps/man2html/man2html-1.6g-r2.ebuild
index e9d4766f3b43..e9d4766f3b43 100644
--- a/sys-apps/man2html/man2html-1.6g-r1.ebuild
+++ b/sys-apps/man2html/man2html-1.6g-r2.ebuild