summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Stein <jstein@gentoo.org>2023-08-26 10:13:05 +0200
committerJonas Stein <jstein@gentoo.org>2023-08-26 10:13:05 +0200
commitbda2670792861734fa7d7d34e95051077c1eb222 (patch)
treefffac671ec591527f205cae2844b9a543a461371 /sys-apps/inxi
parentdev-ruby/bundler: add 2.4.19 (diff)
downloadgentoo-bda2670792861734fa7d7d34e95051077c1eb222.tar.gz
gentoo-bda2670792861734fa7d7d34e95051077c1eb222.tar.bz2
gentoo-bda2670792861734fa7d7d34e95051077c1eb222.zip
sys-apps/inxi: add 3.3.29.1
Signed-off-by: Jonas Stein <jstein@gentoo.org>
Diffstat (limited to 'sys-apps/inxi')
-rw-r--r--sys-apps/inxi/Manifest1
-rw-r--r--sys-apps/inxi/inxi-3.3.29.1.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/sys-apps/inxi/Manifest b/sys-apps/inxi/Manifest
index c073de43f52f..593fff1cd72a 100644
--- a/sys-apps/inxi/Manifest
+++ b/sys-apps/inxi/Manifest
@@ -1,2 +1,3 @@
DIST inxi-3.3.27.1.tar.gz 614167 BLAKE2B 1a312255340bfe361eb10dd725cc9fb1421d8dfda34ee944347278e4a293cbcb51d1e2b7aa00f26c16286b90f26d3e0f91f68fb4beeb112ecd8f7a3bc86680ff SHA512 f21285d709d8dc7ce393a6c3b43b5ebabb8ef2c55adf43f00935b728a28f502bbcbd8c1482249e872e4623430f01b4e8cf51f0a6790d56fb12147fa125152575
DIST inxi-3.3.28.1.tar.gz 624472 BLAKE2B 3d8ac9c21a7531e694e5de3a764906a69ef0c869f1bb4b7b5e5d0b42a74240a141c97401dfe78a85da27e7489d708fbfc4eb568adaab5270388aebd108f29e1a SHA512 6360193cc1f7a71c7329352311fac625e6c80e37c2bd783a78a534ec9712afd7df17b445c652d97415f6162512ede34b32958311b1c5086e899a2aded7a8efd9
+DIST inxi-3.3.29.1.tar.gz 630296 BLAKE2B 176b20b113b3339f27d2ec16681d652e8ccaefed80c220078fa4e625ad7191cd6ebc9ada049197a858475e5c656b5f74f599ca202e1e47d6682e4cd9049eb763 SHA512 09b5a7553ccfd42a3c2e58d4718c487f84bf22df76710a6c42a2a4dd08343279f1d2523652a476ed475c5e019ad5aa02c0886bc40d57de407c9489054f812b5c
diff --git a/sys-apps/inxi/inxi-3.3.29.1.ebuild b/sys-apps/inxi/inxi-3.3.29.1.ebuild
new file mode 100644
index 000000000000..1b3918e6aebe
--- /dev/null
+++ b/sys-apps/inxi/inxi-3.3.29.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PV=$(ver_rs 3 '-')
+# 2.3.56 was the last version with no tagged release.
+# It was also the last Bash based release. Later versions are Perl based
+
+DESCRIPTION="The CLI inxi collects and prints hardware and system information"
+HOMEPAGE="https://github.com/smxi/inxi"
+SRC_URI="https://github.com/smxi/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="bluetooth hddtemp opengl"
+
+RDEPEND="dev-lang/perl
+ sys-apps/pciutils
+ sys-apps/usbutils
+ bluetooth? ( net-wireless/bluez )
+ hddtemp? ( app-admin/hddtemp )
+ opengl? ( x11-apps/mesa-progs )
+ "
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+ dodoc README.txt
+}