summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Stein <jstein@gentoo.org>2024-06-19 23:10:50 +0200
committerJonas Stein <jstein@gentoo.org>2024-06-19 23:10:50 +0200
commit87c16b9a4f171cb33eebdee1abc45a673e86fb5d (patch)
tree2e5e528cc75938fbc08e521d6d4cc4e411d7b15d /sys-apps/inxi
parentdev-lang/pico8: Bump to 0.2.6b, drop old 0.2.5g (diff)
downloadgentoo-87c16b9a4f171cb33eebdee1abc45a673e86fb5d.tar.gz
gentoo-87c16b9a4f171cb33eebdee1abc45a673e86fb5d.tar.bz2
gentoo-87c16b9a4f171cb33eebdee1abc45a673e86fb5d.zip
sys-apps/inxi: add 3.3.35.1
Signed-off-by: Jonas Stein <jstein@gentoo.org>
Diffstat (limited to 'sys-apps/inxi')
-rw-r--r--sys-apps/inxi/Manifest1
-rw-r--r--sys-apps/inxi/inxi-3.3.35.1.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/sys-apps/inxi/Manifest b/sys-apps/inxi/Manifest
index fce8408fd373..f5d9840bc1fc 100644
--- a/sys-apps/inxi/Manifest
+++ b/sys-apps/inxi/Manifest
@@ -2,3 +2,4 @@ DIST inxi-3.3.27.1.tar.gz 614167 BLAKE2B 1a312255340bfe361eb10dd725cc9fb1421d8df
DIST inxi-3.3.30.1.tar.gz 643283 BLAKE2B cfcafc643e7e18261fac622df3614e7ad296ec2233ebf6750243d9490e0ca5e8ba3742286a0630ae948d16ac4d09705ffc1b20df666f48ed2c5331a8320919d7 SHA512 dba5c23d991bd6fb34eec9c2b6107da4e0ddab202f97e8aa53efb25d446fbe77f5250a9d14f543014f21d2cc614cd4e2d486a9f1fae78dde37ecee418cb763f5
DIST inxi-3.3.33.1.tar.gz 679978 BLAKE2B 7445989e64cbb4beb39d6b415230ed70f5b7be90a9b4155104abdb4d57d490ea5ae09cd48871ed3745ba7b719fe4eb49e9706ad168f59245c66f8f576cf022f3 SHA512 7537da7175fe1578a09567e169a309c5258cbb1fd1ae7e58d98df800110cd03333775f8a73f672a5a6a8f0a950123f4f5908a15023648da9150f43464d25be10
DIST inxi-3.3.34.1.tar.gz 683279 BLAKE2B 5693d8add89185fe626f8f6a9e606f7582175402158cd01e30b91779eb289e00d5e8bc71c0d72028b0d5bf1913c040c206c7db83e5fd4639a622dc847d6f1ba9 SHA512 75b21d4ac99383b44d9a2f0f206b3bc612bd2f10fdae44e4b15373090825eea6c7c70250c8f535438d44fc4e938e4ebdb813016cc4a6ab2dbd6d91b6b50adc27
+DIST inxi-3.3.35.1.tar.gz 689546 BLAKE2B 5b383998a110291f02807e2d61f5454a49437bb1dea682ec677ea9e76b5d9fcfb1b1d644700670d71f999ca6fdd100e852d6ab7936309998e6992507b2083c02 SHA512 f71d18c63d7d4dbe4d9d1d6c1dace2527c5ef1c29f58ea08d0d3f09f86c0a7514ec448b3f1f83392d19bd7c64e3718d1ed5f420589a67893ad9b32cc8d0c810c
diff --git a/sys-apps/inxi/inxi-3.3.35.1.ebuild b/sys-apps/inxi/inxi-3.3.35.1.ebuild
new file mode 100644
index 000000000000..990d547acf19
--- /dev/null
+++ b/sys-apps/inxi/inxi-3.3.35.1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PV=$(ver_rs 3 '-')
+
+inherit optfeature
+
+DESCRIPTION="The CLI inxi collects and prints hardware and system information"
+HOMEPAGE="https://codeberg.org/smxi/inxi"
+SRC_URI="https://codeberg.org/smxi/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="dev-lang/perl
+ sys-apps/pciutils
+ "
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+ dodoc README.txt
+}
+
+pkg_postinst() {
+ # All packages are in the same order as displayed by inxi --recommends
+ # including duplicates in order to keep track of changes in the future.
+ optfeature_header "Optional features as suggested by inxi --recommends:"
+
+ optfeature "blockdev: --admin -p/-P (filesystem blocksize)" sys-apps/util-linux
+ optfeature "bt-adapter: -E bluetooth data (if no hciconfig, btmgmt)" net-wireless/bluez-tools
+ optfeature "btmgmt: -E bluetooth data (if no hciconfig)" net-wireless/bluez
+ optfeature "dig: -i wlan IP" net-dns/bind-tools
+ optfeature "dmidecode: -M if no sys machine data; -m" sys-apps/dmidecode
+ optfeature "doas: -Dx hddtemp-user; -o file-user (alt for sudo)" app-admin/doas
+ optfeature "fdisk: -D partition scheme (fallback)" sys-apps/util-linux
+
+ # currently implicit dependency:
+ # optfeature "file: -o unmounted file system (if no lsblk)" sys-apps/file
+ # not packaged yet:
+ # fruid_print: -M machine data, Elbrus only
+
+ optfeature "hciconfig: -E bluetooth data (deprecated, good report)" net-wireless/bluez
+ optfeature "hddtemp: -Dx show hdd temp, if no drivetemp module" app-admin/hddtemp
+ optfeature "ifconfig: -i ip LAN (deprecated)" sys-apps/net-tools
+ optfeature "ip: -i ip LAN" sys-apps/iproute2
+ optfeature "ipmitool: -s IPMI sensors (servers)" sys-apps/ipmitool
+ optfeature "ipmi-sensors: -s IPMI sensors (servers)" sys-libs/freeipmi
+ optfeature "lsblk: -L LUKS/bcache; -o unmounted file system (best option)" sys-apps/util-linux
+ optfeature "lsusb: -A usb audio; -J (optional); -N usb networking" sys-apps/usbutils
+ optfeature "lvs: -L LVM data" sys-fs/lvm2
+ optfeature "mdadm: -Ra advanced mdraid data" sys-fs/mdadm
+ optfeature "modinfo: Ax; -Nx module version" sys-apps/kmod
+ optfeature "runlevel: -I fallback to Perl" sys-apps/sysvinit
+ optfeature "sensors: -s sensors output (optional, /sys supplies most)" sys-apps/lm-sensors
+ optfeature "smartctl: -Da advanced data" sys-apps/smartmontools
+ # TODO optfeature "strings: -I sysvinit version" sys-devel/llvm-toolchain-symlinks
+ optfeature "sudo: -Dx hddtemp-user; -o file-user (try doas!)" app-admin/sudo
+ optfeature "tree: --debugger 20,21 /sys tree" app-text/tree
+ optfeature "udevadm: -m ram data for non-root, or no dmidecode" sys-apps/systemd
+ optfeature "upower: -sx attached device battery info" sys-power/upower
+ optfeature "uptime: -I uptime" sys-process/procps
+ optfeature "eglinfo: -G X11/Wayland EGL info" x11-apps/mesa-progs
+ optfeature "glxinfo: -G X11 GLX info" x11-apps/mesa-progs
+ optfeature "vulkaninfo: -G Vulkan API info" dev-util/vulkan-tools
+ optfeature "wayland-info: -G Wayland data (not for X)" app-misc/wayland-utils
+ optfeature "wmctrl: -S active window manager (fallback)" x11-misc/wmctrl
+ optfeature "xdpyinfo: -G (X) Screen resolution, dpi; -Ga Screen size" x11-apps/xdpyinfo
+ optfeature "xprop: -S (X) desktop data" x11-apps/xprop
+ optfeature "xdriinfo: -G (X) DRI driver (if missing, fallback to Xorg log)" x11-apps/xdriinfo
+ optfeature "xrandr: -G (X) monitors(s) resolution; -Ga monitor data" x11-apps/xrandr
+}