summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-10-17 16:25:47 +0200
committerConrad Kostecki <conikost@gentoo.org>2021-10-17 16:37:54 +0200
commita4b9d4402fc596787d486dea209ca95026be0692 (patch)
tree8a578e5278a141fed774a4fb00324fe020c073d4 /sys-apps/hw-probe
parentdev-libs/intel-compute-runtime: bump to version 21.41.21220 (diff)
downloadgentoo-a4b9d4402fc596787d486dea209ca95026be0692.tar.gz
gentoo-a4b9d4402fc596787d486dea209ca95026be0692.tar.bz2
gentoo-a4b9d4402fc596787d486dea209ca95026be0692.zip
sys-apps/hw-probe: bump to version 1.6
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'sys-apps/hw-probe')
-rw-r--r--sys-apps/hw-probe/Manifest1
-rw-r--r--sys-apps/hw-probe/hw-probe-1.6.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/sys-apps/hw-probe/Manifest b/sys-apps/hw-probe/Manifest
index 92a03dc0b272..cae7c54b2e31 100644
--- a/sys-apps/hw-probe/Manifest
+++ b/sys-apps/hw-probe/Manifest
@@ -1 +1,2 @@
+DIST hw-probe-1.6.tar.gz 158879 BLAKE2B 96d36be283d497df8aed944f3ba14c620e3abc7d3dd728c274f3ebaca3f064d1ac92bd4d47cbae51500264d785feda25082950fde6fdbd6c1b35f48736015659 SHA512 9ef51c0acc450d1f2073c03885e097231a745a456ae384825c56804f94c62ac85bf4c795627e6ea738636fa83d50d7ef60e20c6dd9621247ff06c51461d91249
DIST hw-probe-1.6_beta2.tar.gz 143569 BLAKE2B fc7b7562f86eb1b26fef32a8ed9b4a8d01c5621bedbc7e810d5a011c53d528b000ff9df312cf5e3f0ab455558e08e2b9a3ddcd543cd6856208466721f9a0e13c SHA512 2727e7b0fe449cbb6dd21fc112660df4ec666be845bbfd21037b41372a499dfb80c8c2dc37bd222032c68faadff91192a6d6f5229353cb0fc63b8e3dbd715f5d
diff --git a/sys-apps/hw-probe/hw-probe-1.6.ebuild b/sys-apps/hw-probe/hw-probe-1.6.ebuild
new file mode 100644
index 000000000000..504704b069f7
--- /dev/null
+++ b/sys-apps/hw-probe/hw-probe-1.6.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PV="${PV/_/-}"
+MY_PV_BETA="${MY_PV/2/}"
+
+inherit optfeature readme.gentoo-r1
+
+DESCRIPTION="A tool to probe for hardware, check it's operability and find drivers"
+HOMEPAGE="https://github.com/linuxhw/hw-probe/"
+SRC_URI="https://github.com/linuxhw/hw-probe/archive/${MY_PV_BETA}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV_BETA}"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-lang/perl
+ dev-perl/Digest-SHA1
+ net-misc/curl
+ sys-apps/dmidecode
+ sys-apps/edid-decode
+ sys-apps/hwinfo
+ sys-apps/pciutils
+ sys-apps/smartmontools
+ sys-apps/usbutils
+ virtual/perl-Data-Dumper
+"
+
+src_compile() {
+ :;
+}
+
+src_install() {
+ default
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+
+ optfeature "showing Machine Check Exceptions." app-admin/mcelog
+ optfeature "showing additional I/O statistics." app-admin/sysstat
+ optfeature "showing display data channel (ddc) information." app-misc/ddcutil
+ optfeature "showing smart card (reader) information." dev-libs/opensc
+ optfeature "showing Vulkan GPU hardware information." dev-util/vulkan-tools
+ optfeature "showing information of attached scanners." media-gfx/sane-backends
+ optfeature "showing GPU information provided by MESA." media-libs/mesa
+ optfeature "showing zeroconf statistics." net-dns/avahi
+ optfeature "showing HP printer statistics." net-print/hplip
+ optfeature "showing status about rfkill switches on communication devices." net-wireless/rfkill
+ optfeature "showing additional CPU capabilities." sys-apps/cpuid
+ optfeature "showing hard disk (HDD, SSD, ..) capabilities." sys-apps/hdparm
+ optfeature "showing available I2C sensors." sys-apps/i2c-tools
+ optfeature "showing additional hardware and system information detected by inxi." sys-apps/inxi
+ optfeature "showing information about tested memory for faults." sys-apps/memtester
+ optfeature "showing 'Plug & Play' devices." sys-apps/pnputils
+ optfeature "showing systemd boot process information." sys-apps/systemd
+ optfeature "showing ACPI statistics and tables." sys-power/iasl
+ optfeature "showing information about NUMA." sys-process/numactl
+ optfeature "showing additional GPU information provided by MESA progs." x11-apps/mesa-progs
+ optfeature "showing available Xinput devices." x11-apps/xinput
+}