summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-01-08 19:34:07 +0100
committerThomas Deutschmann <whissi@gentoo.org>2019-01-08 20:19:50 +0100
commit92e12d5306f0f510f994cfa50830c7c4c1ae1ad0 (patch)
tree6a99789ef239fc8ffc1eaf2d3d20436783916c82 /sys-apps/groff
parentkde-plasma: Drop KDE Plasma 5.14.4 (diff)
downloadgentoo-92e12d5306f0f510f994cfa50830c7c4c1ae1ad0.tar.gz
gentoo-92e12d5306f0f510f994cfa50830c7c4c1ae1ad0.tar.bz2
gentoo-92e12d5306f0f510f994cfa50830c7c4c1ae1ad0.zip
sys-apps/groff: really use /usr/share/doc/${PF} as docdir
Previous attempt to force groff to honor docdir didn't work and would require `eautoreconf`. We are now patching Makefile.in only and avoid `eautoreconf`. Link: https://github.com/gentoo/gentoo/pull/10697#issuecomment-451577399 Fixes: ba6771a19744 ("sys-apps/groff: bump to v1.22.4 RC4") Package-Manager: Portage-2.3.54, Repoman-2.3.12 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'sys-apps/groff')
-rw-r--r--sys-apps/groff/groff-1.22.4.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/sys-apps/groff/groff-1.22.4.ebuild b/sys-apps/groff/groff-1.22.4.ebuild
index 67b0f18455e9..749ccb4d7c97 100644
--- a/sys-apps/groff/groff-1.22.4.ebuild
+++ b/sys-apps/groff/groff-1.22.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -42,9 +42,9 @@ src_prepare() {
default
# honor Gentoo's docdir
- sed -i -e '/^docdir=/s/^/#/' \
- Makefile.am \
- || die "failed to modify Makefile.am"
+ sed -i -e "s|^docdir =.*|docdir = \"${EPREFIX%/}/usr/share/doc/${PF}\"|g" \
+ Makefile.in \
+ || die "failed to modify Makefile.in"
# Make sure we can cross-compile this puppy
if tc-is-cross-compiler ; then
@@ -73,7 +73,6 @@ src_prepare() {
src_configure() {
local myeconfargs=(
--with-appresdir="${EPREFIX%/}"/usr/share/X11/app-defaults
- --docdir="${EPREFIX%/}"/usr/share/doc/${PF}
$(use_with X x)
)
econf "${myeconfargs[@]}"