summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-05-26 18:26:16 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-05-26 18:26:16 +0300
commitbe05f3db8e49604e9ffd30faf6dad79bc6b22e30 (patch)
tree727fd1173b202a1c7a42eca309af62b860a426dc /sys-apps/elfix/elfix-0.9.5.ebuild
parentsci-libs/caffe2: drop 2.1.2-r7 (diff)
downloadgentoo-be05f3db8e49604e9ffd30faf6dad79bc6b22e30.tar.gz
gentoo-be05f3db8e49604e9ffd30faf6dad79bc6b22e30.tar.bz2
gentoo-be05f3db8e49604e9ffd30faf6dad79bc6b22e30.zip
sys-apps/elfix: drop 0.9.5
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'sys-apps/elfix/elfix-0.9.5.ebuild')
-rw-r--r--sys-apps/elfix/elfix-0.9.5.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/sys-apps/elfix/elfix-0.9.5.ebuild b/sys-apps/elfix/elfix-0.9.5.ebuild
deleted file mode 100644
index 0f1ed96f6f05..000000000000
--- a/sys-apps/elfix/elfix-0.9.5.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-if [[ ${PV} == *9999* ]] ; then
- EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/elfix.git"
- inherit autotools git-r3
-else
- SRC_URI="https://dev.gentoo.org/~blueness/elfix/${P}.tar.gz"
- KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv sparc x86"
-fi
-
-DESCRIPTION="A suite of tools to work with ELF objects on Hardened Gentoo"
-HOMEPAGE="https://www.gentoo.org/proj/en/hardened/pax-quickstart.xml
- https://dev.gentoo.org/~blueness/elfix/"
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="+ptpax test +xtpax"
-REQUIRED_USE="|| ( ptpax xtpax )"
-# These only work with a properly configured PaX kernel
-RESTRICT="!test? ( test ) test"
-
-DOCS=( AUTHORS ChangeLog INSTALL README THANKS TODO )
-
-DEPEND="~dev-python/pypax-${PV}[ptpax=,xtpax=]
- ptpax? ( dev-libs/elfutils )
- xtpax? ( sys-apps/attr )"
-
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- default
- if [[ ${PV} == *9999* ]]; then
- eautoreconf
- cd doc && ./make.sh || die
- fi
-}
-
-src_configure() {
- rm -f "${S}/scripts/setup.py"
- econf \
- $(use_enable test tests) \
- $(use_enable ptpax) \
- $(use_enable xtpax)
-}