summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/cpuid
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/cpuid')
-rw-r--r--sys-apps/cpuid/Manifest3
-rw-r--r--sys-apps/cpuid/cpuid-20130610.ebuild31
-rw-r--r--sys-apps/cpuid/cpuid-20140123.ebuild31
-rw-r--r--sys-apps/cpuid/cpuid-20150606.ebuild31
-rw-r--r--sys-apps/cpuid/files/cpuid-20110305-Makefile.patch30
-rw-r--r--sys-apps/cpuid/files/cpuid-20110305-fPIC.patch24
-rw-r--r--sys-apps/cpuid/files/cpuid-20150606-Makefile.patch21
-rw-r--r--sys-apps/cpuid/metadata.xml12
8 files changed, 183 insertions, 0 deletions
diff --git a/sys-apps/cpuid/Manifest b/sys-apps/cpuid/Manifest
new file mode 100644
index 000000000000..23c5295a39b0
--- /dev/null
+++ b/sys-apps/cpuid/Manifest
@@ -0,0 +1,3 @@
+DIST cpuid-20130610.src.tar.gz 65801 SHA256 f87e835a83e69013eee09eded0e9c5ac0ea5819d569d3b79680cab2b5ea770f4 SHA512 cb31126a7ba7244d44c3b0d86ad93f3ff0956a59af488a27ed482e549a8f628fedf142ac8f238c32e48946b5c76ceba2f5a0b95a9b4df8bf7354ed4dcdbeb0a7 WHIRLPOOL e82d27e1450e85e53074fa37f42ad5e03a0daf3dd153c5d6a8674c72b2e04f266f59b80f2eb90f3f25e8a8b0f473e8aa1ce4991b9eb8d50e76d6e1ae70665ab2
+DIST cpuid-20140123.src.tar.gz 67882 SHA256 b85aba5696d382f0dba8dc246bd42d09767089d6181a9cd0633d626f079d79ff SHA512 8b205cc539959dcd63326d5de700e090213f5b7cdbd5e25925b8db774001cbd95df7ccb696fda124226380fef69ea7fe0c0885869b0ec7e07b0c340dc0cd8a5b WHIRLPOOL dfcc1b6ea125fb0b6c13b7edd7f6c37592a2acfbc178f4c65cd7ec1577010ec9cc69919af512681e4af048ab028cb8992d1a282435e5b4aace179c40ff607ac4
+DIST cpuid-20150606.src.tar.gz 71882 SHA256 b7607e81e62e4901180d9e2f48fe407033211c3fb300d758a210f746ef518c4e SHA512 6f99266b9720b48ec10f220f8a321d3ed052300960151feb6c45d39b586216745f070241db20afd4d16ac0b3389b634eb31f90c93ea9d12f521012cfe5ab9257 WHIRLPOOL 0c7140b636e7cca8ac0d150cb015170964471a3e00d48f3b7290976c768415773d5741f53937b2773b751a8e830d21e156c3f199de081dd42c50ffd76688e640
diff --git a/sys-apps/cpuid/cpuid-20130610.ebuild b/sys-apps/cpuid/cpuid-20130610.ebuild
new file mode 100644
index 000000000000..909176edf893
--- /dev/null
+++ b/sys-apps/cpuid/cpuid-20130610.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Utility to get detailed information about the CPU(s) using the
+CPUID instruction"
+HOMEPAGE="http://www.etallen.com/cpuid.html"
+SRC_URI="http://www.etallen.com/${PN}/${P}.src.tar.gz"
+
+KEYWORDS="amd64 x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-20110305-Makefile.patch
+ epatch "${FILESDIR}"/${PN}-20110305-fPIC.patch #376245
+}
+
+src_compile() {
+ tc-export CC
+ emake
+}
+
+src_install() {
+ emake BUILDROOT="${D}" install
+}
diff --git a/sys-apps/cpuid/cpuid-20140123.ebuild b/sys-apps/cpuid/cpuid-20140123.ebuild
new file mode 100644
index 000000000000..ce80f5c51d41
--- /dev/null
+++ b/sys-apps/cpuid/cpuid-20140123.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Utility to get detailed information about the CPU(s) using the
+CPUID instruction"
+HOMEPAGE="http://www.etallen.com/cpuid.html"
+SRC_URI="http://www.etallen.com/${PN}/${P}.src.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-20110305-Makefile.patch
+ epatch "${FILESDIR}"/${PN}-20110305-fPIC.patch #376245
+}
+
+src_compile() {
+ tc-export CC
+ emake
+}
+
+src_install() {
+ emake BUILDROOT="${D}" install
+}
diff --git a/sys-apps/cpuid/cpuid-20150606.ebuild b/sys-apps/cpuid/cpuid-20150606.ebuild
new file mode 100644
index 000000000000..77863be1a235
--- /dev/null
+++ b/sys-apps/cpuid/cpuid-20150606.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Utility to get detailed information about the CPU(s) using the
+CPUID instruction"
+HOMEPAGE="http://www.etallen.com/cpuid.html"
+SRC_URI="http://www.etallen.com/${PN}/${P}.src.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-20150606-Makefile.patch
+ epatch "${FILESDIR}"/${PN}-20110305-fPIC.patch #376245
+}
+
+src_compile() {
+ tc-export CC
+ emake
+}
+
+src_install() {
+ emake BUILDROOT="${D}" install
+}
diff --git a/sys-apps/cpuid/files/cpuid-20110305-Makefile.patch b/sys-apps/cpuid/files/cpuid-20110305-Makefile.patch
new file mode 100644
index 000000000000..a3aab8a50f66
--- /dev/null
+++ b/sys-apps/cpuid/files/cpuid-20110305-Makefile.patch
@@ -0,0 +1,30 @@
+Index: cpuid-20110305/Makefile
+===================================================================
+--- cpuid-20110305.orig/Makefile
++++ cpuid-20110305/Makefile
+@@ -1,7 +1,3 @@
+-CFLAGS=-g
+-ifneq (,$(findstring arch=i386,$(CFLAGS)))
+-CISA=-m32
+-endif
+ CFL=$(CFLAGS) $(CISA) -Wall -Wshadow -Wcast-align -Wredundant-decls -Wbad-function-cast -Wcast-qual -Wwrite-strings -Waggregate-return -Wstrict-prototypes -Wmissing-prototypes -D_FILE_OFFSET_BITS=64 -DVERSION=$(VERSION)
+
+ PACKAGE=cpuid
+@@ -36,14 +32,14 @@ BUILDROOT=
+ default: $(PROG) $(PROG).man.gz
+
+ $(PROG): cpuid.c Makefile
+- $(CC) $(CFL) -o $@ cpuid.c
++ $(CC) $(CFL) $(LDFLAGS) -o $@ cpuid.c
+
+ $(PROG).man.gz: $(PROG).man
+ gzip < $< > $@
+
+ install: $(PROG) $(PROG).man.gz
+- install -D -s -m 755 $(PROG) $(BUILDROOT)/usr/bin/$(PROG)
+- install -D -m 444 $(PROG).man.gz $(BUILDROOT)/usr/share/man/man1/$(PROG).1.gz
++ install -D -m 755 $(PROG) $(BUILDROOT)/usr/bin/$(PROG)
++ install -D -m 444 $(PROG).man.gz $(BUILDROOT)/usr/share/man/man1/$(PROG).1.gz
+
+ clean:
+ rm -f $(PROG) $(PROG).i386 $(PROG).x86_64
diff --git a/sys-apps/cpuid/files/cpuid-20110305-fPIC.patch b/sys-apps/cpuid/files/cpuid-20110305-fPIC.patch
new file mode 100644
index 000000000000..80cc6774a188
--- /dev/null
+++ b/sys-apps/cpuid/files/cpuid-20110305-fPIC.patch
@@ -0,0 +1,24 @@
+diff -u cpuid-20110305.orig//cpuid.c cpuid-20110305/cpuid.c
+--- cpuid-20110305.orig//cpuid.c 2011-03-04 13:25:16.000000000 -0500
++++ cpuid-20110305/cpuid.c 2011-07-31 01:53:39.647437813 -0400
+@@ -5319,9 +5319,20 @@
+ boolean quiet)
+ {
+ if (cpuid_fd == USE_INSTRUCTION) {
++#if defined(__i386__) && defined(__PIC__)
++ asm("push %%ebx\n"
++ "cpuid\n"
++ "movl %%ebx, %1\n"
++ "pop %%ebx\n"
++#else
+ asm("cpuid"
++#endif
+ : "=a" (words[WORD_EAX]),
++#if defined(__i386__) && defined(__PIC__)
++ "=r" (words[WORD_EBX]),
++#else
+ "=b" (words[WORD_EBX]),
++#endif
+ "=c" (words[WORD_ECX]),
+ "=d" (words[WORD_EDX])
+ : "a" (reg),
diff --git a/sys-apps/cpuid/files/cpuid-20150606-Makefile.patch b/sys-apps/cpuid/files/cpuid-20150606-Makefile.patch
new file mode 100644
index 000000000000..f878977ece91
--- /dev/null
+++ b/sys-apps/cpuid/files/cpuid-20150606-Makefile.patch
@@ -0,0 +1,21 @@
+--- cpuid-20150606/Makefile
++++ cpuid-20150606/Makefile
+@@ -1,9 +1,3 @@
+-CFLAGS+=-g
+-CPPFLAGS?=
+-LDFLAGS?=
+-ifneq (,$(findstring arch=i386,$(CFLAGS)))
+-CISA=-m32
+-endif
+ CFL=$(CPPFLAGS) $(CFLAGS) $(CISA) -Wall -Wshadow -Wcast-align -Wredundant-decls -Wbad-function-cast -Wcast-qual -Wwrite-strings -Waggregate-return -Wstrict-prototypes -Wmissing-prototypes -D_FILE_OFFSET_BITS=64 -DVERSION=$(VERSION)
+
+ PACKAGE=cpuid
+@@ -44,7 +38,7 @@
+ gzip < $< > $@
+
+ install: $(PROG) $(PROG).man.gz
+- install -D -s -m 755 $(PROG) $(BUILDROOT)/usr/bin/$(PROG)
++ install -D -m 755 $(PROG) $(BUILDROOT)/usr/bin/$(PROG)
+ install -D -m 444 $(PROG).man.gz $(BUILDROOT)/usr/share/man/man1/$(PROG).1.gz
+
+ clean:
diff --git a/sys-apps/cpuid/metadata.xml b/sys-apps/cpuid/metadata.xml
new file mode 100644
index 000000000000..1508c97d6f8e
--- /dev/null
+++ b/sys-apps/cpuid/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>hwoarang@gentoo.org</email>
+ <name>Markos Chandras</name>
+ </maintainer>
+ <maintainer>
+ <email>rhill@gentoo.org</email>
+ <name>Ryan Hill</name>
+ </maintainer>
+</pkgmetadata>