summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2023-11-24 15:09:25 +0100
committerPacho Ramos <pacho@gentoo.org>2023-11-24 15:30:31 +0100
commit15c76b12cf7728823d0b2b0b7f2d3b69220613da (patch)
treec09196037a044432e5aabf5a7654e9ddbb440fd7 /sci-visualization
parentsci-mathematics/wxmaxima: stabilize 23.07.0 for amd64 (diff)
downloadgentoo-15c76b12cf7728823d0b2b0b7f2d3b69220613da.tar.gz
gentoo-15c76b12cf7728823d0b2b0b7f2d3b69220613da.tar.bz2
gentoo-15c76b12cf7728823d0b2b0b7f2d3b69220613da.zip
sci-visualization/fityk: add 1.3.2
Closes: https://bugs.gentoo.org/888603 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/fityk/Manifest1
-rw-r--r--sci-visualization/fityk/fityk-1.3.2.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/sci-visualization/fityk/Manifest b/sci-visualization/fityk/Manifest
index 76f11e9286ba..efa698d3312a 100644
--- a/sci-visualization/fityk/Manifest
+++ b/sci-visualization/fityk/Manifest
@@ -1 +1,2 @@
DIST fityk-1.3.1.tar.bz2 1518937 BLAKE2B 6eb13646e1b5cf3fb0763bcf3e91a1877d89f14f1b986f1065fd27052e7110b357c99431a326a6c1fa2ba002300912b922cd3d5589ac5da367d2fbcee209f9a2 SHA512 4a7a65691af8b8d5b47461133b7870ea21ea04ac2ee8ee5714a6b9bab2f072baa6b5d8bf011baba09c62a7ce2dc9d60f3040cc6fdb77dc498b6e03a24fc0fe08
+DIST fityk-1.3.2.tar.bz2 1611794 BLAKE2B 294d64ed34532e7c126a7128c6f027004c86093293f335d5d900bffc5e1fc6d56b48f8a1ca0739f00b9983f9d21c544a3296a12e187401c0bf429cb545be10d7 SHA512 6871358cc1d12479f4ae8d76260412095fa17247b2bd76d7b036be330d73b8aac6d242239aea5c086a2eefad1bc387caa83e5a61452016cd77ea6a88e387aee3
diff --git a/sci-visualization/fityk/fityk-1.3.2.ebuild b/sci-visualization/fityk/fityk-1.3.2.ebuild
new file mode 100644
index 000000000000..1b1e85c205c7
--- /dev/null
+++ b/sci-visualization/fityk/fityk-1.3.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..4} )
+WX_GTK_VER=3.2-gtk3
+
+inherit flag-o-matic lua-single wxwidgets xdg
+
+DESCRIPTION="General-purpose nonlinear curve fitting and data analysis"
+HOMEPAGE="https://fityk.nieto.pl/"
+SRC_URI="https://github.com/wojdyr/${PN}/releases/download/v${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="gnuplot nlopt readline wxwidgets"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+DEPEND="
+ ${LUA_DEPS}
+ dev-libs/boost:=
+ >=sci-libs/xylib-1
+ nlopt? ( sci-libs/nlopt )
+ readline? ( sys-libs/readline:0= )
+ wxwidgets? ( x11-libs/wxGTK:${WX_GTK_VER} )
+"
+RDEPEND="${DEPEND}
+ gnuplot? ( sci-visualization/gnuplot )
+"
+BDEPEND="dev-lang/swig"
+
+src_configure() {
+ # codebase relies on dynamic exception specifications
+ # for SWIG, no point in trying to fix at this point.
+ # https://github.com/wojdyr/fityk/pull/38
+ append-cxxflags -std=c++14
+
+ use wxwidgets && setup-wxwidgets
+
+ econf \
+ --disable-python \
+ --disable-static \
+ $(use_enable nlopt) \
+ $(use_enable wxwidgets GUI) \
+ $(use_with readline) \
+ --with-wx-config="${WX_CONFIG}"
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+
+ mv "${ED}"/usr/share/appdata "${ED}"/usr/share/metainfo || die
+}