summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerhard Bräunlich <wippbox@gmx.net>2016-11-12 16:23:22 +0100
committerDavid Seifert <soap@gentoo.org>2016-11-14 18:30:52 +0100
commit1c54d75d8b9f76664d6d88694d308f90182d00a2 (patch)
tree1d31cad67ae3cbdd4902391d9000e4d9f95b357a /sci-physics
parentapp-misc/ddcutil: Renamed from ddctool, bump to 0.6.0 (diff)
downloadgentoo-1c54d75d8b9f76664d6d88694d308f90182d00a2.tar.gz
gentoo-1c54d75d8b9f76664d6d88694d308f90182d00a2.tar.bz2
gentoo-1c54d75d8b9f76664d6d88694d308f90182d00a2.zip
sci-physics/harminv-1.3.1-r1: EAPI bump 4 -> 6
Package-Manager: portage-2.3.0 Closes: https://github.com/gentoo/gentoo/pull/2822 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/harminv/files/harminv-1.3.1-configure.ac.patch4
-rw-r--r--sci-physics/harminv/harminv-1.3.1-r1.ebuild34
2 files changed, 36 insertions, 2 deletions
diff --git a/sci-physics/harminv/files/harminv-1.3.1-configure.ac.patch b/sci-physics/harminv/files/harminv-1.3.1-configure.ac.patch
index 2830d5b586f3..508a8c177902 100644
--- a/sci-physics/harminv/files/harminv-1.3.1-configure.ac.patch
+++ b/sci-physics/harminv/files/harminv-1.3.1-configure.ac.patch
@@ -1,5 +1,5 @@
---- configure.ac.orig 2007-09-27 09:27:28.731439558 +0100
-+++ configure.ac 2007-09-27 09:37:45.755835491 +0100
+--- a/configure.ac
++++ b/configure.ac
@@ -9,7 +9,7 @@
# *not* the same as the "public" version number. CURRENT:REVISION:AGE
SHARED_VERSION_INFO="2:4:0"
diff --git a/sci-physics/harminv/harminv-1.3.1-r1.ebuild b/sci-physics/harminv/harminv-1.3.1-r1.ebuild
new file mode 100644
index 000000000000..a7bacff2b2bc
--- /dev/null
+++ b/sci-physics/harminv/harminv-1.3.1-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="Extraction of complex frequencies and amplitudes from time series"
+HOMEPAGE="http://ab-initio.mit.edu/harminv/"
+SRC_URI="http://ab-initio.mit.edu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+RDEPEND="virtual/lapack"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${P}-configure.ac.patch )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ --with-blas="$($(tc-getPKG_CONFIG) --libs blas)" \
+ --with-lapack="$($(tc-getPKG_CONFIG) --libs lapack)"
+}