summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2018-03-09 11:12:55 +0100
committerGuilherme Amadio <amadio@gentoo.org>2018-03-09 11:53:19 +0100
commitf9ca7d787a70027a99843e3202ba12d2bcb8789e (patch)
tree57ccd30c25c1e92741f85ff6192c4cfc1b2c40a7 /sci-physics/yoda
parentsci-physics/rivet: drop old versions (diff)
downloadgentoo-f9ca7d787a70027a99843e3202ba12d2bcb8789e.tar.gz
gentoo-f9ca7d787a70027a99843e3202ba12d2bcb8789e.tar.bz2
gentoo-f9ca7d787a70027a99843e3202ba12d2bcb8789e.zip
sci-physics/yoda: version bump to 1.7.0
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'sci-physics/yoda')
-rw-r--r--sci-physics/yoda/Manifest1
-rw-r--r--sci-physics/yoda/yoda-1.7.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/sci-physics/yoda/Manifest b/sci-physics/yoda/Manifest
index acdf1b246ebe..66afc8b5095b 100644
--- a/sci-physics/yoda/Manifest
+++ b/sci-physics/yoda/Manifest
@@ -1 +1,2 @@
DIST YODA-1.6.5.tar.bz2 818613 BLAKE2B 6a8762c4f8d4bbcacf11c1b9929cff4b00811d4e18c596122dce335782a741aa1c76fab4b2ed9897dc800af1a18dba809e4fa0956cb5eb6fc84cc98544c669d6 SHA512 bead0a3ada233c1fbafe66d25e65262c20d9a9dfa6265440320a0fc782e91b3ac6581698e2015d86f2b58dc305dedbc48ed648ff03ec9f6abc11a7fb27938b1a
+DIST YODA-1.7.0.tar.bz2 949964 BLAKE2B 44063500b95e6a089adac0a28eb0165c6d91f09642dcba7eae994a8b2dd9c4cc5cff40d63cbb481f41e023193632b9b2c17c4304bc03afa4ad2c6010b52c15da SHA512 de4eff3fdd7f8f031745152907eadfe4687c6c8597772d8aba628e58e7d6f203bbe55ba030a77990b2441a9b046a4d7e2bce1fb29ba9a631c1cff17acd95b1e5
diff --git a/sci-physics/yoda/yoda-1.7.0.ebuild b/sci-physics/yoda/yoda-1.7.0.ebuild
new file mode 100644
index 000000000000..9f53d934f26e
--- /dev/null
+++ b/sci-physics/yoda/yoda-1.7.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit bash-completion-r1 python-single-r1
+
+DESCRIPTION="Yet more Objects for (High Energy Physics) Data Analysis"
+HOMEPAGE="http://yoda.hepforge.org/"
+
+SRC_URI="http://www.hepforge.org/archive/${PN}/${P^^}.tar.bz2"
+LICENSE="GPL-2"
+
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="python root static-libs"
+
+RDEPEND="
+ python? ( ${PYTHON_DEPS} )
+ root? ( sci-physics/root:=[python=,${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}
+ python? ( dev-python/cython[${PYTHON_USEDEP}] )"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+S="${WORKDIR}/${P^^}"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ econf \
+ $(use_enable python pyext) \
+ $(use_enable root) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ newbashcomp "${ED%/}"/usr/share/YODA/yoda-completion ${PN}
+ rm "${ED%/}"/usr/share/YODA/yoda-completion || die
+}