summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2016-04-27 19:28:47 +0200
committerDavide Pesavento <pesa@gentoo.org>2016-04-27 19:29:15 +0200
commita81d3b65846d7dfaeccb5612e7440ecdbbe51dad (patch)
tree82da6913f5ce571706e17844879fae5028aeb93f /sci-mathematics
parentsys-boot/grub: call eautoreconf for the sysmacros patch (diff)
downloadgentoo-a81d3b65846d7dfaeccb5612e7440ecdbbe51dad.tar.gz
gentoo-a81d3b65846d7dfaeccb5612e7440ecdbbe51dad.tar.bz2
gentoo-a81d3b65846d7dfaeccb5612e7440ecdbbe51dad.zip
sci-mathematics/relational: version bump
Ebuild rewritten using EAPI 6 and python-single-r1. Parallel make install bug has been reported upstream. Gentoo-Bug: 581000 Package-Manager: portage-2.2.28
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/relational/Manifest1
-rw-r--r--sci-mathematics/relational/relational-2.4.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/sci-mathematics/relational/Manifest b/sci-mathematics/relational/Manifest
index 649deb1fdd92..1dd8a558e2c4 100644
--- a/sci-mathematics/relational/Manifest
+++ b/sci-mathematics/relational/Manifest
@@ -1 +1,2 @@
DIST relational-0.11.tar.gz 133002 SHA256 367b8ade98e4b9d34ff463a217e41d7206d201cdaee3e49cf5f5bcb28f558040 SHA512 90f79700c7b7f2cfe481d10c565f7cf81acc94a26250eff367e361d8fe122c5ce7dfc740ede7309c8308003031eef2c4a1486657e6dc30b8151987af0bec764e WHIRLPOOL 3ae1a79e63fe60c051788b6b6b467ca3030f09bd6ff0f6dced5280c8873ef08e7ed59b4032fca78df3efb5566e21eeec7116ecbf0a4389710f55b8d35b6f205c
+DIST relational_2.4.orig.tar.gz 113606 SHA256 6e322ae4face623e91fb775171eb3758bcb9a253f2967c9e303208e9f32e5dee SHA512 c7cb6bf5c97df57e84f746d0adccbc3285ea863d692c2b999600ec70f8512e1a3f28a4414d2d34fa956ec6d7955ff290f638d048ada6b685d031823b46d368ff WHIRLPOOL 069c0f69237060fe1741c233678400abce7148ef865c6fa61847cc9395289f6f27b2b6456f632ded421ea3e9c0f4f3f8bb8d13713f72e950ad3608d7c4478052
diff --git a/sci-mathematics/relational/relational-2.4.ebuild b/sci-mathematics/relational/relational-2.4.ebuild
new file mode 100644
index 000000000000..120b29b5517a
--- /dev/null
+++ b/sci-mathematics/relational/relational-2.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5} )
+
+inherit python-single-r1
+
+DESCRIPTION="Educational tool for relational algebra"
+HOMEPAGE="http://ltworf.github.io/relational/"
+SRC_URI="https://github.com/ltworf/${PN}/releases/download/${PV}/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ ${PYTHON_DEPS}
+ dev-python/PyQt5[gui,webkit,widgets,${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ default
+
+ sed -i -e '/^Terminal=/ s/0/false/' \
+ -e '/^Keywords=/ s/$/;/' \
+ relational.desktop || die
+}
+
+src_install() {
+ emake -j1 DESTDIR="${ED}" install-{relational-cli,python3-relational,relational}
+ python_optimize
+
+ dodoc CHANGELOG complexity CREDITS README.md
+}