summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2020-12-17 16:37:00 +1100
committerSergei Trofimovich <slyfox@gentoo.org>2020-12-17 07:29:32 +0000
commit91089b1b6477243613403652fe95b9be2baf1462 (patch)
tree84d71fda0223359431f69c1c0cf08bf1c008a861 /sci-mathematics
parentsci-mathematics/agda: bump up to 2.6.1.2 (diff)
downloadgentoo-91089b1b6477243613403652fe95b9be2baf1462.tar.gz
gentoo-91089b1b6477243613403652fe95b9be2baf1462.tar.bz2
gentoo-91089b1b6477243613403652fe95b9be2baf1462.zip
sci-mathematics/agda-stdlib: bump up to 2.6.1.2.1.4
Signed-off-by: Jack Todaro <solpeth@posteo.org> Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/agda-stdlib/Manifest1
-rw-r--r--sci-mathematics/agda-stdlib/agda-stdlib-2.6.1.2.1.4.ebuild67
-rw-r--r--sci-mathematics/agda-stdlib/metadata.xml9
3 files changed, 71 insertions, 6 deletions
diff --git a/sci-mathematics/agda-stdlib/Manifest b/sci-mathematics/agda-stdlib/Manifest
index 4279dcb29b8e..690b60fabc17 100644
--- a/sci-mathematics/agda-stdlib/Manifest
+++ b/sci-mathematics/agda-stdlib/Manifest
@@ -1 +1,2 @@
DIST agda-stdlib-2.5.2.0.13.tar.gz 264701 BLAKE2B f35b419aac1b80af86217a86fb8e21a2f3427ef9629c8f2e284036859cd89da16ce1b64ceb87f8a3030b5bdb2a68b4f59f74a717fc1e13378ecb20cc6b28f59c SHA512 340a7b9cb15793cdbe99f558a32eaab3476b94b4d43d45bdc92c6b368197d075c977fd2f6ce0c5b0baf584289a2218b07dd030ad2b83f6d9e4bc7effee91eece
+DIST agda-stdlib-2.6.1.2.1.4.tar.gz 816654 BLAKE2B c8e6b6f86f32dd2e3d57da4a21066be4a441e71bc3a7cb96d8000f28c56cbb114a00e5df2777b00a8a9fc1a0f94b00bdf4b72eb46f0245ab482a41b6a9d772ee SHA512 90c05d54eaf1d7c78d00f73044afa1f3b4d99df622d40b3cea88fe280f0770ccaeddd787d8fb384c150123f592bb6a7ec24b842a9fcc2936f581d847928223ca
diff --git a/sci-mathematics/agda-stdlib/agda-stdlib-2.6.1.2.1.4.ebuild b/sci-mathematics/agda-stdlib/agda-stdlib-2.6.1.2.1.4.ebuild
new file mode 100644
index 000000000000..55a498c1f260
--- /dev/null
+++ b/sci-mathematics/agda-stdlib/agda-stdlib-2.6.1.2.1.4.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CABAL_FEATURES="profile"
+inherit haskell-cabal elisp-common
+
+## shared with sci-mathematics/agda
+# upstream does not maintain version ordering:
+# https://github.com/agda/agda-stdlib/releases
+# 0.11 -> 2.5.0.20160213 -> 2.5.0.20160412 -> 0.12 -> 0.13
+# As Agda-stdlib is tied to Agda version we encode
+# both versions in gentoo version.
+##
+MY_UPSTREAM_AGDA_STDLIB_V="1.4"
+MY_GENTOO_AGDA_STDLIB_V="${PV}.${MY_UPSTREAM_AGDA_STDLIB_V}"
+MY_UPSTREAM_AGDA_V="${PV%.${MY_UPSTREAM_AGDA_STDLIB_V}}"
+
+DESCRIPTION="Agda standard library"
+HOMEPAGE="https://wiki.portal.chalmers.se/agda/"
+SRC_URI="https://github.com/agda/${PN}/archive/v${MY_UPSTREAM_AGDA_STDLIB_V}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=sci-mathematics/agda-${MY_UPSTREAM_AGDA_V}:=[profile?]
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.24.2.0
+ >=dev-haskell/filemanip-0.3.6.2[profile?] <dev-haskell/filemanip-0.4[profile?]
+ >=dev-lang/ghc-8.0.2
+"
+
+S=${WORKDIR}/${PN}-${MY_UPSTREAM_AGDA_STDLIB_V}
+
+src_compile() {
+ haskell-cabal_src_compile
+ "${S}"/dist/build/GenerateEverything/GenerateEverything \
+ || die "GenerateEverything failed"
+ local prof
+ use profile && prof="--ghc-flag=-prof"
+ agda +RTS -K1G -RTS ${prof} \
+ -i "${S}" -i "${S}"/src "${S}"/Everything.agda || die
+ # Although my agda-9999 build has
+ # /var/tmp/portage/sci-mathematics/agda-9999/work/agda-9999/dist/build/autogen/Paths_Agda.hs
+ # containing:
+ # datadir = "/usr/share/agda-9999/ghc-7.6.1"
+ # it fails without the --css option like:
+ # /usr/share/agda-9999/ghc-7.4.1/Agda.css: copyFile: does not exist
+ local cssdir=$(egrep 'datadir *=' "${S}/dist/build/autogen/Paths_lib.hs" | sed -e 's@datadir = \(.*\)@\1@')
+ agda --html -i "${S}" -i "${S}"/src --css="${cssdir}/Agda.css" "${S}"/README.agda || die
+}
+
+src_test() {
+ agda -i "${S}" -i "${S}"/src README.agda || die
+}
+
+src_install() {
+ insinto usr/share/agda-stdlib
+ insopts --preserve-timestamps
+ doins -r src/*
+ dodoc -r html/*
+ doins "${FILESDIR}/standard-library.agda-lib"
+}
diff --git a/sci-mathematics/agda-stdlib/metadata.xml b/sci-mathematics/agda-stdlib/metadata.xml
index 06549522e123..37374b54118e 100644
--- a/sci-mathematics/agda-stdlib/metadata.xml
+++ b/sci-mathematics/agda-stdlib/metadata.xml
@@ -5,13 +5,10 @@
<email>sci-mathematics@gentoo.org</email>
<name>Gentoo Mathematics Project</name>
</maintainer>
- <maintainer type="project">
- <email>haskell@gentoo.org</email>
- <name>Gentoo Haskell</name>
+<maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
</maintainer>
- <use>
- <flag name="ffi">Install agda-lib-ffi for compilation using the MAlonzo backend</flag>
- </use>
<upstream>
<remote-id type="github">agda/agda-stdlib</remote-id>
</upstream>