summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrançois Bissey <frp.bissey@gmail.com>2022-07-02 23:12:27 +1200
committerMichael Orlitzky <mjo@gentoo.org>2022-07-02 08:55:04 -0400
commit05f4c5e783c5b8440801cb3e612056a81a404515 (patch)
tree1ee58f6fde9571dda74f28a9675da3c3ae5c0f65 /sci-mathematics
parentdev-qt/qtxmlpatterns: Stabilize 5.15.5 ppc, #853232 (diff)
downloadgentoo-05f4c5e783c5b8440801cb3e612056a81a404515.tar.gz
gentoo-05f4c5e783c5b8440801cb3e612056a81a404515.tar.bz2
gentoo-05f4c5e783c5b8440801cb3e612056a81a404515.zip
sci-mathematics/eclib: upstream bump
Closes: https://github.com/gentoo/gentoo/pull/26199 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: François René Pierre Bissey <frp.bissey@gmail.com> Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/eclib/Manifest1
-rw-r--r--sci-mathematics/eclib/eclib-20220621.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/sci-mathematics/eclib/Manifest b/sci-mathematics/eclib/Manifest
index 5663658de8fd..89abce864842 100644
--- a/sci-mathematics/eclib/Manifest
+++ b/sci-mathematics/eclib/Manifest
@@ -1 +1,2 @@
DIST eclib-20210625.tar.bz2 921173 BLAKE2B 8ecfde35fd6e557601c0a4e5f877ec49e355dbd5bb4248256c89b1160406992f59568db1060a835bad482d6ba4f1f0cc7719af5f03ecdc79abbe2ca0c9ed713e SHA512 a1319e91790decbc5219e02edbad5b86a6d3e5400bec3a9a9f2c60b89d340a0b915458f93c86f63d21c4b72995aa5fe65e0b5346241f297fe54ba2d3fc183ae3
+DIST eclib-20220621.tar.bz2 921610 BLAKE2B f53f0648f09e427ae9b208a17c93f9808c2ab859cc41db6b5acb3b1382e9aaee93b17cd9d94c14e7f4941f140749d91b2ad94ad684f8a2c0f6033ac042cc89e7 SHA512 45cc47256f6ccbf2a00711d14533cffe8a3fc0dfea3d94d9823ac43af8a56cfe95485f0559c9141203910e85b1d3fa3284ee12ca5e53d083b74cbb2907afca42
diff --git a/sci-mathematics/eclib/eclib-20220621.ebuild b/sci-mathematics/eclib/eclib-20220621.ebuild
new file mode 100644
index 000000000000..b929d5e52f1c
--- /dev/null
+++ b/sci-mathematics/eclib/eclib-20220621.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Programs for elliptic curves defined over the rational numbers"
+HOMEPAGE="https://github.com/JohnCremona/eclib"
+SRC_URI="https://github.com/JohnCremona/${PN}/releases/download/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+
+# Major version of /usr/lib64/libec.so
+SLOT="0/10"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="boost flint minimal static-libs test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="sci-mathematics/pari:=
+ dev-libs/ntl:=
+ boost? ( dev-libs/boost:= )
+ flint? ( sci-mathematics/flint:= )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf \
+ $(usex minimal --disable-allprogs "" "" "") \
+ $(use_with boost) \
+ $(use_with flint) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}