summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2019-12-28 08:22:33 -0500
committerMichael Orlitzky <mjo@gentoo.org>2019-12-28 08:57:35 -0500
commite3fd7bb8cfe64cd5b92cbf5d758ffb8aeddf8f8e (patch)
tree3aa59debd0d7a0235b685f350c7525c9c9844498 /sci-mathematics/pari/files
parentsci-biology/embassy-phylipnew: Change LICENSE to "free-noncomm". (diff)
downloadgentoo-e3fd7bb8cfe64cd5b92cbf5d758ffb8aeddf8f8e.tar.gz
gentoo-e3fd7bb8cfe64cd5b92cbf5d758ffb8aeddf8f8e.tar.bz2
gentoo-e3fd7bb8cfe64cd5b92cbf5d758ffb8aeddf8f8e.zip
sci-mathematics/pari: new version 2.11.2.
This new version was imported from the sage-on-gentoo overlay where François Bissey has been maintaining it for use with SageMath. I've made a few changes: * Moved the virtual/latex-base dependency into BDEPEND, because those tools are run on the build host to create the documentation. * Used the existing patches (with different names) where possible. * Edited pari-2.10-no-automagic.patch to not mess with PLOTLIBS when USE=fltk is set. My build was failing because this patch resulted in -lstdc++ being stripped from the linker flags. * Dropped empty variable "${mymake}" in a few places. * Enabled the full test suite, which passes for me if I lie to pari about the number of columns my terminal has (???). * Installed some extra documentation by setting DOCS and calling the default implementation of src_install. * Used "usex" instead of an "if" statement for a ./Configure flag. * Changed "export CPLUSPLUS=$(tc-getCXX)" to "tc-export CXX". The CPLUSPLUS variable doesn't appear anywhere in the source, so I doubt this was doing anything. It may not even be necessary to export CC/CXX any longer. * Added RESTRICT="!test? ( test )" now that we run the test suite. * Added myself and François as maintainers. Closes: https://bugs.gentoo.org/703156 Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-mathematics/pari/files')
-rw-r--r--sci-mathematics/pari/files/pari-2.11.2-Makefile-LDFLAGS.patch13
-rw-r--r--sci-mathematics/pari/files/pari-2.11.2-Makefile-docinstall.patch25
-rw-r--r--sci-mathematics/pari/files/pari-2.11.2-no-automagic.patch74
3 files changed, 112 insertions, 0 deletions
diff --git a/sci-mathematics/pari/files/pari-2.11.2-Makefile-LDFLAGS.patch b/sci-mathematics/pari/files/pari-2.11.2-Makefile-LDFLAGS.patch
new file mode 100644
index 000000000000..6d6e6726ddf7
--- /dev/null
+++ b/sci-mathematics/pari/files/pari-2.11.2-Makefile-LDFLAGS.patch
@@ -0,0 +1,13 @@
+diff --git a/config/Makefile.SH b/config/Makefile.SH
+index 27c6d5b..43debb1 100644
+--- a/config/Makefile.SH
++++ b/config/Makefile.SH
+@@ -185,7 +185,7 @@ LD = $LD \$(LD_FLAVOR)
+ LDFLAGS = $LDFLAGS
+ DLLD_FLAVOR = \$(LD_FLAVOR)
+ DLLD = $DLLD \$(DLLD_FLAVOR)
+-DLLDFLAGS = $DLLDFLAGS
++DLLDFLAGS = $DLLDFLAGS \$(LDFLAGS)
+ EXTRADLLDFLAGS = $EXTRADLLDFLAGS
+ RUNTEST = $RUNTEST
+
diff --git a/sci-mathematics/pari/files/pari-2.11.2-Makefile-docinstall.patch b/sci-mathematics/pari/files/pari-2.11.2-Makefile-docinstall.patch
new file mode 100644
index 000000000000..5f03d77d9e7c
--- /dev/null
+++ b/sci-mathematics/pari/files/pari-2.11.2-Makefile-docinstall.patch
@@ -0,0 +1,25 @@
+diff --git a/config/Makefile.SH b/config/Makefile.SH
+index 27c6d5b..43debb1 100644
+--- a/config/Makefile.SH
++++ b/config/Makefile.SH
+@@ -366,9 +366,9 @@ clean: cleanall
+ .headers: $HEADERS
+ @touch \$@
+
+-install-nodata: install-lib-$dft install-include install-bin install-man install-misc install-examples install-cfg
++install-nodata: install-lib-$dft install-include install-bin install-man install-misc install-cfg
+
+-install: install-doc install-nodata install-data
++install: install-nodata install-data
+
+ install-include:
+ -mkdir -p \$(INCLUDEDIR)/pari
+@@ -425,7 +425,7 @@ install-cfg::
+ \$(INSTALL_DATA) $desc/PARI/822.pm \$(DATADIR)/PARI;\
+ \$(INSTALL_DATA) $desc/\$(DESC) \$(DATADIR); fi
+
+-install-doc: install-docdvi install-doctex
++install-doc: install-docpdf install-doctex install-examples
+
+ install-doctex:
+ -mkdir -p \$(BINDIR) \$(DOCDIR)
diff --git a/sci-mathematics/pari/files/pari-2.11.2-no-automagic.patch b/sci-mathematics/pari/files/pari-2.11.2-no-automagic.patch
new file mode 100644
index 000000000000..d4044cc426d8
--- /dev/null
+++ b/sci-mathematics/pari/files/pari-2.11.2-no-automagic.patch
@@ -0,0 +1,74 @@
+diff --git a/config/Makefile.SH b/config/Makefile.SH
+index 6cf5e59ee..7487941f9 100644
+--- a/config/Makefile.SH
++++ b/config/Makefile.SH
+@@ -74,12 +74,12 @@ case "$which_graphic_lib" in
+ ps|svg|none)
+ graph=plot$which_graphic_lib;;
+ Qt4)
+- PLOTCFLAGS="\$(QTINC)"
+- PLOTLIBS="\$(QTLIB) $QTLIBS"
++ PLOTCFLAGS="`pkg-config --cflags QtGui`"
++ PLOTLIBS="`pkg-config --libs QtGui`"
+ graph=plotQt4;;
+ fltk)
+- PLOTCFLAGS=
++ PLOTCFLAGS="`fltk-config --cxxflags` $X11_INC"
+ PLOTLIBS="$FLTK_LIBS"
+ postconfig='fltk-config --post '
+ graph=plotfltk;;
+ win32)
+@@ -267,7 +267,7 @@ RLLIBS = $RLLIBS
+ # GMP
+ GMPINCLUDE = $GMPINCLUDE
+ # Graphic library.
+-QTMOC = $QTMOC
++QTMOC = "`which moc`"
+ QTINC = $QTINC
+ QTLIB = $QTLIB
+ PLOTCFLAGS = $PLOTCFLAGS
+diff --git a/config/get_config_options b/config/get_config_options
+index 4078d2720..5c12bd491 100644
+--- a/config/get_config_options
++++ b/config/get_config_options
+@@ -86,6 +86,7 @@ while test $# -gt 0; do
+ --with-ncurses-lib=*|--with-ncurses=*)
+ with_ncurses_lib=`echo "$1" | sed -e 's/[-a-z]*=//'` ;;
+
++ --without-qt|--with-qt=no) without_qt=yes ;;
+ --with-qt) with_qt=yes ;;
+ --with-qt=*)
+ with_qt=`echo "$1" | sed -e 's/[-a-z]*=//'` ;;
+@@ -94,6 +95,7 @@ while test $# -gt 0; do
+ --with-qt-include=*)
+ with_qt_include=`echo "$1" | sed -e 's/[-a-z]*=//'` ;;
+
++ --without-fltk|--with-fltk=no) without_fltk=yes ;;
+ --with-fltk) with_fltk=yes ;;
+ --with-fltk=*)
+ with_fltk=`echo "$1" | sed -e 's/[-a-z]*=//'` ;;
+@@ -172,10 +174,12 @@ Optional libraries:
+ --with-gmp-lib=DIR specify location of gmp libs
+
+ --with-qt[=DIR] use the Qt graphical library [prefix for Qt dir.]
++ --without-qt do not try to use the Qt lib
+ --with-qt-include=DIR specify location of Qt headers
+ --with-qt-lib=DIR specify location of Qt libs
+
+ --with-fltk use the FLTK graphical library [need fltk-config]
++ --without-fltk do not try to use the FLTK lib
+
+ Miscellaneous
+ --with-runtime-perl[=path-to-perl-binary] for gphelp / tex2mail
+diff --git a/config/get_graphic_lib b/config/get_graphic_lib
+index 4591f2aad..4808aab90 100644
+--- a/config/get_graphic_lib
++++ b/config/get_graphic_lib
+@@ -7,6 +7,7 @@ FLTK_LIBS QTDIR QTLIB"
+
+ if test -n "$with_fltk"; then which_graphic_lib=fltk; fi
+ if test -n "$with_qt"; then which_graphic_lib=Qt; fi
++if test -n "$without_fltk" -a -n "$without_qt"; then which_graphic_lib=none; fi
+ if test "$fastread" != yes; then
+ cat << EOT
+ ==========================================================================