summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-mathematics/mathomatic
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-mathematics/mathomatic')
-rw-r--r--sci-mathematics/mathomatic/Manifest3
-rw-r--r--sci-mathematics/mathomatic/mathomatic-15.8.5.ebuild42
-rw-r--r--sci-mathematics/mathomatic/mathomatic-16.0.1.ebuild42
-rw-r--r--sci-mathematics/mathomatic/mathomatic-16.0.5.ebuild42
-rw-r--r--sci-mathematics/mathomatic/metadata.xml11
5 files changed, 140 insertions, 0 deletions
diff --git a/sci-mathematics/mathomatic/Manifest b/sci-mathematics/mathomatic/Manifest
new file mode 100644
index 000000000000..51564395f8dc
--- /dev/null
+++ b/sci-mathematics/mathomatic/Manifest
@@ -0,0 +1,3 @@
+DIST mathomatic-15.8.5.tar.bz2 270607 SHA256 570065e77196dfca5ad85db4cd9704accf3423fa9552d48a0d847eb67fb7ef98 SHA512 9d8b5fcc369d99b890fde06729daa6c86f1a400d5e42d5fd5d74525b9f4a7c28dea5a05882e753b44590e4624ec7399367a637019867ea85fe68e9e0ed3a3e6e WHIRLPOOL 34c94679cd95cab4bc5b595944d5a82d8cc243dd1203349ca0998ed41e0304d898cbc43fee3155391a2870846dd6d58a404b3cfeedeed05428c4b193135cf94c
+DIST mathomatic-16.0.1.tar.bz2 286365 SHA256 806f64c13f99d17f24681b3e1e5c469f31f7e95776110d7181228ee67e016737 SHA512 d967170b9e02df94fb06019b17e1728e9ec27b9d53abc8a51f333aa0d5d32f2fbcbaba0f1dd3cfbd9905754d38d7057cd639d77f6ecf65eb0177f175b2c500f6 WHIRLPOOL 3eb10303be391d8f889c2159d88e53f302791cfef6632d93f79da481a53fdd4e21d187e1e4f41f941d2ddae3cb0f7b719e3659a0f431360658485b6103ae78e9
+DIST mathomatic-16.0.5.tar.bz2 292220 SHA256 976e6fed1014586bcd584e417c074fa86e4ca6a0fcc2950254da2efde99084ca SHA512 c44c60183442226562df9eefb1d77e5bafd96b7a5d3ad34a76963c586d398647366e782c75ffcf27c2b7d9d4be56678bbbc4d37ac71687a39f04b3fef450cc73 WHIRLPOOL 5d0e01bc829f560e8a84ba8d623f446948a03cd3799361225dcdeb20e96d24031262fef507146330e3d3becde9c1a6b49a5e732f64b7f1283bdc603c68cc1dc9
diff --git a/sci-mathematics/mathomatic/mathomatic-15.8.5.ebuild b/sci-mathematics/mathomatic/mathomatic-15.8.5.ebuild
new file mode 100644
index 000000000000..1ed134b4c31a
--- /dev/null
+++ b/sci-mathematics/mathomatic/mathomatic-15.8.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="Automatic algebraic manipulator"
+HOMEPAGE="http://www.mathomatic.org/"
+SRC_URI="${HOMEPAGE}/archive/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="doc gnuplot"
+
+DEPEND="sys-libs/readline
+ sys-libs/ncurses"
+RDEPEND="${DEPEND}
+ gnuplot? ( sci-visualization/gnuplot )"
+
+src_compile() {
+ append-cflags -DBOLD_COLOR=1
+ emake READLINE=1 CC=$(tc-getCC)
+ emake CC=$(tc-getCC) -C primes
+}
+
+src_test() {
+ default
+ emake -C primes check
+}
+
+src_install() {
+ emake prefix="${EPREFIX}usr" DESTDIR="${D}" bininstall
+ emake prefix="${EPREFIX}usr" DESTDIR="${D}" -C primes install
+ dodoc changes.txt README.txt AUTHORS
+ newdoc primes/README.txt README-primes.txt
+ use doc && emake \
+ prefix="${EPREFIX}usr" \
+ mathdocdir="${EPREFIX}usr/share/doc/${PF}" \
+ DESTDIR="${D}" docinstall
+}
diff --git a/sci-mathematics/mathomatic/mathomatic-16.0.1.ebuild b/sci-mathematics/mathomatic/mathomatic-16.0.1.ebuild
new file mode 100644
index 000000000000..bf517163d080
--- /dev/null
+++ b/sci-mathematics/mathomatic/mathomatic-16.0.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="Automatic algebraic manipulator"
+HOMEPAGE="http://www.mathomatic.org/"
+SRC_URI="${HOMEPAGE}/archive/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc gnuplot"
+
+DEPEND="sys-libs/readline
+ sys-libs/ncurses"
+RDEPEND="${DEPEND}
+ gnuplot? ( sci-visualization/gnuplot )"
+
+src_compile() {
+ append-cflags -DBOLD_COLOR=1
+ emake READLINE=1 CC=$(tc-getCC)
+ emake CC=$(tc-getCC) -C primes
+}
+
+src_test() {
+ default
+ emake -C primes check
+}
+
+src_install() {
+ emake prefix="${EPREFIX}/usr" DESTDIR="${D}" bininstall
+ emake prefix="${EPREFIX}/usr" DESTDIR="${D}" -C primes install
+ dodoc changes.txt README.txt AUTHORS
+ newdoc primes/README.txt README-primes.txt
+ use doc && emake \
+ prefix="${EPREFIX}/usr" \
+ mathdocdir="${EPREFIX}/usr/share/doc/${PF}" \
+ DESTDIR="${D}" docinstall
+}
diff --git a/sci-mathematics/mathomatic/mathomatic-16.0.5.ebuild b/sci-mathematics/mathomatic/mathomatic-16.0.5.ebuild
new file mode 100644
index 000000000000..e8e3c4530ade
--- /dev/null
+++ b/sci-mathematics/mathomatic/mathomatic-16.0.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="Automatic algebraic manipulator"
+HOMEPAGE="http://www.mathomatic.org/"
+SRC_URI="${HOMEPAGE}/archive/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc gnuplot"
+
+DEPEND="sys-libs/readline
+ sys-libs/ncurses"
+RDEPEND="${DEPEND}
+ gnuplot? ( sci-visualization/gnuplot )"
+
+src_compile() {
+ append-cflags -DBOLD_COLOR=1
+ emake READLINE=1 CC=$(tc-getCC)
+ emake CC=$(tc-getCC) -C primes
+}
+
+src_test() {
+ default
+ emake -C primes check
+}
+
+src_install() {
+ emake prefix="${EPREFIX}/usr" DESTDIR="${D}" bininstall m4install
+ emake prefix="${EPREFIX}/usr" DESTDIR="${D}" -C primes install
+ dodoc changes.txt README.txt AUTHORS
+ newdoc primes/README.txt README-primes.txt
+ use doc && emake \
+ prefix="${EPREFIX}/usr" \
+ mathdocdir="${EPREFIX}/usr/share/doc/${PF}" \
+ DESTDIR="${D}" docinstall
+}
diff --git a/sci-mathematics/mathomatic/metadata.xml b/sci-mathematics/mathomatic/metadata.xml
new file mode 100644
index 000000000000..40d859436f67
--- /dev/null
+++ b/sci-mathematics/mathomatic/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-mathematics</herd>
+ <longdescription>
+ Mathomatic is a small, portable symbolic math program that can
+ automatically solve, simplify, differentiate, combine, and compare
+ algebraic equations, perform polynomial and complex arithmetic,
+ etc.
+ </longdescription>
+</pkgmetadata>