summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2024-01-06 20:09:02 -0500
committerMichael Orlitzky <mjo@gentoo.org>2024-01-06 20:38:26 -0500
commit7864bd920d4583ef6f107be02e578f34ab9200af (patch)
tree19624cb15845a5aa1ff5aa4ff0e4c1198299882f /sci-mathematics/eclib
parentnet-libs/quiche: drop versions (diff)
downloadgentoo-7864bd920d4583ef6f107be02e578f34ab9200af.tar.gz
gentoo-7864bd920d4583ef6f107be02e578f34ab9200af.tar.bz2
gentoo-7864bd920d4583ef6f107be02e578f34ab9200af.zip
sci-mathematics/eclib: add 20231212
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-mathematics/eclib')
-rw-r--r--sci-mathematics/eclib/Manifest1
-rw-r--r--sci-mathematics/eclib/eclib-20231212.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/sci-mathematics/eclib/Manifest b/sci-mathematics/eclib/Manifest
index 0beab4361fbc..d5ae1de64af8 100644
--- a/sci-mathematics/eclib/Manifest
+++ b/sci-mathematics/eclib/Manifest
@@ -1 +1,2 @@
DIST eclib-20230424.tar.bz2 923074 BLAKE2B 00c314e54ff2ce37f3aa83b757c0f880aef563093ab33db5241dfeb1e78cfd21be4f6a5097965697d5b87aa1987da17bd47007a599717ebf39456717efa6ad2c SHA512 4c248c48fa563e53b9354f3822c4e95308320a809f2dcc3e116cba8a6f903b333e27b527da9a10dc8252052201c4fcf50d9747a75cf8438a98b9d3828eb3d9d9
+DIST eclib-20231212.tar.bz2 926463 BLAKE2B 8105ac4014f9e44545d1d1e1cd5e18e36e467131b57a04a02d7e4f2390b0b0f78d0bac60dfbc0403a6681816a64a6e81c8d6a198f83bef991f697c2756a6d048 SHA512 692aa6bc2a52cd9496700990172b5a807abbd3f8bf8e931de14c48a401d1d383f95fa5def68bbf9a1aee08dfabac608604c0fd6f8bb49b813e6c6c909a2f27a7
diff --git a/sci-mathematics/eclib/eclib-20231212.ebuild b/sci-mathematics/eclib/eclib-20231212.ebuild
new file mode 100644
index 000000000000..df7ada010cb3
--- /dev/null
+++ b/sci-mathematics/eclib/eclib-20231212.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Programs for elliptic curves defined over the rational numbers"
+HOMEPAGE="https://github.com/JohnCremona/eclib"
+SRC_URI="https://github.com/JohnCremona/${PN}/releases/download/v${PV}/${P}.tar.bz2"
+
+# COPYING is GPL-2 but the file headers say "or ... any later version"
+# LGPL-2.1+ is for bundled GetOpt.cc
+LICENSE="GPL-2+ LGPL-2.1+"
+
+# Subslot is from the soname, (LT_CURRENT - LT_AGE) in configure.ac.
+# (But for now, see src_prepare below.)
+SLOT="0/12"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="boost flint minimal test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="sci-mathematics/pari:=
+ dev-libs/ntl:=
+ boost? ( dev-libs/boost:= )
+ flint? ( sci-mathematics/flint:= )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ # LT_CURRENT was bumped to 12 in the 20230424 release but LT_AGE was
+ # left at two despite an interface being removed. Subsequent releases
+ # have propagated the off-by-two error. This isn't strictly necessary
+ # but it's nice to have the soname match the subslot.
+ sed -e 's/LT_AGE=3/LT_AGE=1/' -i configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(usex minimal --disable-allprogs "" "" "") \
+ $(use_with boost) \
+ $(use_with flint)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}