summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-12-15 12:53:34 +0100
committerDavid Seifert <soap@gentoo.org>2020-12-15 12:53:34 +0100
commite683cd428897c0548827bfe4427fca267158e58a (patch)
tree52532841b7eabc167a4087c9bafbff1bafed65a8 /sci-libs
parentsci-libs/colpack: Remove USE="static-libs" (diff)
downloadgentoo-e683cd428897c0548827bfe4427fca267158e58a.tar.gz
gentoo-e683cd428897c0548827bfe4427fca267158e58a.tar.bz2
gentoo-e683cd428897c0548827bfe4427fca267158e58a.zip
sci-libs/adolc: Remove USE="static-libs"
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/adolc/adolc-2.7.2.ebuild10
-rw-r--r--sci-libs/adolc/adolc-9999.ebuild17
2 files changed, 14 insertions, 13 deletions
diff --git a/sci-libs/adolc/adolc-2.7.2.ebuild b/sci-libs/adolc/adolc-2.7.2.ebuild
index 52d83ebbf38a..e395d9b86954 100644
--- a/sci-libs/adolc/adolc-2.7.2.ebuild
+++ b/sci-libs/adolc/adolc-2.7.2.ebuild
@@ -8,7 +8,7 @@ inherit autotools toolchain-funcs
DESCRIPTION="Automatic differentiation system for C/C++"
HOMEPAGE="https://projects.coin-or.org/ADOL-C/"
-if [[ ${PV} = *9999* ]]; then
+if [[ ${PV} == *9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/coin-or/ADOL-C"
else
@@ -19,7 +19,7 @@ fi
LICENSE="|| ( EPL-1.0 GPL-2 )"
SLOT="0/2"
-IUSE="+boost mpi sparse static-libs"
+IUSE="+boost mpi sparse"
RDEPEND="
boost? ( dev-libs/boost:0= )
@@ -45,12 +45,12 @@ src_configure() {
# https://bugs.gentoo.org/730750
# https://github.com/coin-or/ADOL-C/issues/20
econf \
+ --disable-python \
+ --disable-static \
--enable-advanced-branching \
--enable-atrig-erf \
- --disable-python \
$(use_enable mpi ampi) \
$(use_enable sparse) \
- $(use_enable static-libs static) \
$(use_with boost) \
$(use_with sparse colpack "${EPREFIX}"/usr)
}
@@ -63,5 +63,5 @@ src_test() {
src_install() {
default
- use static-libs || find "${D}" -name '*.la' -type f -delete || die
+ find "${ED}" -name '*.la' -delete || die
}
diff --git a/sci-libs/adolc/adolc-9999.ebuild b/sci-libs/adolc/adolc-9999.ebuild
index dc6d88c74f35..eeaa03bdcee1 100644
--- a/sci-libs/adolc/adolc-9999.ebuild
+++ b/sci-libs/adolc/adolc-9999.ebuild
@@ -3,25 +3,23 @@
EAPI=7
-inherit autotools toolchain-funcs eutils
+inherit autotools toolchain-funcs
DESCRIPTION="Automatic differentiation system for C/C++"
HOMEPAGE="https://projects.coin-or.org/ADOL-C/"
-if [[ ${PV} = *9999* ]]; then
+if [[ ${PV} == *9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/coin-or/ADOL-C"
- SRC_URI=""
- KEYWORDS=""
else
SRC_URI="https://github.com/coin-or/ADOL-C/archive/releases/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
S="${WORKDIR}/ADOL-C-releases-${PV}"
fi
LICENSE="|| ( EPL-1.0 GPL-2 )"
SLOT="0/2"
-IUSE="+boost mpi sparse static-libs"
+IUSE="+boost mpi sparse"
RDEPEND="
boost? ( dev-libs/boost:0= )
@@ -42,20 +40,23 @@ src_prepare() {
src_configure() {
econf \
+ --disable-python \
+ --disable-static \
--enable-advanced-branching \
--enable-atrig-erf \
$(use_enable mpi ampi) \
$(use_enable sparse) \
- $(use_enable static-libs static) \
$(use_with boost) \
$(use_with sparse colpack "${EPREFIX}"/usr)
}
src_test() {
+ # 'check' target is unrelated to checking lib works
+ # ('check' is more like distcheck)
emake test
}
src_install() {
default
- use static-libs || find "${D}" -name '*.la' -type f -delete || die
+ find "${ED}" -name '*.la' -delete || die
}