summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-01 13:44:29 +0100
committerSam James <sam@gentoo.org>2023-05-01 13:48:56 +0100
commitc8f3dfc1071dfac66a0ccfa6a6fe8e0ee2cde3f6 (patch)
treee749e774f59a9b24fc686a7fffcdbdd767fc63f9 /sci-libs
parentsci-chemistry/mdtraj: drop 1.9.4 (diff)
downloadgentoo-c8f3dfc1071dfac66a0ccfa6a6fe8e0ee2cde3f6.tar.gz
gentoo-c8f3dfc1071dfac66a0ccfa6a6fe8e0ee2cde3f6.tar.bz2
gentoo-c8f3dfc1071dfac66a0ccfa6a6fe8e0ee2cde3f6.zip
sci-libs/blis: drop 0.6.0, 0.8.1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/blis/Manifest2
-rw-r--r--sci-libs/blis/blis-0.6.0.ebuild112
-rw-r--r--sci-libs/blis/blis-0.8.1.ebuild112
-rw-r--r--sci-libs/blis/files/blis-0.6.0-rpath.patch13
4 files changed, 0 insertions, 239 deletions
diff --git a/sci-libs/blis/Manifest b/sci-libs/blis/Manifest
index 5e90ff7400e3..feff64952906 100644
--- a/sci-libs/blis/Manifest
+++ b/sci-libs/blis/Manifest
@@ -1,3 +1 @@
-DIST blis-0.6.0.tar.gz 5107257 BLAKE2B cd589ad1216486e8bb0cf574cc096c1e1f2bb9587b182c2bcff44db322468d9f027323c0bf2d22ea0fabb1902dc047d2bf62253ef1c2797fc3de9ba53d7fc34a SHA512 74e9da5146f7986cbd11651d7cd0837562a1603c667b9e6d3f79b5057443de657b60d7463cb2d64daf3eff7d33fc05a64e6d8eb807f4cabe0c3121517924a206
-DIST blis-0.8.1.tar.gz 13442609 BLAKE2B cc4167aaa6461b73876f428de2ab02107803fd6d63df101bf30de4c6ca57241e29f09dfb82fe1cfec8c661b2d9efe65ab854ad7719bf36e27f8a33bf3dd4bb92 SHA512 f920e6ae699af899caca27274b55bb944c886c882dfc06bc2f66d069c08e6d4999c130626cd96297308c1b7e85e77e6552bf981cce37dbbaa5acdf0cb5078e02
DIST blis-0.9.0.tar.gz 15078619 BLAKE2B f7c9632024e0adbba370a4077a7a47f05c54779ad6195b2ccda0950df8e784b8988b4338758ec2fabd424a69009010f8f02cbaef0eda1d74f6794127b43b4f70 SHA512 01e1990eefa4387839ac404089e4ffa32922ceaa30a1747c08a931c67706bcf29fed9d25e30c0faa36bba4f460821290e7973ed6b657d2cd95e126caaf853f81
diff --git a/sci-libs/blis/blis-0.6.0.ebuild b/sci-libs/blis/blis-0.6.0.ebuild
deleted file mode 100644
index 1a2cb188cd4c..000000000000
--- a/sci-libs/blis/blis-0.6.0.ebuild
+++ /dev/null
@@ -1,112 +0,0 @@
-# Copyright 2019-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_9 )
-inherit python-any-r1
-
-DESCRIPTION="BLAS-like Library Instantiation Software Framework"
-HOMEPAGE="https://github.com/flame/blis"
-SRC_URI="https://github.com/flame/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc64 ~x86"
-IUSE="doc eselect-ldso openmp pthread serial 64bit-index"
-REQUIRED_USE="
- ?? ( openmp pthread serial )
- ?? ( eselect-ldso 64bit-index )"
-
-DEPEND="
- eselect-ldso? (
- !app-eselect/eselect-cblas
- >=app-eselect/eselect-blas-0.2
- )"
-
-RDEPEND="${DEPEND}"
-BDEPEND="${PYTHON_DEPS}"
-
-PATCHES=(
- "${FILESDIR}"/${P}-rpath.patch
- "${FILESDIR}"/${P}-blas-provider.patch
-)
-
-src_configure() {
- local BLIS_FLAGS=()
- local confname
- # determine flags
- if use openmp; then
- BLIS_FLAGS+=( -t openmp )
- elif use pthread; then
- BLIS_FLAGS+=( -t pthreads )
- else
- BLIS_FLAGS+=( -t no )
- fi
- use 64bit-index && BLIS_FLAGS+=( -b 64 -i 64 )
- # determine config name
- case "${ARCH}" in
- "x86" | "amd64")
- confname=auto ;;
- "ppc64")
- confname=generic ;;
- *)
- confname=generic ;;
- esac
- # This is not an autotools configure file. We don't use econf here.
- ./configure \
- --enable-verbose-make \
- --prefix="${BROOT}"/usr \
- --libdir="${BROOT}"/usr/$(get_libdir) \
- --disable-static \
- --enable-blas \
- --enable-cblas \
- "${BLIS_FLAGS[@]}" \
- --enable-shared \
- $confname || die
-}
-
-src_compile() {
- DEB_LIBBLAS=libblas.so.3 DEB_LIBCBLAS=libcblas.so.3 \
- LDS_BLAS="${FILESDIR}"/blas.lds LDS_CBLAS="${FILESDIR}"/cblas.lds \
- default
-}
-
-src_test() {
- emake check
-}
-
-src_install() {
- default
- use doc && dodoc README.md docs/*.md
-
- if use eselect-ldso; then
- dodir /usr/$(get_libdir)/blas/blis
- insinto /usr/$(get_libdir)/blas/blis
- doins lib/*/lib{c,}blas.so.3
- dosym libblas.so.3 usr/$(get_libdir)/blas/blis/libblas.so
- dosym libcblas.so.3 usr/$(get_libdir)/blas/blis/libcblas.so
- fi
-}
-
-pkg_postinst() {
- use eselect-ldso || return
-
- local libdir=$(get_libdir) me="blis"
-
- # check blas
- eselect blas add ${libdir} "${EROOT}"/usr/${libdir}/blas/${me} ${me}
- local current_blas=$(eselect blas show ${libdir} | cut -d' ' -f2)
- if [[ ${current_blas} == "${me}" || -z ${current_blas} ]]; then
- eselect blas set ${libdir} ${me}
- elog "Current eselect: BLAS/CBLAS ($libdir) -> [${current_blas}]."
- else
- elog "Current eselect: BLAS/CBLAS ($libdir) -> [${current_blas}]."
- elog "To use blas [${me}] implementation, you have to issue (as root):"
- elog "\t eselect blas set ${libdir} ${me}"
- fi
-}
-
-pkg_postrm() {
- use eselect-ldso && eselect blas validate
-}
diff --git a/sci-libs/blis/blis-0.8.1.ebuild b/sci-libs/blis/blis-0.8.1.ebuild
deleted file mode 100644
index 6fcbb32c9459..000000000000
--- a/sci-libs/blis/blis-0.8.1.ebuild
+++ /dev/null
@@ -1,112 +0,0 @@
-# Copyright 2019-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{9..10} )
-inherit python-any-r1
-
-DESCRIPTION="BLAS-like Library Instantiation Software Framework"
-HOMEPAGE="https://github.com/flame/blis"
-SRC_URI="https://github.com/flame/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc64 ~x86"
-IUSE="doc eselect-ldso openmp pthread serial static-libs 64bit-index"
-REQUIRED_USE="
- ?? ( openmp pthread serial )
- ?? ( eselect-ldso 64bit-index )"
-
-DEPEND="
- eselect-ldso? (
- !app-eselect/eselect-cblas
- >=app-eselect/eselect-blas-0.2
- )"
-
-RDEPEND="${DEPEND}"
-BDEPEND="${PYTHON_DEPS}"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.6.0-rpath.patch
- "${FILESDIR}"/${PN}-0.6.0-blas-provider.patch
- "${FILESDIR}"/${P}-pkg-config.patch
-)
-
-src_configure() {
- local BLIS_FLAGS=()
- local confname
- # determine flags
- if use openmp; then
- BLIS_FLAGS+=( -t openmp )
- elif use pthread; then
- BLIS_FLAGS+=( -t pthreads )
- else
- BLIS_FLAGS+=( -t no )
- fi
- use 64bit-index && BLIS_FLAGS+=( -b 64 -i 64 )
- # determine config name
- case "${ARCH}" in
- "x86" | "amd64")
- confname=auto ;;
- "ppc64")
- confname=generic ;;
- *)
- confname=generic ;;
- esac
- # This is not an autotools configure file. We don't use econf here.
- ./configure \
- --enable-verbose-make \
- --prefix="${BROOT}"/usr \
- --libdir="${BROOT}"/usr/$(get_libdir) \
- $(use_enable static-libs static) \
- --enable-blas \
- --enable-cblas \
- "${BLIS_FLAGS[@]}" \
- --enable-shared \
- $confname || die
-}
-
-src_compile() {
- DEB_LIBBLAS=libblas.so.3 DEB_LIBCBLAS=libcblas.so.3 \
- LDS_BLAS="${FILESDIR}"/blas.lds LDS_CBLAS="${FILESDIR}"/cblas.lds \
- default
-}
-
-src_test() {
- emake check
-}
-
-src_install() {
- default
- use doc && dodoc README.md docs/*.md
-
- if use eselect-ldso; then
- insinto /usr/$(get_libdir)/blas/blis
- doins lib/*/lib{c,}blas.so.3
- dosym libblas.so.3 usr/$(get_libdir)/blas/blis/libblas.so
- dosym libcblas.so.3 usr/$(get_libdir)/blas/blis/libcblas.so
- fi
-}
-
-pkg_postinst() {
- use eselect-ldso || return
-
- local libdir=$(get_libdir) me="blis"
-
- # check blas
- eselect blas add ${libdir} "${EROOT}"/usr/${libdir}/blas/${me} ${me}
- local current_blas=$(eselect blas show ${libdir} | cut -d' ' -f2)
- if [[ ${current_blas} == "${me}" || -z ${current_blas} ]]; then
- eselect blas set ${libdir} ${me}
- elog "Current eselect: BLAS/CBLAS ($libdir) -> [${current_blas}]."
- else
- elog "Current eselect: BLAS/CBLAS ($libdir) -> [${current_blas}]."
- elog "To use blas [${me}] implementation, you have to issue (as root):"
- elog "\t eselect blas set ${libdir} ${me}"
- fi
-}
-
-pkg_postrm() {
- use eselect-ldso && eselect blas validate
-}
diff --git a/sci-libs/blis/files/blis-0.6.0-rpath.patch b/sci-libs/blis/files/blis-0.6.0-rpath.patch
deleted file mode 100644
index a8b5a46870d1..000000000000
--- a/sci-libs/blis/files/blis-0.6.0-rpath.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/common.mk b/common.mk
-index ef0acfb..e1ce31d 100644
---- a/common.mk
-+++ b/common.mk
-@@ -527,7 +527,7 @@ LIBBLIS_L := $(LIBBLIS_SO)
- LIBBLIS_LINK := $(LIBBLIS_SO_PATH)
- ifeq ($(IS_WIN),no)
- # For Linux and OS X: set rpath property of shared object.
--LDFLAGS += -Wl,-rpath,$(BASE_LIB_PATH)
-+#LDFLAGS += -Wl,-rpath,$(BASE_LIB_PATH)
- endif
- endif
- endif