summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2023-07-28 22:39:31 +0800
committerBenda Xu <heroxbd@gentoo.org>2023-07-29 10:54:52 +0800
commitc2b4cbc54fa45e1145ecc7d91d5545a90391de62 (patch)
tree236708ea3c68089f3d301f4ad8dd628c95701a88 /sci-libs
parentsci-libs/rocSOLVER: non-versioned dependency on libfmt. (diff)
downloadgentoo-c2b4cbc54fa45e1145ecc7d91d5545a90391de62.tar.gz
gentoo-c2b4cbc54fa45e1145ecc7d91d5545a90391de62.tar.bz2
gentoo-c2b4cbc54fa45e1145ecc7d91d5545a90391de62.zip
sci-libs/hipBLAS: add 5.4.2 to stick to FHS header locations.
Bug: https://bugs.gentoo.org/911400 Signed-off-by: Benda Xu <heroxbd@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/hipBLAS/Manifest1
-rw-r--r--sci-libs/hipBLAS/hipBLAS-5.4.2.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/sci-libs/hipBLAS/Manifest b/sci-libs/hipBLAS/Manifest
index 99698f6b1488..6dcf1b1dd925 100644
--- a/sci-libs/hipBLAS/Manifest
+++ b/sci-libs/hipBLAS/Manifest
@@ -1 +1,2 @@
DIST hipBLAS-5.1.3.tar.gz 526704 BLAKE2B d32d7029ea910c341e00dccab1ee9ab984518368cf38524f2264bb808cc1242b3d57db283937650f54460cb01174ec90f02c4bd66866cba4be5d0a1855814f0e SHA512 41dbc86b7ea53e7c0f1d629130f90b719f864ceddae972f1c68911e97b6233286f0c22c0fcfce049ae7db73a1ed41bdaf730040c72f1790fca367362c14ac707
+DIST hipBLAS-5.4.2.tar.gz 930814 BLAKE2B 702df09010b50652feb8f7e5741b27117aa58fc3e3b1b5f89f5043073a47581d1710f0831740453e84f7594b1b305e95d2681709898e5231c3eee2e8207404a3 SHA512 a941350d2d25022cf5142f68559242a048136bdd048dafcd544a0241cf3b510062273163f7a0eecc55f17ec47a1063d84d6102ca766ba7cde9b704eee5c44cd8
diff --git a/sci-libs/hipBLAS/hipBLAS-5.4.2.ebuild b/sci-libs/hipBLAS/hipBLAS-5.4.2.ebuild
new file mode 100644
index 000000000000..b61f8865b925
--- /dev/null
+++ b/sci-libs/hipBLAS/hipBLAS-5.4.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ROCM_VERSION=${PV}
+
+inherit cmake rocm
+DESCRIPTION="ROCm BLAS marshalling library"
+HOMEPAGE="https://github.com/ROCmSoftwarePlatform/hipBLAS"
+SRC_URI="https://github.com/ROCmSoftwarePlatform/hipBLAS/archive/rocm-${PV}.tar.gz -> ${P}.tar.gz"
+REQUIRED_USE="${ROCM_REQUIRED_USE}"
+
+LICENSE="MIT"
+KEYWORDS="~amd64"
+SLOT="0/$(ver_cut 1-2)"
+
+RDEPEND="dev-util/hip
+ sci-libs/rocBLAS:${SLOT}[${ROCM_USEDEP}]
+ sci-libs/rocSOLVER:${SLOT}[${ROCM_USEDEP}]"
+DEPEND="${RDEPEND}"
+BDEPEND=""
+
+S="${WORKDIR}/hipBLAS-rocm-${PV}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_CLIENTS_TESTS=OFF # currently hipBLAS is a wrapper of rocBLAS which has tests, so no need to perform test here
+ -DBUILD_CLIENTS_BENCHMARKS=OFF
+ -DBUILD_FILE_REORG_BACKWARD_COMPATIBILITY=OFF
+ -DROCM_SYMLINK_LIBS=OFF
+ )
+
+ CXX=hipcc cmake_src_configure
+}