summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2021-01-17 14:35:40 +0100
committerPacho Ramos <pacho@gentoo.org>2021-01-17 14:36:54 +0100
commitaef15e5534ffcd09c18986004f9e09175e3ced80 (patch)
treefb307866bb7d168e7bf851d4eb08c06e61beab87 /sci-libs
parentnet-misc/realtek-r8152: support building with non default CC. (diff)
downloadgentoo-aef15e5534ffcd09c18986004f9e09175e3ced80.tar.gz
gentoo-aef15e5534ffcd09c18986004f9e09175e3ced80.tar.bz2
gentoo-aef15e5534ffcd09c18986004f9e09175e3ced80.zip
Revert "sci-libs/netcdf: Remove old"
This reverts commit d7fda45912661dcccd5ec1dd17ca0b5831ac66d0 because it removed latest stable version Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/netcdf/Manifest1
-rw-r--r--sci-libs/netcdf/netcdf-4.6.1-r1.ebuild54
-rw-r--r--sci-libs/netcdf/netcdf-4.6.1.ebuild54
3 files changed, 109 insertions, 0 deletions
diff --git a/sci-libs/netcdf/Manifest b/sci-libs/netcdf/Manifest
index 3a7402200224..f0ad551c5b0a 100644
--- a/sci-libs/netcdf/Manifest
+++ b/sci-libs/netcdf/Manifest
@@ -1,2 +1,3 @@
DIST netcdf-4.3.2.tar.gz 5013938 BLAKE2B 7acef16284bf8586750bdeb03da3e2e2a1c543b80423269eb2542d179e1b52dd51e30584a13f604e75c295ae9ff993c814183fbb5a78ad1141c62f8dbdda6525 SHA512 9cb9c761bf1e17a37601c37000fdc0bb654afcf111e5ac2fb7dcf037c6aa827e66beb29d5c661edc50ea3f84849f3dee387aab9e85ef81a9b6ca3f36e45debdd
+DIST netcdf-4.6.1.tar.gz 18201700 BLAKE2B 2dab9add736d0db3ad91fb1ccda63c200fe5a2c6e56e2dd5b76375f6535807c6f462623d1709235f03e0940b66a8c2d1c3fd896b042b8b0004c87f038852befb SHA512 e290b10e763f9f6ef56b5224f834834853de7c21347ef6a078a2e7d819757fc8069814431784d0a0387ba2ce1f01776556e3051f9465829da0ffd3849571cd61
DIST netcdf-4.7.4.tar.gz 19711158 BLAKE2B b49532e6f87b458e7f5654f70ec932d6c8c81272c97ce44df3d27bb61b01d3e005f918b959ce12e42e26f7c12309ab72eeb57a35216d20ab5761837db65741a4 SHA512 15922818fdd71be285eb7dd2fc9be2594fe9af979de3ed316465636c7bbdaec65eb151ca57ef8b703e6a360cdba036b8f9bc193ddff01ff7ce4214c0a66efa79
diff --git a/sci-libs/netcdf/netcdf-4.6.1-r1.ebuild b/sci-libs/netcdf/netcdf-4.6.1-r1.ebuild
new file mode 100644
index 000000000000..d7770061f7a7
--- /dev/null
+++ b/sci-libs/netcdf/netcdf-4.6.1-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils ltprune
+
+DESCRIPTION="Scientific library and interface for array oriented data access"
+HOMEPAGE="https://www.unidata.ucar.edu/software/netcdf/"
+SRC_URI="https://github.com/Unidata/netcdf-c/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="UCAR-Unidata"
+SLOT="0/13"
+KEYWORDS="amd64 ~arm ~ia64 ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="+dap examples hdf +hdf5 mpi static-libs szip test tools"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dap? ( net-misc/curl:0= )
+ hdf? ( sci-libs/hdf:0= sci-libs/hdf5:0= )
+ hdf5? ( sci-libs/hdf5:0=[hl(+),mpi=,szip=,zlib] )"
+DEPEND="${RDEPEND}"
+# doc generation is missing many doxygen files in tar ball
+# doc? ( app-doc/doxygen[dot] )"
+
+REQUIRED_USE="test? ( tools ) szip? ( hdf5 ) mpi? ( hdf5 )"
+
+S="${WORKDIR}/${PN}-c-${PV}"
+
+src_configure() {
+ local myconf
+ if use mpi; then
+ export CC=mpicc
+ fi
+ econf "${myconf}" \
+ --disable-examples \
+ --disable-dap-remote-tests \
+ $(use_enable dap) \
+ $(use_enable hdf hdf4) \
+ $(use_enable hdf5 netcdf-4) \
+ $(use_enable static-libs static) \
+ $(use_enable tools utilities)
+}
+
+src_test() {
+ # fails parallel tests: bug #621486
+ emake check -j1
+}
+
+src_install() {
+ default
+ use examples && dodoc -r examples
+ prune_libtool_files
+}
diff --git a/sci-libs/netcdf/netcdf-4.6.1.ebuild b/sci-libs/netcdf/netcdf-4.6.1.ebuild
new file mode 100644
index 000000000000..ed2f91c0b4a4
--- /dev/null
+++ b/sci-libs/netcdf/netcdf-4.6.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils ltprune
+
+DESCRIPTION="Scientific library and interface for array oriented data access"
+HOMEPAGE="https://www.unidata.ucar.edu/software/netcdf/"
+SRC_URI="https://github.com/Unidata/netcdf-c/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="UCAR-Unidata"
+SLOT="0/11"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+dap examples hdf +hdf5 mpi static-libs szip test tools"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dap? ( net-misc/curl:0= )
+ hdf? ( sci-libs/hdf:0= sci-libs/hdf5:0= )
+ hdf5? ( sci-libs/hdf5:0=[hl(+),mpi=,szip=,zlib] )"
+DEPEND="${RDEPEND}"
+# doc generation is missing many doxygen files in tar ball
+# doc? ( app-doc/doxygen[dot] )"
+
+REQUIRED_USE="test? ( tools ) szip? ( hdf5 ) mpi? ( hdf5 )"
+
+S="${WORKDIR}/${PN}-c-${PV}"
+
+src_configure() {
+ local myconf
+ if use mpi; then
+ export CC=mpicc
+ fi
+ econf "${myconf}" \
+ --disable-examples \
+ --disable-dap-remote-tests \
+ $(use_enable dap) \
+ $(use_enable hdf hdf4) \
+ $(use_enable hdf5 netcdf-4) \
+ $(use_enable static-libs static) \
+ $(use_enable tools utilities)
+}
+
+src_test() {
+ # fails parallel tests: bug #621486
+ emake check -j1
+}
+
+src_install() {
+ default
+ use examples && dodoc -r examples
+ prune_libtool_files
+}