summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2022-11-22 14:00:09 -0800
committerJason Zaman <perfinion@gentoo.org>2022-11-25 10:22:02 -0800
commit5037a2db45fc8531516a792fb30a60eab3f2d320 (patch)
treeeb7e64f8cea60a4183c9cea0a194fed94f2164c1 /sci-libs
parentsci-visualization/tensorboard: add 2.11.0 (diff)
downloadgentoo-5037a2db45fc8531516a792fb30a60eab3f2d320.tar.gz
gentoo-5037a2db45fc8531516a792fb30a60eab3f2d320.tar.bz2
gentoo-5037a2db45fc8531516a792fb30a60eab3f2d320.zip
sci-libs/tensorflow-estimator: add 2.11.0
Signed-off-by: Jason Zaman <perfinion@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/tensorflow-estimator/Manifest1
-rw-r--r--sci-libs/tensorflow-estimator/files/0001-Update-setup.py-for-2.11.0-final-release.patch25
-rw-r--r--sci-libs/tensorflow-estimator/tensorflow-estimator-2.11.0.ebuild79
3 files changed, 105 insertions, 0 deletions
diff --git a/sci-libs/tensorflow-estimator/Manifest b/sci-libs/tensorflow-estimator/Manifest
index 7ca0a51f3836..c208fabb6300 100644
--- a/sci-libs/tensorflow-estimator/Manifest
+++ b/sci-libs/tensorflow-estimator/Manifest
@@ -1,3 +1,4 @@
DIST bazelbuild-rules_cc-b1c40e1de81913a3c40e5948f78719c28152486d.zip 201360 BLAKE2B 0173a8edb17f344b18e42026e2f8a62a1909d4694ab0be83562b6437a3f1ef38889f069269ddd2308b41062e5f375f791be0d2631a8e52ede668203779813b56 SHA512 2ba1dc316d88947c1d17ec67154c052700e3571b8d03370a9f204cf9fe94a1bd58f93a2c4a3c0b02233ee3250053a4c30a4133b5b38745858c1d04be8c9d973f
DIST bazelbuild-rules_java-7cf3cefd652008d0a64a419c34c13bdca6c8f178.zip 9422 BLAKE2B bbc45c97551ee8126335b611ffca6574dac843d4db9b3221b10d26487f8eecfe38ba0cd67a4039a3ad921c25fea6294c43e4f4e7a57a060a30791acd6c4f9d39 SHA512 ba06242feb711e7fb6e821fd9ac029248b4f3e466fb1acf971d0db8196f3efe4d114ef137acbe4913073f8cbe8ccab4d47d8bafa21b867b2d6a6d57f5a647f0c
DIST tensorflow-estimator-2.10.tar.gz 655011 BLAKE2B 465b405bfc5b776bc9722407f0d475b4ce8a520bded4b6f0db4c9fc771b9486a4ef08ae460f2e1c8c4be1d2882b942fff79f7f08a458eaa444f1bb44eb66e91c SHA512 63cdc97d9abf3551a931372ab91e86b1cab761ea7476182ed82ac7c56884d315107b1873376385bcdfc531465c11fe0273aefe8b88e8b333d8e7b54e7d0a09eb
+DIST tensorflow-estimator-2.11.0-rc0.tar.gz 655514 BLAKE2B cc73f282a32f657bf507d948210aa981f0867c4898574c61fb5654204fa573ac7bdef16635d202ed3d202ccc9c8915f5613e4149ce6839d59281a38cfd6953f7 SHA512 c473a6db62a0a55f25f8fd5fd7ffb2f2a473261c5a7b3217bd1d8a21a02ab4871793ea57917c6eb9dc9012bd030faf8030702caf3f764983ce526d201866204f
diff --git a/sci-libs/tensorflow-estimator/files/0001-Update-setup.py-for-2.11.0-final-release.patch b/sci-libs/tensorflow-estimator/files/0001-Update-setup.py-for-2.11.0-final-release.patch
new file mode 100644
index 000000000000..3a22052e9845
--- /dev/null
+++ b/sci-libs/tensorflow-estimator/files/0001-Update-setup.py-for-2.11.0-final-release.patch
@@ -0,0 +1,25 @@
+From bfc826cf6ab1a65c3cf2e28cf9c6300ced56e9f8 Mon Sep 17 00:00:00 2001
+From: Vinila S <106367904+vinila21@users.noreply.github.com>
+Date: Fri, 11 Nov 2022 16:55:11 -0800
+Subject: [PATCH] Update setup.py for 2.11.0 final release.
+
+---
+ tensorflow_estimator/tools/pip_package/setup.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tensorflow_estimator/tools/pip_package/setup.py b/tensorflow_estimator/tools/pip_package/setup.py
+index b49eff2..fe35b4b 100644
+--- a/tensorflow_estimator/tools/pip_package/setup.py
++++ b/tensorflow_estimator/tools/pip_package/setup.py
+@@ -30,7 +30,7 @@ DOCLINES = __doc__.split('\n')
+ # This version string is semver compatible, but incompatible with pip.
+ # For pip, we will remove all '-' characters from this string, and use the
+ # result for pip.
+-_VERSION = '2.11.0-rc0'
++_VERSION = '2.11.0'
+
+ REQUIRED_PACKAGES = [
+ # We depend on TensorFlow's declared pip dependencies.
+--
+2.37.4
+
diff --git a/sci-libs/tensorflow-estimator/tensorflow-estimator-2.11.0.ebuild b/sci-libs/tensorflow-estimator/tensorflow-estimator-2.11.0.ebuild
new file mode 100644
index 000000000000..fdf1ef3c5276
--- /dev/null
+++ b/sci-libs/tensorflow-estimator/tensorflow-estimator-2.11.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8,9,10} )
+MY_PN="estimator"
+MY_PV=${PV}-rc0
+MY_P=${MY_PN}-${MY_PV}
+
+inherit bazel distutils-r1
+
+DESCRIPTION="A high-level TensorFlow API that greatly simplifies machine learning programming"
+HOMEPAGE="https://www.tensorflow.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+bazel_external_uris="
+ https://github.com/bazelbuild/rules_cc/archive/b1c40e1de81913a3c40e5948f78719c28152486d.zip -> bazelbuild-rules_cc-b1c40e1de81913a3c40e5948f78719c28152486d.zip
+ https://github.com/bazelbuild/rules_java/archive/7cf3cefd652008d0a64a419c34c13bdca6c8f178.zip -> bazelbuild-rules_java-7cf3cefd652008d0a64a419c34c13bdca6c8f178.zip"
+
+SRC_URI="https://github.com/tensorflow/${MY_PN}/archive/v${MY_PV}.tar.gz -> ${P}-rc0.tar.gz
+ ${bazel_external_uris}"
+
+RDEPEND="
+ sci-libs/tensorflow[python,${PYTHON_USEDEP}]
+ sci-libs/keras[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-arch/unzip
+ dev-java/java-config
+ >=dev-util/bazel-5.1.1"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( CONTRIBUTING.md README.md )
+PATCHES=(
+ # Tag is missing for v2.11.0, apply version update manually
+ "${FILESDIR}/0001-Update-setup.py-for-2.11.0-final-release.patch"
+)
+
+src_unpack() {
+ unpack "${P}-rc0.tar.gz"
+ bazel_load_distfiles "${bazel_external_uris}"
+}
+
+src_prepare() {
+ bazel_setup_bazelrc
+ default
+ python_copy_sources
+}
+
+python_compile() {
+ pushd "${BUILD_DIR}" >/dev/null || die
+
+ ebazel build //tensorflow_estimator/tools/pip_package:build_pip_package
+ ebazel shutdown
+
+ local srcdir="${T}/src-${EPYTHON/./_}"
+ mkdir -p "${srcdir}" || die
+ bazel-bin/tensorflow_estimator/tools/pip_package/build_pip_package --src "${srcdir}" || die
+
+ popd >/dev/null || die
+}
+
+src_compile() {
+ export JAVA_HOME=$(java-config --jre-home)
+ distutils-r1_src_compile
+}
+
+python_install() {
+ pushd "${T}/src-${EPYTHON/./_}" >/dev/null || die
+ esetup.py install
+ python_optimize
+ popd >/dev/null || die
+}