summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrançois Bissey <frp.bissey@gmail.com>2023-06-06 08:59:21 +1200
committerMichael Orlitzky <mjo@gentoo.org>2023-06-19 20:01:14 -0400
commit4b20407b767f00948a70016fa16c391167f1dc67 (patch)
tree948d319b020a3c725e76dc06d7670cd888bef9f8 /sci-libs
parentsci-libs/camd: add 3.0.3 (diff)
downloadgentoo-4b20407b767f00948a70016fa16c391167f1dc67.tar.gz
gentoo-4b20407b767f00948a70016fa16c391167f1dc67.tar.bz2
gentoo-4b20407b767f00948a70016fa16c391167f1dc67.zip
sci-libs/colamd: add 3.0.3
Signed-off-by: François Bissey <frp.bissey@gmail.com> Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/colamd/Manifest1
-rw-r--r--sci-libs/colamd/colamd-3.0.3.ebuild39
-rw-r--r--sci-libs/colamd/metadata.xml3
3 files changed, 43 insertions, 0 deletions
diff --git a/sci-libs/colamd/Manifest b/sci-libs/colamd/Manifest
index d892a2a7e321..a699b1aea285 100644
--- a/sci-libs/colamd/Manifest
+++ b/sci-libs/colamd/Manifest
@@ -1 +1,2 @@
+DIST SuiteSparse-7.0.0.gh.tar.gz 64884962 BLAKE2B 06c6cf54ffae188f5179e0cd45523700448d8999b44d6b1aeb3dfb99ccf34a570f6aff600988a144c68a4a2d8f41e32f7145e09349aed3bd889501ea031c8340 SHA512 50b1cd7bab6e4c063984162ed803fd13b69df7f67efe8ce7af15eace6b0ccd1669b6e57daa59511fd9531a847433cda49c1f52bfff234031af0d79e7fbd6423e
DIST colamd-2.9.6.tar.bz2 298903 BLAKE2B e1e3cfa0153e21b742854d28fb6d3ede287c2ec22cfef4268a8aba8bb239be527433907f6984dad976341cf6e1ca9cb39f5c97029ad9bed032a874add9aa0e02 SHA512 f302d18f9ba004c9d1b0e1ada76e70f20fa1d11896815e5300983513b7ed4a7b969adef33adb1a57d67ce856a5ded410874c23d9bba42b6bf1a6a790430f5137
diff --git a/sci-libs/colamd/colamd-3.0.3.ebuild b/sci-libs/colamd/colamd-3.0.3.ebuild
new file mode 100644
index 000000000000..bb834c744386
--- /dev/null
+++ b/sci-libs/colamd/colamd-3.0.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+Sparse_PV="7.0.0"
+Sparse_P="SuiteSparse-${Sparse_PV}"
+DESCRIPTION="Column approximate minimum degree ordering algorithm"
+HOMEPAGE="https://people.engr.tamu.edu/davis/suitesparse.html"
+SRC_URI="https://github.com/DrTimothyAldenDavis/SuiteSparse/archive/refs/tags/v${Sparse_PV}.tar.gz -> ${Sparse_P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND=">=sci-libs/suitesparseconfig-${Sparse_PV}"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${Sparse_P}/${PN^^}"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DNSTATIC=ON
+ -DDEMO=$(usex test)
+ )
+ cmake_src_configure
+}
+
+multilib_src_test() {
+ # Run demo files
+ ./colamd_example > colamd_example.out
+ diff "${S}"/Demo/colamd_example.out colamd_example.out || die "failed testing colamd_example"
+ ./colamd_l_example > colamd_l_example.out
+ diff "${S}"/Demo/colamd_l_example.out colamd_l_example.out || die "failed testing colamd_l_example"
+}
diff --git a/sci-libs/colamd/metadata.xml b/sci-libs/colamd/metadata.xml
index 249c30df3a5c..568cb46d3cfe 100644
--- a/sci-libs/colamd/metadata.xml
+++ b/sci-libs/colamd/metadata.xml
@@ -15,4 +15,7 @@
matrix M such that M\'*M has the same pattern as A, and then uses
COLAMD to compute a column ordering of M.
</longdescription>
+ <upstream>
+ <remote-id type="github">DrTimothyAldenDavis/SuiteSparse</remote-id>
+ </upstream>
</pkgmetadata>