summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/silo/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/silo/files')
-rw-r--r--sci-libs/silo/files/silo-4.10.2-qtlibs.patch66
-rw-r--r--sci-libs/silo/files/silo-4.10.2-tests.patch11
-rw-r--r--sci-libs/silo/files/silo-4.9.1-qtlibs.patch66
-rw-r--r--sci-libs/silo/files/silo-4.9.1-tests.patch11
4 files changed, 154 insertions, 0 deletions
diff --git a/sci-libs/silo/files/silo-4.10.2-qtlibs.patch b/sci-libs/silo/files/silo-4.10.2-qtlibs.patch
new file mode 100644
index 000000000000..e8fc4284cac0
--- /dev/null
+++ b/sci-libs/silo/files/silo-4.10.2-qtlibs.patch
@@ -0,0 +1,66 @@
+diff -ru silo-4.9.1-old/configure silo-4.9.1-new/configure
+--- silo-4.9.1-old/configure 2014-01-18 23:19:15.755030306 +0100
++++ silo-4.9.1-new/configure 2014-01-18 23:20:52.595031159 +0100
+@@ -27503,7 +27503,7 @@
+ ax_qt_lib="`ls $ax_qt_lib_dir/libQt* | sed -n 1p |
+ sed s@$ax_qt_lib_dir/lib@@ | sed s@[.].*@@`"
+ fi
+- ax_qt_LIBS="-L$ax_qt_lib_dir -l$ax_qt_lib $X_PRE_LIBS $X_LIBS -lX11 -lXext -lXmu -lXt -lXi $X_EXTRA_LIBS"
++ ax_qt_LIBS="-L$ax_qt_lib_dir -l$ax_qt_lib $X_PRE_LIBS $X_LIBS -lQtCore -lQtGui -lX11 -lXext -lXmu -lXt -lXi $X_EXTRA_LIBS"
+ else
+ # Use cached value or do search, starting with suggestions from
+ # the command line
+@@ -27577,7 +27577,7 @@
+ ax_qt_lib="`ls $ax_qt_lib_dir/libQt* | sed -n 1p |
+ sed s@$ax_qt_lib_dir/lib@@ | sed s@[.].*@@`"
+ fi
+- ax_qt_LIBS="-L$ax_qt_lib_dir -l$ax_qt_lib $X_PRE_LIBS $X_LIBS -lX11 -lXext -lXmu -lXt -lXi $X_EXTRA_LIBS"
++ ax_qt_LIBS="-L$ax_qt_lib_dir -l$ax_qt_lib $X_PRE_LIBS $X_LIBS -lQtCore -lQtGui -lX11 -lXext -lXmu -lXt -lXi $X_EXTRA_LIBS"
+ else
+ # There is no valid definition for $QTDIR as Trolltech likes to see it
+ ax_qt_dir=
+@@ -27589,7 +27589,7 @@
+ ax_qt_lib="`ls $ax_qt_lib_dir/libQt* | sed -n 1p |
+ sed s@$ax_qt_lib_dir/lib@@ | sed s@[.].*@@`"
+ fi
+- ax_qt_LIBS="-L$ax_qt_lib_dir -l$ax_qt_lib $X_PRE_LIBS $X_LIBS -lX11 -lXext -lXmu -lXt -lXi $X_EXTRA_LIBS"
++ ax_qt_LIBS="-L$ax_qt_lib_dir -l$ax_qt_lib $X_PRE_LIBS $X_LIBS -lQtCore -lQtGui -lX11 -lXext -lXmu -lXt -lXi $X_EXTRA_LIBS"
+ else
+ # Normally, when there is no traditional Trolltech installation,
+ # the library is installed in a place where the linker finds it
+@@ -27607,7 +27607,7 @@
+ # See if we find the library without any special options.
+ # Don't add top $LIBS permanently yet
+ ax_save_LIBS="$LIBS"
+- LIBS="-l$ax_qt_lib $X_PRE_LIBS $X_LIBS -lX11 -lXext -lXmu -lXt -lXi $X_EXTRA_LIBS"
++ LIBS="-l$ax_qt_lib $X_PRE_LIBS $X_LIBS -lQtCore -lQtGui -lX11 -lXext -lXmu -lXt -lXi $X_EXTRA_LIBS"
+ ax_qt_LIBS="$LIBS"
+ ax_save_CXXFLAGS="$CXXFLAGS"
+ CXXFLAGS="-I$ax_qt_include_dir -I$ax_qt_include_dir/Qt -I$ax_qt_include_dir/QtCore -I$ax_qt_include_dir/QtGui"
+@@ -27668,7 +27668,7 @@
+ # That did not work. Try the multi-threaded version
+ echo "Non-critical error, please neglect the above." >&5
+ ax_qt_lib=qt-mt
+- LIBS="-l$ax_qt_lib $X_PRE_LIBS $X_LIBS -lX11 -lXext -lXmu -lXt -lXi $X_EXTRA_LIBS"
++ LIBS="-l$ax_qt_lib $X_PRE_LIBS $X_LIBS -lQtCore -lQtGui -lX11 -lXext -lXmu -lXt -lXi $X_EXTRA_LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */
+ _ACEOF
+@@ -27726,7 +27726,7 @@
+ # That did not work. Try the OpenGL version
+ echo "Non-critical error, please neglect the above." >&5
+ ax_qt_lib=qt-gl
+- LIBS="-l$ax_qt_lib $X_PRE_LIBS $X_LIBS -lX11 -lXext -lXmu -lXt -lXi $X_EXTRA_LIBS"
++ LIBS="-l$ax_qt_lib $X_PRE_LIBS $X_LIBS -lQtCore -lQtGui -lX11 -lXext -lXmu -lXt -lXi $X_EXTRA_LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */
+ _ACEOF
+@@ -27809,7 +27809,7 @@
+ fi
+ done
+ # Try with that one
+- LIBS="-l$ax_qt_lib $X_PRE_LIBS $X_LIBS -lX11 -lXext -lXmu -lXt -lXi $X_EXTRA_LIBS"
++ LIBS="-l$ax_qt_lib $X_PRE_LIBS $X_LIBS -lQtCore -lQtGui -lX11 -lXext -lXmu -lXt -lXi $X_EXTRA_LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */
+ _ACEOF
diff --git a/sci-libs/silo/files/silo-4.10.2-tests.patch b/sci-libs/silo/files/silo-4.10.2-tests.patch
new file mode 100644
index 000000000000..2e0a52191d0e
--- /dev/null
+++ b/sci-libs/silo/files/silo-4.10.2-tests.patch
@@ -0,0 +1,11 @@
+--- tests/Makefile.in.old 2014-07-24 07:25:53.464381420 +0200
++++ tests/Makefile.in 2014-07-24 07:26:14.951048323 +0200
+@@ -169,7 +169,7 @@
+ $(LIBTOOLFLAGS) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
+ $(ioperf_stdio_la_LDFLAGS) $(LDFLAGS) -o $@
+ rocket_silo_la_LIBADD =
+-am_rocket_silo_la_OBJECTS = rocket_silo.lo
++am_rocket_silo_la_OBJECTS = rocket_silo.lo ../src/.libs/libsilo.la
+ rocket_silo_la_OBJECTS = $(am_rocket_silo_la_OBJECTS)
+ rocket_silo_la_LINK = $(LIBTOOL) --tag=CXX $(AM_LIBTOOLFLAGS) \
+ $(LIBTOOLFLAGS) --mode=link $(CXXLD) $(AM_CXXFLAGS) \
diff --git a/sci-libs/silo/files/silo-4.9.1-qtlibs.patch b/sci-libs/silo/files/silo-4.9.1-qtlibs.patch
new file mode 100644
index 000000000000..e8fc4284cac0
--- /dev/null
+++ b/sci-libs/silo/files/silo-4.9.1-qtlibs.patch
@@ -0,0 +1,66 @@
+diff -ru silo-4.9.1-old/configure silo-4.9.1-new/configure
+--- silo-4.9.1-old/configure 2014-01-18 23:19:15.755030306 +0100
++++ silo-4.9.1-new/configure 2014-01-18 23:20:52.595031159 +0100
+@@ -27503,7 +27503,7 @@
+ ax_qt_lib="`ls $ax_qt_lib_dir/libQt* | sed -n 1p |
+ sed s@$ax_qt_lib_dir/lib@@ | sed s@[.].*@@`"
+ fi
+- ax_qt_LIBS="-L$ax_qt_lib_dir -l$ax_qt_lib $X_PRE_LIBS $X_LIBS -lX11 -lXext -lXmu -lXt -lXi $X_EXTRA_LIBS"
++ ax_qt_LIBS="-L$ax_qt_lib_dir -l$ax_qt_lib $X_PRE_LIBS $X_LIBS -lQtCore -lQtGui -lX11 -lXext -lXmu -lXt -lXi $X_EXTRA_LIBS"
+ else
+ # Use cached value or do search, starting with suggestions from
+ # the command line
+@@ -27577,7 +27577,7 @@
+ ax_qt_lib="`ls $ax_qt_lib_dir/libQt* | sed -n 1p |
+ sed s@$ax_qt_lib_dir/lib@@ | sed s@[.].*@@`"
+ fi
+- ax_qt_LIBS="-L$ax_qt_lib_dir -l$ax_qt_lib $X_PRE_LIBS $X_LIBS -lX11 -lXext -lXmu -lXt -lXi $X_EXTRA_LIBS"
++ ax_qt_LIBS="-L$ax_qt_lib_dir -l$ax_qt_lib $X_PRE_LIBS $X_LIBS -lQtCore -lQtGui -lX11 -lXext -lXmu -lXt -lXi $X_EXTRA_LIBS"
+ else
+ # There is no valid definition for $QTDIR as Trolltech likes to see it
+ ax_qt_dir=
+@@ -27589,7 +27589,7 @@
+ ax_qt_lib="`ls $ax_qt_lib_dir/libQt* | sed -n 1p |
+ sed s@$ax_qt_lib_dir/lib@@ | sed s@[.].*@@`"
+ fi
+- ax_qt_LIBS="-L$ax_qt_lib_dir -l$ax_qt_lib $X_PRE_LIBS $X_LIBS -lX11 -lXext -lXmu -lXt -lXi $X_EXTRA_LIBS"
++ ax_qt_LIBS="-L$ax_qt_lib_dir -l$ax_qt_lib $X_PRE_LIBS $X_LIBS -lQtCore -lQtGui -lX11 -lXext -lXmu -lXt -lXi $X_EXTRA_LIBS"
+ else
+ # Normally, when there is no traditional Trolltech installation,
+ # the library is installed in a place where the linker finds it
+@@ -27607,7 +27607,7 @@
+ # See if we find the library without any special options.
+ # Don't add top $LIBS permanently yet
+ ax_save_LIBS="$LIBS"
+- LIBS="-l$ax_qt_lib $X_PRE_LIBS $X_LIBS -lX11 -lXext -lXmu -lXt -lXi $X_EXTRA_LIBS"
++ LIBS="-l$ax_qt_lib $X_PRE_LIBS $X_LIBS -lQtCore -lQtGui -lX11 -lXext -lXmu -lXt -lXi $X_EXTRA_LIBS"
+ ax_qt_LIBS="$LIBS"
+ ax_save_CXXFLAGS="$CXXFLAGS"
+ CXXFLAGS="-I$ax_qt_include_dir -I$ax_qt_include_dir/Qt -I$ax_qt_include_dir/QtCore -I$ax_qt_include_dir/QtGui"
+@@ -27668,7 +27668,7 @@
+ # That did not work. Try the multi-threaded version
+ echo "Non-critical error, please neglect the above." >&5
+ ax_qt_lib=qt-mt
+- LIBS="-l$ax_qt_lib $X_PRE_LIBS $X_LIBS -lX11 -lXext -lXmu -lXt -lXi $X_EXTRA_LIBS"
++ LIBS="-l$ax_qt_lib $X_PRE_LIBS $X_LIBS -lQtCore -lQtGui -lX11 -lXext -lXmu -lXt -lXi $X_EXTRA_LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */
+ _ACEOF
+@@ -27726,7 +27726,7 @@
+ # That did not work. Try the OpenGL version
+ echo "Non-critical error, please neglect the above." >&5
+ ax_qt_lib=qt-gl
+- LIBS="-l$ax_qt_lib $X_PRE_LIBS $X_LIBS -lX11 -lXext -lXmu -lXt -lXi $X_EXTRA_LIBS"
++ LIBS="-l$ax_qt_lib $X_PRE_LIBS $X_LIBS -lQtCore -lQtGui -lX11 -lXext -lXmu -lXt -lXi $X_EXTRA_LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */
+ _ACEOF
+@@ -27809,7 +27809,7 @@
+ fi
+ done
+ # Try with that one
+- LIBS="-l$ax_qt_lib $X_PRE_LIBS $X_LIBS -lX11 -lXext -lXmu -lXt -lXi $X_EXTRA_LIBS"
++ LIBS="-l$ax_qt_lib $X_PRE_LIBS $X_LIBS -lQtCore -lQtGui -lX11 -lXext -lXmu -lXt -lXi $X_EXTRA_LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */
+ _ACEOF
diff --git a/sci-libs/silo/files/silo-4.9.1-tests.patch b/sci-libs/silo/files/silo-4.9.1-tests.patch
new file mode 100644
index 000000000000..2e0a52191d0e
--- /dev/null
+++ b/sci-libs/silo/files/silo-4.9.1-tests.patch
@@ -0,0 +1,11 @@
+--- tests/Makefile.in.old 2014-07-24 07:25:53.464381420 +0200
++++ tests/Makefile.in 2014-07-24 07:26:14.951048323 +0200
+@@ -169,7 +169,7 @@
+ $(LIBTOOLFLAGS) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
+ $(ioperf_stdio_la_LDFLAGS) $(LDFLAGS) -o $@
+ rocket_silo_la_LIBADD =
+-am_rocket_silo_la_OBJECTS = rocket_silo.lo
++am_rocket_silo_la_OBJECTS = rocket_silo.lo ../src/.libs/libsilo.la
+ rocket_silo_la_OBJECTS = $(am_rocket_silo_la_OBJECTS)
+ rocket_silo_la_LINK = $(LIBTOOL) --tag=CXX $(AM_LIBTOOLFLAGS) \
+ $(LIBTOOLFLAGS) --mode=link $(CXXLD) $(AM_CXXFLAGS) \