summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2021-01-21 21:58:06 +0800
committerBenda Xu <heroxbd@gentoo.org>2021-01-24 15:51:01 +0800
commiteb75dfab9e7af24c606278dce28101b51f47f043 (patch)
treee39b715bef0900603e28155611b55c5acaebd398 /sci-libs/rocRAND
parentdev-libs/rccl: ROCm Communication Collectives Library (diff)
downloadgentoo-eb75dfab9e7af24c606278dce28101b51f47f043.tar.gz
gentoo-eb75dfab9e7af24c606278dce28101b51f47f043.tar.bz2
gentoo-eb75dfab9e7af24c606278dce28101b51f47f043.zip
sci-libs/rocRAND: pseudo-random number generator.
Closes: https://github.com/gentoo/gentoo/pull/19147 Suggested-by: Yiyang Wu <xgreenlandforwyy@gmail.com> Suggested-by: Wilfried Holzke <gentoo@holzke.net> Bug: https://bugs.gentoo.org/650804 Bug: https://github.com/gentoo/gentoo/pull/10724 Package-Manager: Portage-3.0.12, Repoman-3.0.1 Signed-off-by: Benda Xu <heroxbd@gentoo.org>
Diffstat (limited to 'sci-libs/rocRAND')
-rw-r--r--sci-libs/rocRAND/Manifest1
-rw-r--r--sci-libs/rocRAND/metadata.xml19
-rw-r--r--sci-libs/rocRAND/rocRAND-4.0.0-r1.ebuild46
3 files changed, 66 insertions, 0 deletions
diff --git a/sci-libs/rocRAND/Manifest b/sci-libs/rocRAND/Manifest
new file mode 100644
index 000000000000..7059aa650348
--- /dev/null
+++ b/sci-libs/rocRAND/Manifest
@@ -0,0 +1 @@
+DIST rocRAND-4.0.0.tar.gz 3105585 BLAKE2B 0466d88c286290a9cd179fac61209051f7db5323457ccad9c5f0b579439662e1fe2b8951f85101c7c31bd058bc1448e839a19dc9a3a2d4ca42eb4e0b2baf4eb4 SHA512 c02bc32a9cf7660739ecf7ef99262fb14efa2c76afb3476105eedc4264dec987351ebd461c13c9e0aef9e640b42960b2a63295479664b83924cf0d5c34a157e8
diff --git a/sci-libs/rocRAND/metadata.xml b/sci-libs/rocRAND/metadata.xml
new file mode 100644
index 000000000000..77cd8b248d11
--- /dev/null
+++ b/sci-libs/rocRAND/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>candrews@gentoo.org</email>
+ <name>Craig Andrews</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>gentoo@holzke.net</email>
+ <name>Wilfried Holzke</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ROCmSoftwarePlatform/rocRAND</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-libs/rocRAND/rocRAND-4.0.0-r1.ebuild b/sci-libs/rocRAND/rocRAND-4.0.0-r1.ebuild
new file mode 100644
index 000000000000..1a112d2a73d1
--- /dev/null
+++ b/sci-libs/rocRAND/rocRAND-4.0.0-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Generate pseudo-random and quasi-random numbers"
+HOMEPAGE="https://github.com/ROCmSoftwarePlatform/rocRAND"
+SRC_URI="https://github.com/ROCmSoftwarePlatform/rocRAND/archive/rocm-${PV}.tar.gz -> rocRAND-${PV}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64"
+SLOT="0"
+
+RDEPEND="=dev-util/hip-$(ver_cut 1-2)*"
+DEPEND="${RDEPEND}
+ =dev-util/rocm-cmake-$(ver_cut 1-2)*"
+
+S="${WORKDIR}/rocRAND-rocm-${PV}"
+
+src_prepare() {
+ sed -r -e "s:(hip|roc)rand/lib:\${CMAKE_INSTALL_LIBDIR}:" \
+ -e "s:(hip|roc)rand/include:include/\1rand:" \
+ -e "/INSTALL_RPATH/d" -i library/CMakeLists.txt || die
+
+ eapply_user
+ cmake_src_prepare
+}
+
+src_configure() {
+ # Grant access to the device
+ addwrite /dev/kfd
+ addpredict /dev/dri/
+
+ # Compiler to use
+ export CXX=hipcc
+
+ local mycmakeargs=(
+ -DBUILD_TEST=OFF
+ )
+
+ cmake_src_configure
+ # do not rerun cmake and the build process in src_install
+ sed '/RERUN/,+1d' -i "${BUILD_DIR}"/build.ninja || die
+}