summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/pymmlib
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/pymmlib')
-rw-r--r--sci-libs/pymmlib/Manifest1
-rw-r--r--sci-libs/pymmlib/metadata.xml5
-rw-r--r--sci-libs/pymmlib/pymmlib-1.2.1.ebuild45
3 files changed, 51 insertions, 0 deletions
diff --git a/sci-libs/pymmlib/Manifest b/sci-libs/pymmlib/Manifest
new file mode 100644
index 000000000000..c5cd3dad9da1
--- /dev/null
+++ b/sci-libs/pymmlib/Manifest
@@ -0,0 +1 @@
+DIST pymmlib-1.2.1.tar.gz 37480403 SHA256 58e678be6056e40647fd28fec048571563402802156912bb3481852698179738 SHA512 96328fcb8af70a271c0960be753c677f716d3b15c41519c320a1240fd9ad584fee173ab3a8e528c9ae198efea95d20863f64627e44d1a6726513f2916d93b464 WHIRLPOOL 96ba086514c22c7431739fa50908cc9e7678adf864c1402117e1d852b202e9c1da99c54278bd96861f3f4360ea72c25a04e49c7f4b65621e21ec6ee5f8ded774
diff --git a/sci-libs/pymmlib/metadata.xml b/sci-libs/pymmlib/metadata.xml
new file mode 100644
index 000000000000..51fdedab1b38
--- /dev/null
+++ b/sci-libs/pymmlib/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+</pkgmetadata>
diff --git a/sci-libs/pymmlib/pymmlib-1.2.1.ebuild b/sci-libs/pymmlib/pymmlib-1.2.1.ebuild
new file mode 100644
index 000000000000..8e3c826be383
--- /dev/null
+++ b/sci-libs/pymmlib/pymmlib-1.2.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 multilib
+
+DESCRIPTION="Toolkit and library for the analysis and manipulation of macromolecular structural models"
+HOMEPAGE="http://pymmlib.sourceforge.net/"
+SRC_URI="mirror://github/masci/mmLib/${P}.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pygtkglext[${PYTHON_USEDEP}]
+ media-libs/freeglut
+ virtual/glu
+ virtual/opengl
+ x11-libs/libXmu"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/epydoc[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ rm mmLib/NumericCompat.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && esetup.py doc
+}
+
+python_install_all() {
+ DOCS=( "${S}"/README.txt )
+ use doc && HTML_DOCS=( "${S}"/doc/. )
+ distutils-r1_python_install_all
+
+ python_foreach_impl python_doscript "${S}"/applications/* "${S}"/examples/*.py
+}