summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2023-12-17 16:58:19 -0500
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-12-18 09:21:01 +0100
commit0c573513414f30ca44e76fa6aa0ed34897c41257 (patch)
treef5d4b24a498de4ca0738e6b9420b8a3c4246d296 /sci-libs/hdf5
parentsys-apps/syd: add 3.9.5, drop 3.8.7 (diff)
downloadgentoo-0c573513414f30ca44e76fa6aa0ed34897c41257.tar.gz
gentoo-0c573513414f30ca44e76fa6aa0ed34897c41257.tar.bz2
gentoo-0c573513414f30ca44e76fa6aa0ed34897c41257.zip
sci-libs/hdf5: fix broken examplesdir support
Since at least upstream version 1.12.2, upstream added a configure option to choose the examples directory. It was no longer hardcoded in Makefile.am, which means the sed fixup did not work, but also the option wasn't passed. Upstream commit: https://github.com/HDFGroup/hdf5/commit/b8a93a7224114739e42f32aaf62ae64fd1aad33e iwdevtools: ``` * SED: the following did not cause any changes * sed -e "s:hdf5_examples:doc/${PF}/examples:g" -i $(find . -name Makefile.am) $(find . -name "run*.sh.in") || die; * no-op: -e s:hdf5_examples:doc/hdf5-1.12.2-r4/examples:g ``` Make sure the option is correctly passed. Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/34335 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-libs/hdf5')
-rw-r--r--sci-libs/hdf5/hdf5-1.14.3-r1.ebuild (renamed from sci-libs/hdf5/hdf5-1.14.3.ebuild)5
1 files changed, 1 insertions, 4 deletions
diff --git a/sci-libs/hdf5/hdf5-1.14.3.ebuild b/sci-libs/hdf5/hdf5-1.14.3-r1.ebuild
index 47b70efe199b..750f17457476 100644
--- a/sci-libs/hdf5/hdf5-1.14.3.ebuild
+++ b/sci-libs/hdf5/hdf5-1.14.3-r1.ebuild
@@ -65,10 +65,6 @@ pkg_setup() {
src_prepare() {
default
- # Respect Gentoo examples directory
- sed \
- -e "s:hdf5_examples:doc/${PF}/examples:g" \
- -i $(find . -name Makefile.am) $(find . -name "run*.sh.in") || die
sed \
-e '/docdir/d' \
-i config/commence.am || die
@@ -96,6 +92,7 @@ src_configure() {
--enable-deprecated-symbols
--enable-build-mode=$(usex debug debug production)
--with-default-plugindir="${EPREFIX}/usr/$(get_libdir)/${PN}/plugin"
+ --with-examplesdir="\${datarootdir}/doc/${PF}/examples" \
$(use_enable cxx)
$(use_enable debug codestack)
$(use_enable fortran)