summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSv. Lockal <lockalsash@gmail.com>2024-06-02 11:49:42 +0000
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-06-03 15:27:03 +0200
commit9c9c079f4919e0c85eca39e74bc00e6db646389f (patch)
tree0b0f3f1f6a80cfe505b09617a78335c70aa19001 /sci-libs/blis
parentsci-libs/blis: don't autodetect CPU, build according to cpu_flags_* (diff)
downloadgentoo-9c9c079f4919e0c85eca39e74bc00e6db646389f.tar.gz
gentoo-9c9c079f4919e0c85eca39e74bc00e6db646389f.tar.bz2
gentoo-9c9c079f4919e0c85eca39e74bc00e6db646389f.zip
sci-libs/blis: add 1.0
Changes from 0.9: * Added patch to not install /usr/include/cblas.h, as it conflicts with sci-libs/lapack * aarch64 now builds/passes tests (in qemu), can be keyworded later Signed-off-by: Sv. Lockal <lockalsash@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/36974 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-libs/blis')
-rw-r--r--sci-libs/blis/Manifest1
-rw-r--r--sci-libs/blis/blis-1.0.ebuild137
-rw-r--r--sci-libs/blis/files/blis-1.0-no-helper-headers.patch13
3 files changed, 151 insertions, 0 deletions
diff --git a/sci-libs/blis/Manifest b/sci-libs/blis/Manifest
index feff64952906..6671de7c7fc6 100644
--- a/sci-libs/blis/Manifest
+++ b/sci-libs/blis/Manifest
@@ -1 +1,2 @@
DIST blis-0.9.0.tar.gz 15078619 BLAKE2B f7c9632024e0adbba370a4077a7a47f05c54779ad6195b2ccda0950df8e784b8988b4338758ec2fabd424a69009010f8f02cbaef0eda1d74f6794127b43b4f70 SHA512 01e1990eefa4387839ac404089e4ffa32922ceaa30a1747c08a931c67706bcf29fed9d25e30c0faa36bba4f460821290e7973ed6b657d2cd95e126caaf853f81
+DIST blis-1.0.tar.gz 15714356 BLAKE2B 7e9b6132ab556adf7ccb2d1bff6c5195eb2f48a9193a6df57d409e25b42f1aaa64f053f97996a6467ad42cbe5848c3689f3e6c501579d5d1083523ca9ed52ce1 SHA512 91cd2a2944762e584f11cb931ba11c4b296e93040b553f105ba8579d748a49cfcb6db8ae2ce1b5a537c0ae88182c9d212a4a5daa757ca4d0a7beee552d2eb55c
diff --git a/sci-libs/blis/blis-1.0.ebuild b/sci-libs/blis/blis-1.0.ebuild
new file mode 100644
index 000000000000..ecbc704021e8
--- /dev/null
+++ b/sci-libs/blis/blis-1.0.ebuild
@@ -0,0 +1,137 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+inherit python-any-r1 toolchain-funcs
+
+DESCRIPTION="BLAS-like Library Instantiation Software Framework"
+HOMEPAGE="https://github.com/flame/blis"
+SRC_URI="https://github.com/flame/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+CPU_USE=(
+ cpu_flags_ppc_{vsx,vsx3}
+ cpu_flags_arm_{neon,v7,v8,sve}
+ cpu_flags_x86_{ssse3,avx,fma3,fma4,avx2,avx512vl}
+)
+IUSE="doc eselect-ldso openmp pthread serial static-libs 64bit-index ${CPU_USE[@]}"
+REQUIRED_USE="
+ ?? ( openmp pthread serial )
+ ?? ( eselect-ldso 64bit-index )"
+
+DEPEND="
+ eselect-ldso? (
+ !app-eselect/eselect-cblas
+ >=app-eselect/eselect-blas-0.2
+ )"
+
+RDEPEND="${DEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-lang/perl
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.6.0-blas-provider.patch
+ # to prevent QA Notice: pkg-config files with wrong LDFLAGS detected
+ "${FILESDIR}"/${PN}-0.8.1-pkg-config.patch
+ "${FILESDIR}"/${PN}-0.9.0-rpath.patch
+ "${FILESDIR}"/${PN}-1.0-no-helper-headers.patch
+)
+
+get_confname() {
+ local confname=generic
+ if use x86 || use amd64; then
+ use cpu_flags_x86_ssse3 && confname=penryn
+ use cpu_flags_x86_avx && use cpu_flags_x86_fma3 && confname=sandybridge
+ use cpu_flags_x86_avx && use cpu_flags_x86_fma4 && confname=bulldozer
+ use cpu_flags_x86_avx && use cpu_flags_x86_fma4 && use cpu_flags_x86_fma3 && confname=piledriver
+ use cpu_flags_x86_avx2 && confname=haswell
+ use cpu_flags_x86_avx512vl && confname=skx
+ elif use arm || use arm64; then
+ use arm && confname=arm32
+ use arm64 && confname=arm64
+ use cpu_flags_arm_neon && use cpu_flags_arm_v7 && confname=cortexa9
+ use cpu_flags_arm_v8 && confname=cortexa53
+ use cpu_flags_arm_sve && confname=armsve
+ elif use ppc || use ppc64; then
+ confname=power
+ use cpu_flags_ppc_vsx && confname=power7
+ use cpu_flags_ppc_vsx3 && confname=power9
+ fi
+ echo ${confname}
+}
+
+src_configure() {
+ local BLIS_FLAGS=()
+ # determine flags
+ if use openmp; then
+ BLIS_FLAGS+=( -t openmp )
+ elif use pthread; then
+ BLIS_FLAGS+=( -t pthreads )
+ else
+ BLIS_FLAGS+=( -t no )
+ fi
+ use 64bit-index && BLIS_FLAGS+=( -b 64 -i 64 )
+
+ # This is not an autotools configure file. We don't use econf here.
+ CC="$(tc-getCC)" AR="$(tc-getAR)" RANLIB="$(tc-getRANLIB)" ./configure \
+ --enable-verbose-make \
+ --prefix="${BROOT}"/usr \
+ --libdir="${BROOT}"/usr/$(get_libdir) \
+ $(use_enable static-libs static) \
+ --enable-blas \
+ --enable-cblas \
+ "${BLIS_FLAGS[@]}" \
+ --enable-shared \
+ $(get_confname) || die
+}
+
+src_compile() {
+ DEB_LIBBLAS=libblas.so.3 DEB_LIBCBLAS=libcblas.so.3 \
+ LDS_BLAS="${FILESDIR}"/blas.lds LDS_CBLAS="${FILESDIR}"/cblas.lds \
+ default
+}
+
+src_test() {
+ LD_LIBRARY_PATH=lib/$(get_confname) emake testblis-fast
+ ./testsuite/check-blistest.sh ./output.testsuite || die
+}
+
+src_install() {
+ default
+ use doc && dodoc README.md docs/*.md
+
+ if use eselect-ldso; then
+ insinto /usr/$(get_libdir)/blas/blis
+ doins lib/*/lib{c,}blas.so.3
+ dosym libblas.so.3 usr/$(get_libdir)/blas/blis/libblas.so
+ dosym libcblas.so.3 usr/$(get_libdir)/blas/blis/libcblas.so
+ fi
+}
+
+pkg_postinst() {
+ use eselect-ldso || return
+
+ local libdir=$(get_libdir) me="blis"
+
+ # check blas
+ eselect blas add ${libdir} "${EROOT}"/usr/${libdir}/blas/${me} ${me}
+ local current_blas=$(eselect blas show ${libdir} | cut -d' ' -f2)
+ if [[ ${current_blas} == "${me}" || -z ${current_blas} ]]; then
+ eselect blas set ${libdir} ${me}
+ elog "Current eselect: BLAS/CBLAS ($libdir) -> [${current_blas}]."
+ else
+ elog "Current eselect: BLAS/CBLAS ($libdir) -> [${current_blas}]."
+ elog "To use blas [${me}] implementation, you have to issue (as root):"
+ elog "\t eselect blas set ${libdir} ${me}"
+ fi
+}
+
+pkg_postrm() {
+ use eselect-ldso && eselect blas validate
+}
diff --git a/sci-libs/blis/files/blis-1.0-no-helper-headers.patch b/sci-libs/blis/files/blis-1.0-no-helper-headers.patch
new file mode 100644
index 000000000000..ec747824e7dc
--- /dev/null
+++ b/sci-libs/blis/files/blis-1.0-no-helper-headers.patch
@@ -0,0 +1,13 @@
+Don't install one-line "helper header" cblas.h into /usr/include,
+as it conflicts with sci-libs/lapack.
+--- a/Makefile
++++ b/Makefile
+@@ -1052,7 +1052,7 @@ endif
+
+ # --- Install header rules ---
+
+-install-headers: check-env $(MK_INCL_DIR_INST) install-helper-headers
++install-headers: check-env $(MK_INCL_DIR_INST)
+
+ # Rule for installing main headers.
+ $(MK_INCL_DIR_INST): $(HEADERS_TO_INSTALL) $(CONFIG_MK_FILE)