summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMo Zhou <cdluminate@gmail.com>2019-09-04 07:24:42 +0000
committerMichał Górny <mgorny@gentoo.org>2019-09-04 09:51:01 +0200
commit13c00964fd7f52a9b74e1eba62aae1594f215752 (patch)
tree6123f1b3e54b954f059e10d943751ec3d36f84c8 /sci-libs/blis
parentx11-plugins/enigmail: Revbump to re-enable seamonkey support (diff)
downloadgentoo-13c00964fd7f52a9b74e1eba62aae1594f215752.tar.gz
gentoo-13c00964fd7f52a9b74e1eba62aae1594f215752.tar.bz2
gentoo-13c00964fd7f52a9b74e1eba62aae1594f215752.zip
sci-lib/blis: use python-any-r1 eclass instead of hardcoded python deps.
Additionally, quote ${BLIS_FLAGS[@]}, and remove unused `eutils` Closes: https://bugs.gentoo.org/693130 Signed-off-by: Mo Zhou <cdluminate@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/12859 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sci-libs/blis')
-rw-r--r--sci-libs/blis/blis-0.5.2.ebuild7
-rw-r--r--sci-libs/blis/blis-0.6.0.ebuild7
2 files changed, 8 insertions, 6 deletions
diff --git a/sci-libs/blis/blis-0.5.2.ebuild b/sci-libs/blis/blis-0.5.2.ebuild
index 785210e5b5a9..2c8bf1dbc422 100644
--- a/sci-libs/blis/blis-0.5.2.ebuild
+++ b/sci-libs/blis/blis-0.5.2.ebuild
@@ -2,7 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit eutils
+PYTHON_COMPAT=( python{2_7,3_{4,5,6,7}} )
+inherit python-any-r1
DESCRIPTION="BLAS-like Library Instantiation Software Framework"
HOMEPAGE="https://github.com/flame/blis"
@@ -18,7 +19,7 @@ RDEPEND="eselect-ldso? ( !app-eselect/eselect-cblas
>=app-eselect/eselect-blas-0.2 )"
DEPEND="${RDEPEND}
- dev-lang/python
+ ${PYTHON_DEPS}
"
PATCHES=(
@@ -56,7 +57,7 @@ src_configure () {
$(use_enable static-libs static) \
--enable-blas \
--enable-cblas \
- ${BLIS_FLAGS[@]} \
+ "${BLIS_FLAGS[@]}" \
--enable-shared \
$confname || die
}
diff --git a/sci-libs/blis/blis-0.6.0.ebuild b/sci-libs/blis/blis-0.6.0.ebuild
index ccb44fdd6824..4d56f5622120 100644
--- a/sci-libs/blis/blis-0.6.0.ebuild
+++ b/sci-libs/blis/blis-0.6.0.ebuild
@@ -2,7 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit eutils
+PYTHON_COMPAT=( python{2_7,3_{4,5,6,7}} )
+inherit python-any-r1
DESCRIPTION="BLAS-like Library Instantiation Software Framework"
HOMEPAGE="https://github.com/flame/blis"
@@ -18,7 +19,7 @@ RDEPEND="eselect-ldso? ( !app-eselect/eselect-cblas
>=app-eselect/eselect-blas-0.2 )"
DEPEND="${RDEPEND}
- dev-lang/python
+ ${PYTHON_DEPS}
"
PATCHES=(
@@ -55,7 +56,7 @@ src_configure () {
$(use_enable static-libs static) \
--enable-blas \
--enable-cblas \
- ${BLIS_FLAGS[@]} \
+ "${BLIS_FLAGS[@]}" \
--enable-shared \
$confname || die
}