summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-10-17 14:41:42 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-10-17 15:39:33 +0200
commitf7e2b8df372f5d14253793bf00a148a4423df212 (patch)
treec18843c5a60213fc26f271b7e7ec5987e0540d7b /sci-electronics
parentsci-electronics/nvc: drop old 1.10.1-r2 (diff)
downloadgentoo-f7e2b8df372f5d14253793bf00a148a4423df212.tar.gz
gentoo-f7e2b8df372f5d14253793bf00a148a4423df212.tar.bz2
gentoo-f7e2b8df372f5d14253793bf00a148a4423df212.zip
sci-electronics/nvc: drop old 1.10.2-r2
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/nvc/Manifest1
-rw-r--r--sci-electronics/nvc/nvc-1.10.2-r2.ebuild115
2 files changed, 0 insertions, 116 deletions
diff --git a/sci-electronics/nvc/Manifest b/sci-electronics/nvc/Manifest
index 837c5a467016..adb4e3eb872f 100644
--- a/sci-electronics/nvc/Manifest
+++ b/sci-electronics/nvc/Manifest
@@ -1,2 +1 @@
-DIST nvc-1.10.2.tar.gz 1591682 BLAKE2B 6b98ffd2a35498a572627e1460ef075653d1aed917a0b21de65c4740236570ac243fade51d795752062f022b1dc2ea9f7608ca47aee1ea6161fbfb6a525f926e SHA512 f5022f0871810ae6a9a53639a7b7c9055bb3c6fd243557eac71db14167ea073c7434a287b83cfc427920cff6433d0342bb8c4d44cee3d3a2b24ad73def8a7715
DIST nvc-1.10.3.tar.gz 1594551 BLAKE2B 0b607dfdcb0fba0edf5ca56d35786bce3e20cc7f9ecd90d0fd8ebbf492171d08fcd7f4df9ba200446fe890244d7a7fee70f5de0b22d16fb5872550fc69bc199c SHA512 cd5bae71e765c87f0c8a1f21bb4cdd1022470bd4bb9dc5ecc2d15cfa365ed0a2c0e85c4edffd9fa90080db6a44db7101a11cd6fcc134c7870d64601183994893
diff --git a/sci-electronics/nvc/nvc-1.10.2-r2.ebuild b/sci-electronics/nvc/nvc-1.10.2-r2.ebuild
deleted file mode 100644
index 801f314f5b8a..000000000000
--- a/sci-electronics/nvc/nvc-1.10.2-r2.ebuild
+++ /dev/null
@@ -1,115 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-LLVM_MAX_SLOT=16
-
-inherit autotools bash-completion-r1 llvm
-
-DESCRIPTION="NVC is a VHDL compiler and simulator"
-HOMEPAGE="https://www.nickg.me.uk/nvc/
- https://github.com/nickg/nvc/"
-
-if [[ ${PV} == *9999* ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/nickg/nvc.git"
-
- NVC_SOURCEDIR="${WORKDIR}"/${PN}-${PV}
-else
- SRC_URI="https://github.com/nickg/nvc/archive/r${PV}.tar.gz
- -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-
- NVC_SOURCEDIR="${WORKDIR}"/${PN}-r${PV}
-fi
-
-LICENSE="GPL-3+"
-SLOT="0"
-IUSE="debug jit llvm"
-REQUIRED_USE="jit? ( llvm )"
-RESTRICT="test" # Some tests fail.
-
-RDEPEND="
- app-arch/bzip2:=
- app-arch/zstd:=
- dev-libs/capstone:=
- dev-libs/elfutils
- dev-libs/icu:=
- dev-libs/libffi:=
- dev-libs/libxml2:=
- sys-libs/ncurses:=
- sys-libs/zlib:=
- llvm? ( <sys-devel/llvm-$((${LLVM_MAX_SLOT} + 1)):= )
-"
-DEPEND="
- ${RDEPEND}
-"
-BDEPEND="
- dev-libs/check
- sys-devel/bison
- sys-devel/flex
-"
-
-NVC_BUILDDIR="${NVC_SOURCEDIR}_BuildDir"
-S="${NVC_BUILDDIR}"
-
-PATCHES=( "${FILESDIR}"/nvc-1.9.2-jit-code-capstone.patch )
-
-# Special libraries for NVC.
-QA_FLAGS_IGNORED="usr/lib[0-9]*/nvc/preload[0-9]*.so"
-
-pkg_setup() {
- use llvm && llvm_pkg_setup
-}
-
-src_unpack() {
- default
-
- mkdir -p "${S}" || die
-}
-
-src_prepare() {
- pushd "${NVC_SOURCEDIR}" >/dev/null || die
-
- default
-
- eautoreconf
-
- popd >/dev/null || die
-}
-
-src_configure() {
- # Needs "bison" and "flex" exactly.
- unset LEX
- unset YACC
-
- local ECONF_SOURCE="${NVC_SOURCEDIR}"
- local -a myconf=(
- --enable-verilog
- --enable-vital
- --with-bash-completion="$(get_bashcompdir)"
- $(use_enable debug)
- $(use_enable jit)
- $(use_enable llvm)
- )
- econf "${myconf[@]}"
-
- export V=1 # Verbose compilation and install.
-}
-
-src_compile() {
- emake -j1
-}
-
-src_test() {
- emake check
-}
-
-src_install() {
- default
-
- mv "${ED}"/"$(get_bashcompdir)"/nvc{.bash,} || die
-
- dostrip -x /usr/$(get_libdir)/nvc
-}