summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-electronics/gerbv
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-electronics/gerbv')
-rw-r--r--sci-electronics/gerbv/Manifest1
-rw-r--r--sci-electronics/gerbv/gerbv-2.6.0.ebuild55
-rw-r--r--sci-electronics/gerbv/metadata.xml18
3 files changed, 74 insertions, 0 deletions
diff --git a/sci-electronics/gerbv/Manifest b/sci-electronics/gerbv/Manifest
new file mode 100644
index 000000000000..eb77eccf63d1
--- /dev/null
+++ b/sci-electronics/gerbv/Manifest
@@ -0,0 +1 @@
+DIST gerbv-2.6.0.tar.gz 2346299 SHA256 5c55425c3493bc8407949be8b4e572434a6b378f5727cc0dcef97dc2e7574dd0 SHA512 a2d7601b44c8ed16a89d18713f451c0298bee65e2ea76b87e3d9d573af63d3b57758cb7cfcfb2177a22aecc7d9fdaaca3d369ea051446651af4dc542065a4377 WHIRLPOOL 07fd10e35d7f384bfdf8d16c9e1a42bdf3010dcd45c2cb3cb359f7c0478b0739c784900e8448c117841511e7d6fed2fe5bd69051fd61e2c64750f83e931909c4
diff --git a/sci-electronics/gerbv/gerbv-2.6.0.ebuild b/sci-electronics/gerbv/gerbv-2.6.0.ebuild
new file mode 100644
index 000000000000..53dbb2514e38
--- /dev/null
+++ b/sci-electronics/gerbv/gerbv-2.6.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit fdo-mime
+
+DESCRIPTION="A RS-274X (Gerber) and NC drill (Excellon) file viewer"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://gerbv.geda-project.org/"
+
+IUSE="doc examples static-libs unit-mm"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="amd64 ppc x86"
+RESTRICT="test"
+
+RDEPEND="
+ x11-libs/gtk+:2
+ x11-libs/cairo"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ $(use_enable unit-mm) \
+ --disable-update-desktop-database \
+ $(use_enable static-libs static)
+}
+
+src_install () {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS BUGS ChangeLog CONTRIBUTORS HACKING NEWS README* TODO
+
+ rm doc/Doxyfile.nopreprocessing
+ if use doc; then
+ find doc -name "Makefile*" -exec rm -f '{}' \;
+ dodoc -r doc/*
+ fi
+
+ if use examples; then
+ find example -name "Makefile*" -exec rm -f '{}' \;
+ dodoc -r example/*
+ fi
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}
diff --git a/sci-electronics/gerbv/metadata.xml b/sci-electronics/gerbv/metadata.xml
new file mode 100644
index 000000000000..655a535046fe
--- /dev/null
+++ b/sci-electronics/gerbv/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-electronics</herd>
+ <longdescription>
+ Gerbv is a viewer for Gerber RS-274X files, Excellon drill files, and CSV
+ pick-and-place files. (Note: RS-274D files are not supported.)
+ The core functionality of gerbv is located in a separate library
+ (libgerbv), allowing developers to include Gerber
+ parsing/editing/exporting/rendering into other programs.
+ </longdescription>
+ <use>
+ <flag name="unit-mm">Set default unit for coordinates in status bar to mm</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">gerbv</remote-id>
+ </upstream>
+</pkgmetadata>