summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-chemistry/tm-align
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-chemistry/tm-align')
-rw-r--r--sci-chemistry/tm-align/Manifest1
-rw-r--r--sci-chemistry/tm-align/files/CMakeLists.txt6
-rw-r--r--sci-chemistry/tm-align/metadata.xml24
-rw-r--r--sci-chemistry/tm-align/tm-align-20140601.ebuild25
4 files changed, 56 insertions, 0 deletions
diff --git a/sci-chemistry/tm-align/Manifest b/sci-chemistry/tm-align/Manifest
new file mode 100644
index 000000000000..d9e8dc8632b3
--- /dev/null
+++ b/sci-chemistry/tm-align/Manifest
@@ -0,0 +1 @@
+DIST TMtools20140601.tar.gz 934391 SHA256 5032f7ab1824c8b2191b4a3667e1405feb6ccf7c900f57632aa506fff8ec1bf5 SHA512 99b90425ff051c836e19225601ddfb1576bec9c8f233aafeba96075f924a3c0892b5b1cfef36254ff5ef468a6dbf64f7fcc9a3ce24a0d869b3c1eb87c0149765 WHIRLPOOL 5ba7d9cb71e3055dff62851c68e127314b9ca70c4bbc39aeba35e5a4b02dc0cffeacb52c6369c90875d8062603c830acf604cfc339bdecfeb3dd6c10015e20de
diff --git a/sci-chemistry/tm-align/files/CMakeLists.txt b/sci-chemistry/tm-align/files/CMakeLists.txt
new file mode 100644
index 000000000000..506ef136309e
--- /dev/null
+++ b/sci-chemistry/tm-align/files/CMakeLists.txt
@@ -0,0 +1,6 @@
+cmake_minimum_required (VERSION 2.6)
+project (TMTools Fortran)
+add_executable(TMalign TMalign.f)
+add_executable(TMscore TMscore.f)
+
+install (TARGETS TMalign TMscore DESTINATION bin)
diff --git a/sci-chemistry/tm-align/metadata.xml b/sci-chemistry/tm-align/metadata.xml
new file mode 100644
index 000000000000..1e724495b8e2
--- /dev/null
+++ b/sci-chemistry/tm-align/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+TM-align is a computer algorithm for protein structure alignment using dynamic
+programming and TM-score rotation matrix. An optimal alignment between two
+proteins, as well as the TM-score, will be reported for each comparison. The
+value of TM-score lies in (0,1]. In general, a comparison of TM-score smaller
+0.2 indicates that there is no similarity between two structures; a TM-score
+greater 0.5 means the structures share the same fold.
+
+What is the difference between TM-score and TM-align? The TM-score program
+is to compare two models based on their given and known residue equivalency.
+It is usually NOT applied to compare two proteins of different sequences. The
+TM-align is a structural alignment program for comparing two proteins whose
+sequences can be different. The TM-align will first find the best equivalent
+residues of two proteins based on the structure similarity and then output a
+TM-score. The TM-score values in both programs have the same definition.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-chemistry/tm-align/tm-align-20140601.ebuild b/sci-chemistry/tm-align/tm-align-20140601.ebuild
new file mode 100644
index 000000000000..e7718e305db1
--- /dev/null
+++ b/sci-chemistry/tm-align/tm-align-20140601.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils flag-o-matic fortran-2
+
+DESCRIPTION="Quick & Accurate Structural Alignment"
+HOMEPAGE="http://zhanglab.ccmb.med.umich.edu/TM-align/"
+SRC_URI="http://zhanglab.ccmb.med.umich.edu/TM-align/TMtools${PV}.tar.gz"
+
+LICENSE="tm-align"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="static custom-cflags"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ cp "${FILESDIR}"/CMakeLists.txt . || die
+ use static && append-fflags -static && append-ldflags -static
+ # recommended by upstream
+ use custom-cflags || replace-flags -O* -O3 && append-fflags -ffast-math
+}