summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-02-27 22:39:37 +0000
committerSam James <sam@gentoo.org>2022-02-27 22:39:37 +0000
commitbc5b58f78574e2a185a02ab4b56230a02f1090ff (patch)
treef3246eeddf627b9eccdef3ce10fb95bd62d42806 /sci-chemistry/pdbmat
parentsci-chemistry/pdbcat: port to EAPI 8 (diff)
downloadgentoo-bc5b58f78574e2a185a02ab4b56230a02f1090ff.tar.gz
gentoo-bc5b58f78574e2a185a02ab4b56230a02f1090ff.tar.bz2
gentoo-bc5b58f78574e2a185a02ab4b56230a02f1090ff.zip
sci-chemistry/pdbmat: port to EAPI 8
Closes: https://bugs.gentoo.org/809773 Closes: https://bugs.gentoo.org/834303 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-chemistry/pdbmat')
-rw-r--r--sci-chemistry/pdbmat/files/CMakeLists.txt6
-rw-r--r--sci-chemistry/pdbmat/pdbmat-3.89-r1.ebuild (renamed from sci-chemistry/pdbmat/pdbmat-3.89.ebuild)15
2 files changed, 11 insertions, 10 deletions
diff --git a/sci-chemistry/pdbmat/files/CMakeLists.txt b/sci-chemistry/pdbmat/files/CMakeLists.txt
index 2f1937d84b3f..a20199bbca91 100644
--- a/sci-chemistry/pdbmat/files/CMakeLists.txt
+++ b/sci-chemistry/pdbmat/files/CMakeLists.txt
@@ -1,14 +1,16 @@
cmake_minimum_required (VERSION 2.6)
project (PDBMAT Fortran)
+include(GNUInstallDirs)
+
option (EXAMPLES "Instal additional example files" OFF)
add_executable(diagstd diagstd.f)
add_executable(pdbmat pdbmat.f)
install (TARGETS diagstd pdbmat DESTINATION bin)
-install (FILES diagstd.README pdbmat.README DESTINATION share/doc/pdbmat)
+install (FILES diagstd.README pdbmat.README DESTINATION ${CMAKE_INSTALL_DOCDIR})
if ( EXAMPLES )
- install (DIRECTORY ../Try_ENM2011 DESTINATION share/pdbmat/examples)
+ install (DIRECTORY ../Try_ENM2011 DESTINATION ${CMAKE_INSTALL_DOCDIR}/examples)
endif (EXAMPLES)
diff --git a/sci-chemistry/pdbmat/pdbmat-3.89.ebuild b/sci-chemistry/pdbmat/pdbmat-3.89-r1.ebuild
index 6c14461b5019..40ef7c9df2d3 100644
--- a/sci-chemistry/pdbmat/pdbmat-3.89.ebuild
+++ b/sci-chemistry/pdbmat/pdbmat-3.89-r1.ebuild
@@ -1,25 +1,24 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
-inherit cmake-utils fortran-2
+inherit cmake fortran-2
DESCRIPTION="Calculate Tirion's model from pdb structures"
HOMEPAGE="http://ecole.modelisation.free.fr/modes.html"
SRC_URI="http://ecole.modelisation.free.fr/enm2011.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/Source_ENM2011
-SLOT="0"
LICENSE="CeCILL-2"
+SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="examples"
-S="${WORKDIR}"/Source_ENM2011
-
src_prepare() {
cp "${FILESDIR}"/CMakeLists.txt . || die
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
@@ -27,5 +26,5 @@ src_configure() {
-DEXAMPLES=$(usex examples)
)
- cmake-utils_src_configure
+ cmake_src_configure
}