summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-12-27 01:06:46 +0100
committerDavid Seifert <soap@gentoo.org>2022-12-27 01:06:46 +0100
commit01090e63f3067303d6ca41e5bbea8b890bbab7b6 (patch)
treeb75022a532f4391aa0f1b7fe020797156e14da4b /sci-biology
parentsci-biology/samtools: add 1.16.1 (diff)
downloadgentoo-01090e63f3067303d6ca41e5bbea8b890bbab7b6.tar.gz
gentoo-01090e63f3067303d6ca41e5bbea8b890bbab7b6.tar.bz2
gentoo-01090e63f3067303d6ca41e5bbea8b890bbab7b6.zip
sci-biology/bcftools: add 1.16
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/bcftools/Manifest1
-rw-r--r--sci-biology/bcftools/bcftools-1.16.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/sci-biology/bcftools/Manifest b/sci-biology/bcftools/Manifest
index 4dbacdb4a399..af5f3f40dd8b 100644
--- a/sci-biology/bcftools/Manifest
+++ b/sci-biology/bcftools/Manifest
@@ -1 +1,2 @@
DIST bcftools-1.15.1.tar.bz2 6917252 BLAKE2B d2389df8d2a1bbc48fcaccad47d77ff99d700e82e04330189e7d93acdac97a13506c2b799fbba31bdc0988977c7df7c699e7b156f3530dd35e5f052c6f977731 SHA512 60fedacc41051675d372e68146ac8fa0dc019a7fb694fda487d89e62f34edaf5ac11cca38779e9bcfcf8b3148802fadabed12f7e46ad534ad5087b8d6383f97b
+DIST bcftools-1.16.tar.bz2 7325862 BLAKE2B 0e1240448d4efb352d3d0cd83decd286f7544fff3676f0a5cca51dec9c445c47c37ac24a3317aa7b41182c576e7e57dba460fc98aca069dc2f8fe0625c0b0f06 SHA512 998d5ac941f73798c35dd1db7ac7aba9067f275bd3055728aabfd8edd9f40484130df1fb57621d1a762a57b28ffcac358570915c341d420ae6f12bd17f7651a3
diff --git a/sci-biology/bcftools/bcftools-1.16.ebuild b/sci-biology/bcftools/bcftools-1.16.ebuild
new file mode 100644
index 000000000000..eeb9a7c890b7
--- /dev/null
+++ b/sci-biology/bcftools/bcftools-1.16.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit python-single-r1
+
+DESCRIPTION="Utilities for variant calling and manipulating VCF and BCF files"
+HOMEPAGE="http://www.htslib.org"
+SRC_URI="https://github.com/samtools/${PN}/releases/download/${PV}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ dev-lang/perl
+ $(python_gen_cond_dep 'dev-python/matplotlib[${PYTHON_USEDEP}]')
+ =sci-libs/htslib-$(ver_cut 1-2)*:=
+ sys-libs/zlib
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+BDEPEND="${PYTHON_DEPS}"
+
+src_prepare() {
+ default
+
+ python_fix_shebang misc/{gff2gff,guess-ploidy,plot-roh}.py
+
+ # remove bundled htslib
+ rm -r htslib-* || die
+}
+
+src_configure() {
+ econf \
+ --disable-bcftools-plugins \
+ --disable-libgsl \
+ --with-htslib=system
+}