summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2024-06-16 20:44:50 -0700
committerZac Medico <zmedico@gentoo.org>2024-06-16 20:49:22 -0700
commitd8936a4603c74516dea90948b22ff71e0144baef (patch)
treea8e0cc8625fbd72cdd4c4dcd0452c597450fc386 /net-vpn
parentnet-vpn/frp: drop 0.53.2-r1 (diff)
downloadgentoo-d8936a4603c74516dea90948b22ff71e0144baef.tar.gz
gentoo-d8936a4603c74516dea90948b22ff71e0144baef.tar.bz2
gentoo-d8936a4603c74516dea90948b22ff71e0144baef.zip
net-vpn/frp: add 0.58.1
Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'net-vpn')
-rw-r--r--net-vpn/frp/Manifest2
-rw-r--r--net-vpn/frp/frp-0.58.1.ebuild65
2 files changed, 67 insertions, 0 deletions
diff --git a/net-vpn/frp/Manifest b/net-vpn/frp/Manifest
index 4594afdcab34..fc780a5df065 100644
--- a/net-vpn/frp/Manifest
+++ b/net-vpn/frp/Manifest
@@ -1,2 +1,4 @@
DIST frp-0.56.0-deps.tar.xz 2890568 BLAKE2B cabeeba66d4fa94ff95637020178310c984b7e3254c756e75f0facc5bee0803c6ba485fa83e7c0f7c92474ce9d60621cd6a1608c3b631f2a9c27f6b6c9638ebe SHA512 0687db5001542780ac6e5c57d0da356f4c36bd31c96c2657a9e15988950436abedcd490d85cc272ff80f4868989d173a71dcf2cf28ed26f93b877d1650f04206
DIST frp-0.56.0.tar.gz 1080201 BLAKE2B 493e8b21aab6d5fae2d762eafba7d94de59394e9c4cb3c3dfce2bd8b5a0d0fcca6ef471917e8257022e079bececf34e910fe3b6bc845753862da59a1d00ca20c SHA512 883dce220aa78296f2b7eb9d64b3d1598bc2df436c52a48bc813d725a6f8fa43028359b0507bf4a586a29f4739310474047abfefd46249c0c9942990ceac0e2d
+DIST frp-0.58.1-deps.tar.xz 2916740 BLAKE2B 49256c40ca359a5b76a92e2999e3a5a3ca4899f71e4804544296ee71fa6c079f563b1892195243e9e8792c72c445f779fb5a32b1cc5c4ebca9265d88808072e3 SHA512 3295e0e6b5a7ace8c5af1dd9e15ffb893930c0f03755e8de46dfbca2272747b95d8e58f4034f4fa2c44896c5036654b3c805a6d3dd0d39299996335330d28d07
+DIST frp-0.58.1.tar.gz 1081317 BLAKE2B e5d897a9d866df1075c9fb397f1cbcf23efb738fd89e58bce4fba5abce23d9cb6c826b50d4cda52b3fa40a6194003a51c6209f2d4aef43d9dc62f08b51a776a7 SHA512 809e86e9cd2cb67ae338b2584c0c8f5d4f01104cc7725826743f48eb5c893bce9cd678bcd90e04953bb6bfc6523fcf400c6bc1bdf03ff335666b05af5e0c4b55
diff --git a/net-vpn/frp/frp-0.58.1.ebuild b/net-vpn/frp/frp-0.58.1.ebuild
new file mode 100644
index 000000000000..df51f8a4c33b
--- /dev/null
+++ b/net-vpn/frp/frp-0.58.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module systemd shell-completion
+
+DESCRIPTION="A reverse proxy that exposes a server behind a NAT or firewall to the internet"
+HOMEPAGE="https://github.com/fatedier/frp"
+SRC_URI="https://github.com/fatedier/frp/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~zmedico/dist/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0 BSD BSD-2 ISC MIT MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~loong ~riscv"
+IUSE="+client +server"
+REQUIRED_USE="|| ( client server )"
+BDEPEND=">=dev-lang/go-1.22"
+
+src_compile() {
+ mkdir -pv comp || die
+
+ if use client; then
+ ego build -trimpath -ldflags "-s -w" -tags frpc -o frpc ./cmd/frpc
+ ./frpc completion bash > comp/frpc || die
+ ./frpc completion fish > comp/frpc.fish || die
+ ./frpc completion zsh > comp/_frpc || die
+ fi
+
+ if use server; then
+ ego build -trimpath -ldflags "-s -w" -tags frps -o frps ./cmd/frps
+ ./frps completion bash > comp/frps || die
+ ./frps completion fish > comp/frps.fish || die
+ ./frps completion zsh > comp/_frps || die
+ fi
+}
+
+src_install() {
+ _install() {
+ # Install binary file
+ dobin "${1}"
+
+ # Install completion files
+ dobashcomp "${S}/comp/${1}"
+ dofishcomp "${S}/comp/${1}.fish"
+ dozshcomp "${S}/comp/_${1}"
+
+ # Install systemd services
+ systemd_dounit "${FILESDIR}/${1}.service"
+ systemd_newunit "${FILESDIR}/${1}_at_.service" "${1}@.service"
+
+ # Install config files
+ insinto "/etc/${PN}"
+ newins "${S}/conf/${1}.toml" "${1}.toml.example"
+ newins "${S}/conf/${1}_full_example.toml" "${1}_full.toml.example"
+ }
+
+ if use client; then
+ _install frpc
+ fi
+
+ if use server; then
+ _install frps
+ fi
+}