summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-03-11 17:25:37 -0700
committerPatrick McLean <chutzpah@gentoo.org>2020-03-11 17:25:55 -0700
commit8e3b4abba8e585c09b9fcc1146fb2b6cfa49a0c4 (patch)
treef0e165d57d80b150aac68feff74f216aacb73c5b /net-vpn/openvpn
parentnet-vpn/openvpn-2.4.8: Version bump (diff)
downloadgentoo-8e3b4abba8e585c09b9fcc1146fb2b6cfa49a0c4.tar.gz
gentoo-8e3b4abba8e585c09b9fcc1146fb2b6cfa49a0c4.tar.bz2
gentoo-8e3b4abba8e585c09b9fcc1146fb2b6cfa49a0c4.zip
net-vpn/openvpn-9999: Sync with 2.4.8
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.93, Repoman-2.3.20 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'net-vpn/openvpn')
-rw-r--r--net-vpn/openvpn/openvpn-9999.ebuild42
1 files changed, 21 insertions, 21 deletions
diff --git a/net-vpn/openvpn/openvpn-9999.ebuild b/net-vpn/openvpn/openvpn-9999.ebuild
index 19122b752be6..8ea466d6754f 100644
--- a/net-vpn/openvpn/openvpn-9999.ebuild
+++ b/net-vpn/openvpn/openvpn-9999.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit autotools flag-o-matic user systemd linux-info git-r3
+inherit autotools flag-o-matic systemd linux-info git-r3
DESCRIPTION="Robust and highly flexible tunneling application compatible with many OSes"
EGIT_REPO_URI="https://github.com/OpenVPN/${PN}.git"
@@ -18,14 +18,15 @@ IUSE="down-root examples inotify iproute2 libressl lz4 +lzo mbedtls pam"
IUSE+=" pkcs11 +plugins selinux +ssl systemd test userland_BSD"
RESTRICT="!test? ( test )"
-REQUIRED_USE="lzo? ( !lz4 )
+REQUIRED_USE="pkcs11? ( ssl )
!plugins? ( !pam !down-root )
- inotify? ( plugins )"
+ inotify? ( plugins )
+"
CDEPEND="
kernel_linux? (
iproute2? ( sys-apps/iproute2[-minimal] )
- !iproute2? ( sys-apps/net-tools )
+ !iproute2? ( >=sys-apps/net-tools-1.60_p20160215155418 )
)
pam? ( sys-libs/pam )
ssl? (
@@ -38,18 +39,19 @@ CDEPEND="
lz4? ( app-arch/lz4 )
lzo? ( >=dev-libs/lzo-1.07 )
pkcs11? ( >=dev-libs/pkcs11-helper-1.11 )
- systemd? ( sys-apps/systemd )"
+ systemd? ( sys-apps/systemd )
+"
DEPEND="${CDEPEND}
- test? ( dev-util/cmocka )"
+ test? ( dev-util/cmocka )
+"
RDEPEND="${CDEPEND}
- selinux? ( sec-policy/selinux-openvpn )"
+ acct-group/openvpn
+ acct-user/openvpn
+ selinux? ( sec-policy/selinux-openvpn )
+"
CONFIG_CHECK="~TUN"
-PATCHES=(
- "${FILESDIR}/${PN}-2.5-external-cmocka.patch"
-)
-
pkg_setup() {
linux-info_pkg_setup
}
@@ -74,7 +76,6 @@ src_configure() {
$(use_enable iproute2) \
$(use_enable pam plugin-auth-pam) \
$(use_enable down-root plugin-down-root) \
- $(use_enable test tests) \
$(use_enable systemd)
}
@@ -104,17 +105,16 @@ src_install() {
# install examples, controlled by the respective useflag
if use examples ; then
# dodoc does not supportly support directory traversal, #15193
- insinto /usr/share/doc/${PF}/examples
- doins -r sample contrib
+ docinto /usr/share/doc/${PF}/examples
+ dodoc -r sample contrib
fi
}
pkg_postinst() {
- # Add openvpn user so openvpn servers can drop privs
- # Clients should run as root so they can change ip addresses,
- # dns information and other such things.
- enewgroup openvpn
- enewuser openvpn "" "" "" openvpn
+ if use x64-macos; then
+ elog "You might want to install tuntaposx for TAP interface support:"
+ elog "http://tuntaposx.sourceforge.net"
+ fi
elog "The openvpn init script expects to find the configuration file"
elog "openvpn.conf in /etc/openvpn along with any extra files it may need."
@@ -140,7 +140,7 @@ pkg_postinst() {
if use plugins ; then
einfo ""
- einfo "plugins have been installed into /usr/$(get_libdir)/${PN}"
+ einfo "plugins have been installed into /usr/$(get_libdir)/${PN}/plugins"
fi
ewarn ""