summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-30 20:12:17 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-12-31 19:42:20 +0100
commitbe0ab352405aa2d5d968a8c3905557b914df9626 (patch)
tree5b5da6a6ab8feb0c82b1f5c6b02e9fafdee83463 /net-proxy
parentsys-kernel/gentoo-sources: Linux patch 5.4.7 (diff)
downloadgentoo-be0ab352405aa2d5d968a8c3905557b914df9626.tar.gz
gentoo-be0ab352405aa2d5d968a8c3905557b914df9626.tar.bz2
gentoo-be0ab352405aa2d5d968a8c3905557b914df9626.zip
*/*: Switch proxy-maint to cmake.eclass
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/trojan/trojan-1.12.3.ebuild9
-rw-r--r--net-proxy/trojan/trojan-1.13.0.ebuild9
2 files changed, 8 insertions, 10 deletions
diff --git a/net-proxy/trojan/trojan-1.12.3.ebuild b/net-proxy/trojan/trojan-1.12.3.ebuild
index e394deff72a0..012870955efa 100644
--- a/net-proxy/trojan/trojan-1.12.3.ebuild
+++ b/net-proxy/trojan/trojan-1.12.3.ebuild
@@ -5,7 +5,7 @@ EAPI=7
PYTHON_COMPAT=( python{3_5,3_6,3_7} )
-inherit cmake-utils python-any-r1 systemd
+inherit cmake python-any-r1 systemd
DESCRIPTION="An unidentifiable mechanism that helps you bypass GFW"
HOMEPAGE="https://github.com/trojan-gfw/${PN}"
@@ -32,16 +32,15 @@ src_configure() {
-DENABLE_MYSQL=$(usex mysql)
-DSYSTEMD_SERVICE=ON
-DSYSTEMD_SERVICE_PATH=$(systemd_get_systemunitdir)
- -DCMAKE_INSTALL_DOCDIR=share/doc/${PF}
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
newinitd "${FILESDIR}/trojan.initd" trojan
}
src_test() {
- cmake-utils_src_test -j1
+ cmake_src_test -j1
}
diff --git a/net-proxy/trojan/trojan-1.13.0.ebuild b/net-proxy/trojan/trojan-1.13.0.ebuild
index 64ae38797920..b1e471124857 100644
--- a/net-proxy/trojan/trojan-1.13.0.ebuild
+++ b/net-proxy/trojan/trojan-1.13.0.ebuild
@@ -5,7 +5,7 @@ EAPI=7
PYTHON_COMPAT=( python{3_5,3_6,3_7} )
-inherit cmake-utils python-any-r1 systemd
+inherit cmake python-any-r1 systemd
DESCRIPTION="An unidentifiable mechanism that helps you bypass GFW"
HOMEPAGE="https://github.com/trojan-gfw/trojan"
@@ -33,16 +33,15 @@ src_configure() {
-DENABLE_MYSQL=$(usex mysql)
-DSYSTEMD_SERVICE=ON
-DSYSTEMD_SERVICE_PATH=$(systemd_get_systemunitdir)
- -DCMAKE_INSTALL_DOCDIR=share/doc/${PF}
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
newinitd "${FILESDIR}/trojan.initd" trojan
}
src_test() {
- cmake-utils_src_test -j1
+ cmake_src_test -j1
}