summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-11-23 16:26:37 +0000
committerSam James <sam@gentoo.org>2024-11-23 16:26:37 +0000
commit9b6cf3d873b71607d29ad78b8275803daac06dc0 (patch)
tree097063f74ff361121ad6203e5a712106965f0dbd /net-proxy
parentmedia-gfx/jpeginfo: Stabilize 1.7.1 x86, #944690 (diff)
downloadgentoo-9b6cf3d873b71607d29ad78b8275803daac06dc0.tar.gz
gentoo-9b6cf3d873b71607d29ad78b8275803daac06dc0.tar.bz2
gentoo-9b6cf3d873b71607d29ad78b8275803daac06dc0.zip
net-proxy/lyrebird: add 0.5.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/lyrebird/Manifest2
-rw-r--r--net-proxy/lyrebird/lyrebird-0.5.0.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/net-proxy/lyrebird/Manifest b/net-proxy/lyrebird/Manifest
index 7c0ff52ea34e..e8331123e1a1 100644
--- a/net-proxy/lyrebird/Manifest
+++ b/net-proxy/lyrebird/Manifest
@@ -2,3 +2,5 @@ DIST lyrebird-0.1.0-deps.tar.xz 88991580 BLAKE2B ba9113d847bc900ad3001e91a67ac93
DIST lyrebird-0.1.0.tar.bz2 76753 BLAKE2B af168a25093b68b10b489adc282f1ee65b70193602f79d9cc352c78e2a9c71205191dc6487ea58584f76ce1cbbf653d3fd0e1f645d7972d3e73173a90ae39361 SHA512 f9b8686d1c5f9ddb41a255a1a8954e05cefd50523ada7360432b456c62475ba606872df407ba8ebd7714d4f185eef0efae63e3e53c5c1c18fd323a97912f951e
DIST lyrebird-0.4.0-deps.tar.xz 44450504 BLAKE2B 7d8010c4f2d911f26d37b7069908368ac56e4237c9cb25f7845b16cf881e2b25d30e135314b0f8cd60c42c7a34aedd17586689134b7357ff33e2673f9664c7c0 SHA512 8cf0b3e80a0d1bdc2af0d6900862fbc48d7fa02593d3c0a92f9d21598fd3df69aa312f55ae122837fa409b0ee83fc7373c2fd5d2a43c14f8d3e3bab77b8b77a4
DIST lyrebird-0.4.0.tar.bz2 80497 BLAKE2B 060ceba6389f8f6a739e43162bf6b54e410c5206348f323e83130903c9dd07622393a28a0da8cf6e59376406be10d17b003e416dba3dcca8fa9ad3e41b68d4db SHA512 406d62d7da76807ad9fa1107bb9f335fc14f54dfecda26964886869e35122172d302ccc83442b355c055d506c84a212da11ea3b1f456f6fd19674a5c1bcd1773
+DIST lyrebird-0.5.0-deps.tar.xz 49717604 BLAKE2B cb490f3c5b13512f2c9238c8ea47121627d1b77c33e637096cd466d1f59fc71b6113bb10ba2ac3cee16bf9f8c8885a8f4587384bfe6f09ff8b2bbcef087e819c SHA512 33b8ab0e4850c06720430df90ca0a174925b2c03366b1dc2b71480ed3c7c8344dee4c12145654e757d9c8c2dc583a5d44b952ed021b570b86878edfa57b1cfa5
+DIST lyrebird-0.5.0.tar.bz2 111189 BLAKE2B d534074f6db7ad190b12010ddc44889c15ae2c3dc594e30dea41ae1f092ca83481ecb51611d763b63a8b3d8d97f887fdc4e216b41dab3b219d7c2df2f7b5d84f SHA512 8059583ae6ebc121cb853600d635382c9d85b6a98a71be0f7f71bfd780d4278804b89cdaa083233dcdb47ec64ebf00a32a57b84f5cd46d42c94e6a7ff74887a8
diff --git a/net-proxy/lyrebird/lyrebird-0.5.0.ebuild b/net-proxy/lyrebird/lyrebird-0.5.0.ebuild
new file mode 100644
index 000000000000..0313b779ac34
--- /dev/null
+++ b/net-proxy/lyrebird/lyrebird-0.5.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="An obfuscating proxy supporting Tor's pluggable transport protocol obfs4"
+HOMEPAGE="https://gitlab.torproject.org/tpo/anti-censorship/pluggable-transports/lyrebird"
+SRC_URI="https://gitlab.torproject.org/tpo/anti-censorship/pluggable-transports/${PN}/-/archive/${P}/${PN}-${P}.tar.bz2 -> ${P}.tar.bz2"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+S="${WORKDIR}"/${PN}-${P}
+
+LICENSE="BSD CC0-1.0 BZIP2 GPL-3+ MIT public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~riscv ~x86"
+IUSE="selinux"
+
+RDEPEND="selinux? ( sec-policy/selinux-obfs4proxy )"
+BDEPEND=">=dev-lang/go-1.21"
+
+DOCS=( README.md ChangeLog doc/obfs4-spec.txt )
+
+src_compile() {
+ ego build ./cmd/${PN}
+}
+
+src_install() {
+ dobin ${PN}
+ doman doc/${PN}.1
+}
+
+pkg_postinst() {
+ if [[ ! -z "${REPLACING_VERSIONS}" ]]; then
+ local oldver
+ for oldver in ${REPLACING_VERSIONS}; do
+ if ver_test "${oldver}" -lt 0.1.0; then
+ ewarn "Since version 0.1.0 the proxy executable is called '${PN}' rather than 'obfs4proxy'."
+ ewarn "Please update your Tor configuration accordingly."
+ ewarn
+ break
+ fi
+ done
+ fi
+}