summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Smith <matt@offtopica.uk>2021-10-28 17:24:57 +0100
committerSam James <sam@gentoo.org>2021-10-31 02:59:47 +0000
commit8f71e73d68dda7c748867b29013b9d23d48fd6b9 (patch)
tree62285bf6508a35366b7324b4dc5a13c11be8760d /net-proxy
parentmedia-sound/beets: update 9999 (diff)
downloadgentoo-8f71e73d68dda7c748867b29013b9d23d48fd6b9.tar.gz
gentoo-8f71e73d68dda7c748867b29013b9d23d48fd6b9.tar.bz2
gentoo-8f71e73d68dda7c748867b29013b9d23d48fd6b9.zip
net-proxy/mitmproxy: Bump to 7.0.4
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Matt Smith <matt@offtopica.uk> Closes: https://github.com/gentoo/gentoo/pull/22745 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/mitmproxy/Manifest1
-rw-r--r--net-proxy/mitmproxy/mitmproxy-7.0.4.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/net-proxy/mitmproxy/Manifest b/net-proxy/mitmproxy/Manifest
index cfbb764a1564..abd6222b1626 100644
--- a/net-proxy/mitmproxy/Manifest
+++ b/net-proxy/mitmproxy/Manifest
@@ -1 +1,2 @@
DIST mitmproxy-7.0.3.tar.gz 27311502 BLAKE2B a55f8a43cc052e342a0630fdd80fc713be7ce3db7b3899ccce79cfcd385345b7ebe8480c618c626d63e851d92f528a350d614ac3c7dfb85b01a555389d914ff7 SHA512 cffbb60421724fa28aab69b3bf1100e0aa5ab6e8933186f5706eb4eee35ef0f716616001156dac07921c73024e6ad8b98499a273575c592bb7694c0dffb728da
+DIST mitmproxy-7.0.4.tar.gz 27312748 BLAKE2B a23db472adab33db615b0daa93694211450e8899885dc75601d40a4964cc505437db6a106622eb8051263db23280261134937b6567482dd584eed29cc592e42b SHA512 4224b44e609f84b974b5419c6ceb576845957968c786ee437bffb5fa5df685ce0712d5ef8c402d40c568406242f44692cc7f04037fadd19ecece8b112d73b7ae
diff --git a/net-proxy/mitmproxy/mitmproxy-7.0.4.ebuild b/net-proxy/mitmproxy/mitmproxy-7.0.4.ebuild
new file mode 100644
index 000000000000..0abdfc2548cf
--- /dev/null
+++ b/net-proxy/mitmproxy/mitmproxy-7.0.4.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8,9} )
+PYTHON_REQ_USE="sqlite"
+inherit distutils-r1
+
+DESCRIPTION="An interactive, SSL-capable, man-in-the-middle HTTP proxy"
+HOMEPAGE="https://mitmproxy.org/"
+SRC_URI="https://github.com/mitmproxy/mitmproxy/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=app-arch/brotli-1.0.0[python,${PYTHON_USEDEP}]
+ >=dev-python/asgiref-3.2.10[${PYTHON_USEDEP}]
+ >=dev-python/blinker-1.4[${PYTHON_USEDEP}]
+ >=dev-python/certifi-2015.11.20.1[${PYTHON_USEDEP}]
+ >=dev-python/click-7.0[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-3.3[${PYTHON_USEDEP}]
+ >=dev-python/flask-1.1.1[${PYTHON_USEDEP}]
+ >=dev-python/h2-4.0.0[${PYTHON_USEDEP}]
+ >=dev-python/hyperframe-6.0.0[${PYTHON_USEDEP}]
+ >=dev-python/kaitaistruct-0.7[${PYTHON_USEDEP}]
+ >=dev-python/ldap3-2.8[${PYTHON_USEDEP}]
+ >=dev-python/msgpack-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/passlib-1.6.5[${PYTHON_USEDEP}]
+ >=dev-python/protobuf-python-3.14.0[${PYTHON_USEDEP}]
+ >=dev-python/publicsuffix-2.20190205[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-0.3.1[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-20.0[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-2.4.2[${PYTHON_USEDEP}]
+ >=dev-python/pyperclip-1.6.0[${PYTHON_USEDEP}]
+ >=dev-python/ruamel-yaml-0.16[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.3.0[${PYTHON_USEDEP}]
+ >=www-servers/tornado-4.3[${PYTHON_USEDEP}]
+ >=dev-python/urwid-2.1.1[${PYTHON_USEDEP}]
+ >=dev-python/wsproto-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/zstandard-0.11.0[${PYTHON_USEDEP}]
+ dev-libs/openssl:0
+"
+
+BDEPEND="
+ test? (
+ >=dev-python/hypothesis-5.8[${PYTHON_USEDEP}]
+ >=dev-python/parver-0.1[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.10.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.9.1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # loosen dependencies
+ sed -i \
+ -e '/>/s/>.*/",/g' \
+ -e '/python_requires/d' \
+ setup.py || die
+
+ # remove failing test
+ sed -i 's/test_get_version/_&/g' test/mitmproxy/test_version.py || die
+
+ distutils-r1_python_prepare_all
+}