summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFilip Kobierski <fkobi@pm.me>2024-10-01 09:10:48 +0200
committerEli Schwartz <eschwartz@gentoo.org>2024-10-01 19:04:09 -0400
commitf24dd67a61b59a6e1af4d3a21e14ca48a41cb490 (patch)
treeab396d899031907e3778ee28443d3a1244ef045f /net-p2p
parentnet-libs/libtorrent-rasterbar: drop 2.0.9-r0 (diff)
downloadgentoo-f24dd67a61b59a6e1af4d3a21e14ca48a41cb490.tar.gz
gentoo-f24dd67a61b59a6e1af4d3a21e14ca48a41cb490.tar.bz2
gentoo-f24dd67a61b59a6e1af4d3a21e14ca48a41cb490.zip
net-p2p/qbittorrent: add 5.0.0
- remove qt5 support & qt6 USE flag (upstream dropped qt5 support) - bump minimal versions - fix LICENSE Signed-off-by: Filip Kobierski <fkobi@pm.me> Signed-off-by: Eli Schwartz <eschwartz@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/qbittorrent/Manifest2
-rw-r--r--net-p2p/qbittorrent/qbittorrent-5.0.0.ebuild129
2 files changed, 131 insertions, 0 deletions
diff --git a/net-p2p/qbittorrent/Manifest b/net-p2p/qbittorrent/Manifest
index dcf2d1e8c23a..c8db56dc3660 100644
--- a/net-p2p/qbittorrent/Manifest
+++ b/net-p2p/qbittorrent/Manifest
@@ -4,3 +4,5 @@ DIST qbittorrent-4.6.6.tar.xz 4524468 BLAKE2B 20141bf0bca5dd851950e070172d509b8f
DIST qbittorrent-4.6.6.tar.xz.asc 849 BLAKE2B 56ec7c17d3c49661bc156400d6a721767fa2b90e9946b4a6e737fa712bc60dc61ec08a4db638dcc440875a217ae36823d645bbd2a913e14b35747a3128ad9d21 SHA512 09975d8200f9c6c46ace2de95f43f42924ddfebb3140a20f10db2389fc63f1f2117e28bc3084da5605b01a0c040f272bd1e638feea51ebcc4cd56df1e9cb2af4
DIST qbittorrent-4.6.7.tar.xz 4539016 BLAKE2B 8565fdc298e5085b10b52442874ce2d9b9f253ba57bb2d1bef065d603847e5d3d838197ea2077aa80cc3db56aea4b1100fad2d7a0398fa13128d4a064286afc6 SHA512 3664c89f91a3443c74a5c76da8f66ab595bf4f48cbba2421a287d4f8bf780e06605cd0a6fa9598a5ab09e876a46d31b2f85461ef65f17410df1914acd9d37262
DIST qbittorrent-4.6.7.tar.xz.asc 849 BLAKE2B e63d1fc1c8c6b9a70551bd717a2614b8548bd93656b578f4289d720c2784508ca90971f995fa6c8b6dc26ed6a7f976d294e44d4e384bb3de30791f26ff930017 SHA512 820e329921d23409560fa2a2f3e714b233154783da5bb8fdcf7ed70c90df69d5140d8159f8d52dc1a9b5cc32306580a08e56c02b55f0e2b00c16cbf9f6982baa
+DIST qbittorrent-5.0.0.tar.xz 4512592 BLAKE2B 156a2aae2c45d877197d50ec0c42b003dcb290d2e612b93d94f10c1c1b55fb24d6bc37cfd489b70f545bb4f390ee35634a808992441ce49e7e27de5ecb508943 SHA512 ab480c181f3a43a3e248daa35d3d3e0b121eb80bfd8a4a4d63fd504ba26441a31e7ca563fe80bc520ad1219104cf929460cfc0a5cfdad13ad61a5a316deeb695
+DIST qbittorrent-5.0.0.tar.xz.asc 849 BLAKE2B c3fee4711f51491c26ca7669ce8746853b886334454b1b6a7ae0fb61e2634cfe3172c00f3b0ac2c1ca498b23969c3d6ac3095fbb380e9a3626a1923705a40fb3 SHA512 60589122b9030f17afa766a757992134430f7bb32ee97acc5f544dcac99f82a0fc00411d46a11c52f350790f86fa686158e06c74cc53dbabcfc96ebb5f4af09e
diff --git a/net-p2p/qbittorrent/qbittorrent-5.0.0.ebuild b/net-p2p/qbittorrent/qbittorrent-5.0.0.ebuild
new file mode 100644
index 000000000000..77ac01cf12cb
--- /dev/null
+++ b/net-p2p/qbittorrent/qbittorrent-5.0.0.ebuild
@@ -0,0 +1,129 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake edo multibuild systemd verify-sig xdg
+
+DESCRIPTION="BitTorrent client in C++ and Qt"
+HOMEPAGE="https://www.qbittorrent.org"
+
+if [[ ${PV} == *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/qbittorrent/qBittorrent.git"
+ inherit git-r3
+else
+ SRC_URI="
+ https://downloads.sourceforge.net/qbittorrent/${P}.tar.xz
+ verify-sig? ( https://downloads.sourceforge.net/qbittorrent/${P}.tar.xz.asc )
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+ BDEPEND="verify-sig? ( sec-keys/openpgp-keys-qbittorrent )"
+ VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/qBittorrent.asc
+fi
+
+LICENSE="GPL-2+ GPL-3+"
+SLOT="0"
+IUSE="+dbus +gui systemd test webui"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="
+ || ( gui webui )
+ dbus? ( gui )
+"
+
+RDEPEND="
+ >=dev-libs/openssl-3.0.2:=
+ >=net-libs/libtorrent-rasterbar-1.2.19:=
+ >=sys-libs/zlib-1.2.11
+ >=dev-qt/qtbase-6.5:6[network,ssl,sql,sqlite,xml]
+ gui? (
+ >=dev-qt/qtbase-6.5:6[dbus?,gui,widgets]
+ >=dev-qt/qtsvg-6.5:6
+ )
+ webui? (
+ acct-group/qbittorrent
+ acct-user/qbittorrent
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ >=dev-libs/boost-1.76
+"
+BDEPEND+="
+ >=dev-qt/qttools-6.5:6[linguist]
+ virtual/pkgconfig
+"
+
+DOCS=( AUTHORS Changelog CONTRIBUTING.md README.md )
+
+src_prepare() {
+ MULTIBUILD_VARIANTS=()
+ use gui && MULTIBUILD_VARIANTS+=( gui )
+ use webui && MULTIBUILD_VARIANTS+=( nogui )
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ my_src_configure() {
+ local mycmakeargs=(
+ # musl lacks execinfo.h
+ -DSTACKTRACE=$(usex !elibc_musl)
+ # More verbose build logs are preferable for bug reports
+ -DVERBOSE_CONFIGURE=ON
+ -DWEBUI=$(usex webui)
+ -DTESTING=$(usex test)
+ )
+
+ if [[ ${MULTIBUILD_VARIANT} == "gui" ]]; then
+ # We do this in multibuild, see bug #839531 for why.
+ # Fedora has to do the same thing.
+ mycmakeargs+=(
+ -DGUI=ON
+ -DDBUS=$(usex dbus)
+ -DSYSTEMD=OFF
+ )
+ else
+ mycmakeargs+=(
+ -DGUI=OFF
+ -DDBUS=OFF
+ )
+
+ use systemd && mycmakeargs+=(
+ # The systemd service calls qbittorrent-nox, which is only
+ # installed when GUI=OFF.
+ -DSYSTEMD=ON
+ -DSYSTEMD_SERVICES_INSTALL_DIR="$(systemd_get_systemunitdir)"
+ )
+ fi
+
+ cmake_src_configure
+ }
+
+ multibuild_foreach_variant my_src_configure
+}
+
+src_compile() {
+ multibuild_foreach_variant cmake_src_compile
+}
+
+src_test() {
+ my_src_test() {
+ # cmake does not detect tests by default, if you use enable_testing
+ # in a subdirectory instead of the root CMakeLists.txt
+ cd "${BUILD_DIR}"/test || die
+ edo ctest .
+ }
+
+ multibuild_foreach_variant my_src_test
+}
+
+src_install() {
+ multibuild_foreach_variant cmake_src_install
+ einstalldocs
+
+ if use webui; then
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ fi
+}