summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorマリウス <marius@xn--gckvb8fzb.com>2021-12-17 00:13:26 -0500
committerJoonas Niilola <juippis@gentoo.org>2022-01-15 13:32:56 +0200
commit6fe8482d6e4e4a38aa2a602d9dcc27030fbaf57e (patch)
treeff1c2530586ee507b6602650d447df0e2eec53a6 /net-p2p
parentdev-tex/latexdiff: 1.3.2 version bump (diff)
downloadgentoo-6fe8482d6e4e4a38aa2a602d9dcc27030fbaf57e.tar.gz
gentoo-6fe8482d6e4e4a38aa2a602d9dcc27030fbaf57e.tar.bz2
gentoo-6fe8482d6e4e4a38aa2a602d9dcc27030fbaf57e.zip
net-p2p/resilio-sync: version bump to 2.7.2.1375
Signed-off-by: Joonas Niilola <juippis@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/23352
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/resilio-sync/Manifest2
-rw-r--r--net-p2p/resilio-sync/resilio-sync-2.7.2.1375.ebuild80
2 files changed, 82 insertions, 0 deletions
diff --git a/net-p2p/resilio-sync/Manifest b/net-p2p/resilio-sync/Manifest
index cc8b4bc228e2..ea7f1dfb96ac 100644
--- a/net-p2p/resilio-sync/Manifest
+++ b/net-p2p/resilio-sync/Manifest
@@ -1,2 +1,4 @@
DIST resilio-sync_2.6.3-1_amd64.deb 12111264 BLAKE2B e4b4d3d0bda910db5f10131d9072c47d7daccd6ff37267546385fb2657c84d9b12e9ae637df8380175f175c3e3a304fc3424ab93aa71b69d9890320d3464cf58 SHA512 92097e155fe74c07a89034db75e889fb3679fbd6cc497a361e4cf403bd1ffb5c2bc9f2a327d65d20b03067e5b7b898635a2dbeff7d4d9937b5e5ffe4daf4ba9d
DIST resilio-sync_2.6.3-1_i386.deb 12062034 BLAKE2B 9c92e118ee8977a7e26948a21c61e1ff7c0692a2a76ff11e1b6ea8ef0edb08032d33453963b8c400c8945ed67cc561ce8334391fc4d8edc2e4bf37ff3c8acaff SHA512 4254de420b2b2263779befbfd93bddb8fa5352fbcce80e2a21efb463f0f3008a282fd07eb6602d4785ca6f0e770980b6da66c8d33911ae68938aee5e09e08e44
+DIST resilio-sync_2.7.2.1375-1_amd64.deb 11845750 BLAKE2B 894b975327f18ef4c5fe124466d9b1b50de72d08c106fe9f61a634e42b98042c2f5b40ed6c1afc2550fea3506e6cdef7d58eb041604624b26a5a877d62d941e5 SHA512 563643aab506f521c320e5b2ddc08d7d6893ea0908ecedeb11237495c47fb0585a781f83d0daacaf7de2084d9312784b947ad2e626995a05cdd03ffaae413665
+DIST resilio-sync_2.7.2.1375-1_i386.deb 11921570 BLAKE2B 8595bfa5ca1c366fdeb93a4126b5634ef65ffab1883a6b9a5f557d172b18a6f1966f891ff79407e576eaa3315b8d67b7fe11c7b8a760a5ab0272e1bcb4224552 SHA512 114af90ea5e89c6f3698cfd9eb8f5dd8bd5316ab5fd0873238a78a29e4c33d0e96a19f61687d47f46d708b79a2f1877166075e7c3e11b4e4fe4f517cc26d2231
diff --git a/net-p2p/resilio-sync/resilio-sync-2.7.2.1375.ebuild b/net-p2p/resilio-sync/resilio-sync-2.7.2.1375.ebuild
new file mode 100644
index 000000000000..8fa9b94c65f9
--- /dev/null
+++ b/net-p2p/resilio-sync/resilio-sync-2.7.2.1375.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit pax-utils readme.gentoo-r1 systemd tmpfiles unpacker
+
+QA_PREBUILT="usr/bin/rslsync"
+BASE_URI="http://download-cdn.resilio.com/${PV}/Debian/${PN}_${PV}-1_@arch@.deb"
+
+DESCRIPTION="Resilient, fast and scalable file synchronization tool"
+HOMEPAGE="https://resilio.com/"
+SRC_URI="
+ amd64? ( ${BASE_URI/@arch@/amd64} )
+ x86? ( ${BASE_URI/@arch@/i386} )
+"
+S="${WORKDIR}"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="bindist mirror"
+
+DEPEND="
+ acct-group/rslsync
+ acct-user/rslsync
+"
+
+RDEPEND="
+ ${DEPEND}
+ || (
+ sys-libs/libxcrypt[compat]
+ sys-libs/glibc[crypt(+)]
+ )"
+
+DOC_CONTENTS="You may need to review /etc/resilio-sync/config.json\\n
+Default metadata path is /var/lib/resilio-sync/.sync\\n
+Default web-gui URL is http://localhost:8888/\\n\\n"
+
+src_unpack() {
+ unpacker_src_unpack
+
+ unpack usr/share/man/man1/resilio-sync.1.gz
+}
+
+src_install() {
+ dobin usr/bin/rslsync
+ pax-mark m "${ED}"/usr/bin/rslsync
+
+ doman resilio-sync.1
+
+ newinitd "${FILESDIR}"/resilio-sync.initd resilio-sync
+ newconfd "${FILESDIR}"/resilio-sync.confd resilio-sync
+ newinitd "${FILESDIR}"/resilio-sync-user.initd resilio-sync-user
+ newconfd "${FILESDIR}"/resilio-sync-user.confd resilio-sync-user
+ systemd_dounit "${FILESDIR}"/resilio-sync.service
+ systemd_douserunit "${FILESDIR}"/resilio-sync-user.service
+ newtmpfiles "${FILESDIR}"/resilio-sync.tmpfile resilio-sync.conf
+
+ readme.gentoo_create_doc
+
+ # Generate sample config, uncomment config directives and change values
+ insopts -orslsync -grslsync -m0644
+ insinto /etc/resilio-sync
+ newins - config.json < <("${ED}"/usr/bin/rslsync --dump-sample-config | \
+ sed \
+ -e "/storage_path/s|//| |g" \
+ -e "/pid_file/s|//| |g" \
+ -e "/storage_path/s|/home/user/.sync|/var/lib/resilio-sync/.sync|g" \
+ -e "/pid_file/s|resilio/resilio|resilio-sync/resilio-sync|g" \
+ || die "sed failed for config.json" )
+
+ diropts -orslsync -grslsync -m0700
+ keepdir /etc/resilio-sync /var/lib/resilio-sync/.sync /var/log/resilio-sync
+}
+
+pkg_postinst() {
+ tmpfiles_process resilio-sync.conf
+ readme.gentoo_print_elog
+}