summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert III <ajak@gentoo.org>2023-05-28 11:30:52 -0700
committerJohn Helmert III <ajak@gentoo.org>2023-05-28 11:32:34 -0700
commit60d324664c386e3bd32b3820a72a3d8c9d497f9c (patch)
tree5ec9a1b48a525b42016813c768d8fc6e1da1630e /net-p2p/tremc
parentmedia-gfx/phototonic: update EAPI 7 -> 8, fix build with >=exiv2-0.28 (diff)
downloadgentoo-60d324664c386e3bd32b3820a72a3d8c9d497f9c.tar.gz
gentoo-60d324664c386e3bd32b3820a72a3d8c9d497f9c.tar.bz2
gentoo-60d324664c386e3bd32b3820a72a3d8c9d497f9c.zip
net-p2p/tremc: add 0.9.3_p20230506
And slide PYTHON_COMPAT window forward. Bug: https://bugs.gentoo.org/902907 Signed-off-by: John Helmert III <ajak@gentoo.org>
Diffstat (limited to 'net-p2p/tremc')
-rw-r--r--net-p2p/tremc/Manifest1
-rw-r--r--net-p2p/tremc/tremc-0.9.3_p20230506.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/net-p2p/tremc/Manifest b/net-p2p/tremc/Manifest
index f15840486e81..c2583532cd2e 100644
--- a/net-p2p/tremc/Manifest
+++ b/net-p2p/tremc/Manifest
@@ -1 +1,2 @@
DIST tremc-0.9.3.tar.gz 334457 BLAKE2B 328f158c96c4927fb910a58508fb3a74aa43d6ab74dfcdde7a99eee0ba70aa7020e00f19197ba0d3ae641b169cf147fc0ea04c1ef4e638a41a29311a042df284 SHA512 cbc40ce36eec1f641a6754933e7b009ca3d47e9a2d5091f7677f8005c466f6d0c744023b92e6b5aa93e736828390917c2b5f2f87ba6634d74016960b764467eb
+DIST tremc-0.9.3_p20230506.tar.gz 337178 BLAKE2B 64e9443bb11d1151a1d9d811ddeaacf67e6e68c37faca3b0267291822d124370f8b1e382c408b2b18f164549a1179dd9c613c4e54f0a93effd501cef76910485 SHA512 f13abd1ae5d8bfca4d7d1c10d870e654e974ffd06d7fd46b5d10ae3e6480f9e462c18e7e5cbfbf5bea5c19f8443e76e50e7e3f536db9e1993b4c6bed040c9d66
diff --git a/net-p2p/tremc/tremc-0.9.3_p20230506.ebuild b/net-p2p/tremc/tremc-0.9.3_p20230506.ebuild
new file mode 100644
index 000000000000..dbe299c4ad08
--- /dev/null
+++ b/net-p2p/tremc/tremc-0.9.3_p20230506.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+COMMIT=d8deaa5ac25bb45a2ca3a930309d6ecc74836a54
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="ncurses"
+
+inherit bash-completion-r1 optfeature python-single-r1
+
+DESCRIPTION="Ncurses interface for the Transmission BitTorrent client"
+HOMEPAGE="https://github.com/tremc/tremc"
+SRC_URI="https://github.com/tremc/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+
+# Github tag tarballs include the repo with commit in the dir's name
+# Specify a no-op src_compile so upstream's broken Makefile doesn't get used
+src_compile() {
+ :
+}
+
+src_install() {
+ python_doscript tremc
+ newbashcomp completion/bash/tremc.sh tremc
+ insinto /usr/share/zsh/site-functions
+ doins completion/zsh/_tremc
+ doman tremc.1
+ dodoc NEWS README.md
+}
+
+pkg_postinst() {
+ optfeature "Extract ipv4 from ipv6 addresses" dev-python/ipy
+ optfeature "Clipboard support" dev-python/pyperclip
+}