summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-nntp/nzb
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-nntp/nzb')
-rw-r--r--net-nntp/nzb/Manifest2
-rw-r--r--net-nntp/nzb/metadata.xml10
-rw-r--r--net-nntp/nzb/nzb-0.2.ebuild27
-rw-r--r--net-nntp/nzb/nzb-0.3.ebuild27
4 files changed, 66 insertions, 0 deletions
diff --git a/net-nntp/nzb/Manifest b/net-nntp/nzb/Manifest
new file mode 100644
index 000000000000..d270810c07cd
--- /dev/null
+++ b/net-nntp/nzb/Manifest
@@ -0,0 +1,2 @@
+DIST nzb-0.2.tar.gz 44351 SHA256 df27606e8e016485a7e9cfb3aa7a2cea9f453d1f26901c02d53731ef0c816497 SHA512 3bfafa8a971a996661e542e72fb63f63530d7efd7e3814a87c3f822764837a151b1c0279bd718a3cafc925d759d8cf338537ba80618014b24a9b836da990f435 WHIRLPOOL 5ce9af8113e97a62e22983dd98cedb2910f4b3789a447c3579a76dc26b84d0647d0749a92632a63db963ee320b0c22859380b83e56018aec0b571d700114d461
+DIST nzb-0.3.tar.gz 47596 SHA256 29811cfc6bd3d972683b33b7410ddfcbfe829269e12894a7b2ab2392b9b2c050 SHA512 f0c7c3d2825a98439848b895074d5a8c66264d90f87b8e988ea21405c4a01546d8fda5024aefbc7c0e6ff7fb45b8f29202516fd20a375c1fc0e999595da95ee3 WHIRLPOOL 8ec6733c089447f502407cde57896f0d2489afa2bd378f4845efb9f5257a4958861f4f037cb9e398409d6ceca9a6bbe2e1fffd8fcb03d1baa2937df1d35102b9
diff --git a/net-nntp/nzb/metadata.xml b/net-nntp/nzb/metadata.xml
new file mode 100644
index 000000000000..3344595f6cf7
--- /dev/null
+++ b/net-nntp/nzb/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>qt</herd>
+ <herd>net-news</herd>
+ <upstream>
+ <remote-id type="sourceforge">nzb</remote-id>
+ <bugs-to>http://sourceforge.net/tracker/?group_id=113793</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/net-nntp/nzb/nzb-0.2.ebuild b/net-nntp/nzb/nzb-0.2.ebuild
new file mode 100644
index 000000000000..879a8b104623
--- /dev/null
+++ b/net-nntp/nzb/nzb-0.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils qt4-r2
+
+DESCRIPTION="A binary news grabber"
+HOMEPAGE="http://www.nzb.fi/"
+SRC_URI="mirror://sourceforge/nzb/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-qt/qtcore:4
+ dev-qt/qtgui:4"
+RDEPEND="${DEPEND}"
+
+DOCS="ChangeLog"
+
+src_install() {
+ qt4-r2_src_install
+ doicon images/nzb.png
+ make_desktop_entry nzb
+}
diff --git a/net-nntp/nzb/nzb-0.3.ebuild b/net-nntp/nzb/nzb-0.3.ebuild
new file mode 100644
index 000000000000..326027447afc
--- /dev/null
+++ b/net-nntp/nzb/nzb-0.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils qt4-r2
+
+DESCRIPTION="A binary news grabber"
+HOMEPAGE="http://www.nzb.fi/"
+SRC_URI="mirror://sourceforge/nzb/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-qt/qtcore:4
+ dev-qt/qtgui:4"
+RDEPEND="${DEPEND}"
+
+DOCS=( ChangeLog )
+
+src_install() {
+ qt4-r2_src_install
+ doicon images/nzb.png
+ make_desktop_entry nzb
+}