summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-04-27 18:35:04 +0200
committerDavid Seifert <soap@gentoo.org>2019-04-27 22:27:54 +0200
commitac9711d1ba3c62defd5560ca827c8959f68386f1 (patch)
treec7ccac7b98a4d5a94e01722988f3aa2a0c0171ee /net-nds/openldap
parentmail-mta/courier: [QA] Fix USE=libressl semantics (diff)
downloadgentoo-ac9711d1ba3c62defd5560ca827c8959f68386f1.tar.gz
gentoo-ac9711d1ba3c62defd5560ca827c8959f68386f1.tar.bz2
gentoo-ac9711d1ba3c62defd5560ca827c8959f68386f1.zip
net-nds/openldap: [QA] Fix USE=libressl semantics
Closes: https://bugs.gentoo.org/684004 Package-Manager: Portage-2.3.64, Repoman-2.3.12 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'net-nds/openldap')
-rw-r--r--net-nds/openldap/openldap-2.4.45-r1.ebuild10
-rw-r--r--net-nds/openldap/openldap-2.4.45.ebuild12
-rw-r--r--net-nds/openldap/openldap-2.4.47-r1.ebuild5
3 files changed, 15 insertions, 12 deletions
diff --git a/net-nds/openldap/openldap-2.4.45-r1.ebuild b/net-nds/openldap/openldap-2.4.45-r1.ebuild
index 7d16acea025a..027f4e6a258c 100644
--- a/net-nds/openldap/openldap-2.4.45-r1.ebuild
+++ b/net-nds/openldap/openldap-2.4.45-r1.ebuild
@@ -29,7 +29,6 @@ IUSE_CONTRIB="${IUSE_CONTRIB} -cxx"
IUSE="${IUSE_DAEMON} ${IUSE_BACKEND} ${IUSE_OVERLAY} ${IUSE_OPTIONAL} ${IUSE_CONTRIB}"
REQUIRED_USE="cxx? ( sasl )
- ?? ( gnutls libressl )
pbkdf2? ( ssl )"
# always list newer first
@@ -45,10 +44,13 @@ CDEPEND="
ssl? (
!gnutls? (
!libressl? ( >=dev-libs/openssl-1.0.1h-r2:0=[${MULTILIB_USEDEP}] )
+ libressl? ( dev-libs/libressl:0=[${MULTILIB_USEDEP}] )
)
- gnutls? ( >=net-libs/gnutls-2.12.23-r6[${MULTILIB_USEDEP}]
- libressl? ( dev-libs/libressl:0=[${MULTILIB_USEDEP}] )
- >=dev-libs/libgcrypt-1.5.3:0[${MULTILIB_USEDEP}] ) )
+ gnutls? (
+ >=net-libs/gnutls-2.12.23-r6:=[${MULTILIB_USEDEP}]
+ >=dev-libs/libgcrypt-1.5.3:0=[${MULTILIB_USEDEP}]
+ )
+ )
sasl? ( dev-libs/cyrus-sasl:= )
!minimal? (
sys-devel/libtool
diff --git a/net-nds/openldap/openldap-2.4.45.ebuild b/net-nds/openldap/openldap-2.4.45.ebuild
index 7f5cd3fc1bd9..afafb6f7063a 100644
--- a/net-nds/openldap/openldap-2.4.45.ebuild
+++ b/net-nds/openldap/openldap-2.4.45.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
@@ -29,7 +29,6 @@ IUSE_CONTRIB="${IUSE_CONTRIB} -cxx"
IUSE="${IUSE_DAEMON} ${IUSE_BACKEND} ${IUSE_OVERLAY} ${IUSE_OPTIONAL} ${IUSE_CONTRIB}"
REQUIRED_USE="cxx? ( sasl )
- ?? ( gnutls libressl )
pbkdf2? ( ssl )"
# always list newer first
@@ -45,10 +44,13 @@ CDEPEND="
ssl? (
!gnutls? (
!libressl? ( >=dev-libs/openssl-1.0.1h-r2:0=[${MULTILIB_USEDEP}] )
+ libressl? ( dev-libs/libressl:0=[${MULTILIB_USEDEP}] )
)
- gnutls? ( >=net-libs/gnutls-2.12.23-r6[${MULTILIB_USEDEP}]
- libressl? ( dev-libs/libressl[${MULTILIB_USEDEP}] )
- >=dev-libs/libgcrypt-1.5.3:0[${MULTILIB_USEDEP}] ) )
+ gnutls? (
+ >=net-libs/gnutls-2.12.23-r6:=[${MULTILIB_USEDEP}]
+ >=dev-libs/libgcrypt-1.5.3:0=[${MULTILIB_USEDEP}]
+ )
+ )
sasl? ( dev-libs/cyrus-sasl:= )
!minimal? (
sys-devel/libtool
diff --git a/net-nds/openldap/openldap-2.4.47-r1.ebuild b/net-nds/openldap/openldap-2.4.47-r1.ebuild
index e63077460b18..5b6b5239e468 100644
--- a/net-nds/openldap/openldap-2.4.47-r1.ebuild
+++ b/net-nds/openldap/openldap-2.4.47-r1.ebuild
@@ -29,7 +29,6 @@ IUSE_CONTRIB="${IUSE_CONTRIB} -cxx"
IUSE="${IUSE_DAEMON} ${IUSE_BACKEND} ${IUSE_OVERLAY} ${IUSE_OPTIONAL} ${IUSE_CONTRIB}"
REQUIRED_USE="cxx? ( sasl )
- ?? ( gnutls libressl )
pbkdf2? ( ssl )
test? ( berkdb )
?? ( test minimal )"
@@ -50,8 +49,8 @@ CDEPEND="
libressl? ( dev-libs/libressl:0=[${MULTILIB_USEDEP}] )
)
gnutls? (
- >=net-libs/gnutls-2.12.23-r6[${MULTILIB_USEDEP}]
- >=dev-libs/libgcrypt-1.5.3:0[${MULTILIB_USEDEP}]
+ >=net-libs/gnutls-2.12.23-r6:=[${MULTILIB_USEDEP}]
+ >=dev-libs/libgcrypt-1.5.3:0=[${MULTILIB_USEDEP}]
)
)
sasl? ( dev-libs/cyrus-sasl:= )