summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-02-23 19:18:44 +0000
committerSam James <sam@gentoo.org>2023-02-23 20:29:11 +0000
commitdf19781d71e94c3ab01b1fd8166b416fdae1fe4f (patch)
tree1d969de9086de11210f312c5e7841cedfc6c5cf3 /net-misc
parentsys-devel/gdb: explicitly disable gprofng build too (diff)
downloadgentoo-df19781d71e94c3ab01b1fd8166b416fdae1fe4f.tar.gz
gentoo-df19781d71e94c3ab01b1fd8166b416fdae1fe4f.tar.bz2
gentoo-df19781d71e94c3ab01b1fd8166b416fdae1fe4f.zip
net-misc/streamlink: add 5.3.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/streamlink/Manifest1
-rw-r--r--net-misc/streamlink/streamlink-5.3.0.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/net-misc/streamlink/Manifest b/net-misc/streamlink/Manifest
index b74fd731c90e..ed41f6d57189 100644
--- a/net-misc/streamlink/Manifest
+++ b/net-misc/streamlink/Manifest
@@ -1,3 +1,4 @@
DIST streamlink-4.3.0.tar.gz 474184 BLAKE2B 557d70105f043fe7454d1c6dd7a49becfd354612df43d09242ec86da5275c7c629f6df887ee7e3a25d9c502e0845f38bece0da2335c5f09951cb4b0aada408a3 SHA512 e1c450d777c00515c07895303dccdece23a8a29b2f9cc272790f5d4b260adbb381845d7ffbc9425e6cee7be41d66158e226d14d08352430bff1c29889b0b0077
DIST streamlink-5.1.2.tar.gz 494342 BLAKE2B f916aab0fcd346e9945de04335309c61cb83c7c5047208a281a87162fb19dae6e45ae861fbc55780049e63bd854f303ee1669d3664a3736debbf8194ee4e6760 SHA512 8fecdc46fc34b37a5a67d15bb4252d1ebab69815398deb533de063fdf7e211d23d413b1b519984dddd2bb5e35296d717dd0504a3578b7bc44c7b123cd70db2a3
DIST streamlink-5.2.1.tar.gz 510860 BLAKE2B eb7f3c85b048d3f274c332f27daafe38a0b495a651101ba2f7c19f13f18a8c691d495f614212dd610e80d0e80c23c695017a212760fe10dd58e00e9d8ac7f95f SHA512 68c02eaee2881f8777eaae3d0b54b0c6aeb0aabf76ab52ac23999895ed0d04a73d817634926869acbf8c092bbe65aadc9637824d56fc439d7445d2ea5f400764
+DIST streamlink-5.3.0.tar.gz 521864 BLAKE2B 2afb7577ba43b73f58d7cd13d217dbaa96f8abea8a10fa495d158c56604ec385e6191df6001f3d969f6aafa3a9aca8a46ab7224af646e2bb404e6098b5261e6a SHA512 7fc18c0604729df358ba396a21e4aa646344d1a1f320ce84831bc13c207a6dd64b2bd6679dc1712483764edd01bd87347d7eca2e3c8d4f6f2113db9c03737343
diff --git a/net-misc/streamlink/streamlink-5.3.0.ebuild b/net-misc/streamlink/streamlink-5.3.0.ebuild
new file mode 100644
index 000000000000..ff7c51d0ed88
--- /dev/null
+++ b/net-misc/streamlink/streamlink-5.3.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/streamlink/${PN}.git"
+ inherit git-r3
+fi
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE='xml(+),threads(+)'
+inherit distutils-r1
+
+DESCRIPTION="CLI for extracting streams from websites to a video player of your choice"
+HOMEPAGE="https://streamlink.github.io/"
+
+if [[ ${PV} != 9999* ]]; then
+ SRC_URI="https://github.com/streamlink/${PN}/releases/download/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD-2 Apache-2.0"
+SLOT="0"
+
+DEPEND="
+ $(python_gen_cond_dep '
+ dev-python/certifi[${PYTHON_USEDEP}]
+ >dev-python/requests-2.21.0[${PYTHON_USEDEP}]
+ dev-python/isodate[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.6.4[${PYTHON_USEDEP}]
+ dev-python/websocket-client[${PYTHON_USEDEP}]
+ dev-python/pycountry[${PYTHON_USEDEP}]
+ >=dev-python/pycryptodome-3.4.3[${PYTHON_USEDEP}]
+ >dev-python/PySocks-1.5.7[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.26.0[${PYTHON_USEDEP}]
+ >=dev-python/versioningit-2.0.0[${PYTHON_USEDEP}]
+ ')
+"
+RDEPEND="${DEPEND}
+ media-video/ffmpeg
+"
+BDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/versioningit-2.0.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ >=dev-python/freezegun-1.0.0[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ )
+ ')"
+
+distutils_enable_tests pytest