summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-11-15 18:44:37 -0500
committerIonen Wolkens <ionen@gentoo.org>2021-11-15 20:25:58 -0500
commit4e814b89568e9ea364a89bf4b607e7758aceea50 (patch)
treea0864a4c94b6b2a57cc09117e1005c3ffb7a5ba1 /net-misc
parentapp-emulation/snapd: Remove old (diff)
downloadgentoo-4e814b89568e9ea364a89bf4b607e7758aceea50.tar.gz
gentoo-4e814b89568e9ea364a89bf4b607e7758aceea50.tar.bz2
gentoo-4e814b89568e9ea364a89bf4b607e7758aceea50.zip
net-misc/yt-dlp: add youtube_dl symlink for python site-packages
Compatibility isn't great but this is enough for packages that do not make a complex use of it, e.g. gpodder can use it and it effectively removes youtube's 50kB/s throttling. Should be better than nothing while waiting for the various upstreams to officially migrate (which already have open issues, users are pushing for it). Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/yt-dlp/yt-dlp-2021.11.10.1-r1.ebuild (renamed from net-misc/yt-dlp/yt-dlp-2021.11.10.1.ebuild)7
1 files changed, 7 insertions, 0 deletions
diff --git a/net-misc/yt-dlp/yt-dlp-2021.11.10.1.ebuild b/net-misc/yt-dlp/yt-dlp-2021.11.10.1-r1.ebuild
index 1aa701367fef..990228a53ee5 100644
--- a/net-misc/yt-dlp/yt-dlp-2021.11.10.1.ebuild
+++ b/net-misc/yt-dlp/yt-dlp-2021.11.10.1-r1.ebuild
@@ -24,6 +24,13 @@ python_test() {
epytest -m 'not download'
}
+python_install() {
+ distutils-r1_python_install
+
+ local sitedir=$(python_get_sitedir)
+ dosym yt_dlp "${sitedir#${EPREFIX}}"/youtube_dl
+}
+
python_install_all() {
dodoc README.md Changelog.md supportedsites.md
doman yt-dlp.1